"+helppageheader+"

PushOK's SmartItems suite.

Reference manual for version 1.1.xx

SmartItems это пакет программ предназначенных для персонального учета различных коллекций: аудио\видео дисков, книг, марок, записок и т.п. Пакет программ включает в себя следующие компоненты:

  • SIWin - основная часть пакета, прдназанчена для создания, редактирования и управления коллекцией
  • SICreator - программа для редактирования типов элементов, используемых в пакете
  • SIPalm - программа просмотра файлов коллекций на PALM совместимых устройствах
  • SIce - программа просмотра файлов коллекций на WinCE совместимых устройствах
  • SIWinViewver - программа просмотра файлоы коллекций на Windows платформе

Основная идея данной программы это создание универсальной системы учета коллекций любых элементов с возможнстью полноценного просмотра и поиска данных на PDA устройствах. Не секрет, что существует великое множество аналогичных программ, однако на наш вгляд все они обладают рядом существенных недостатков, среди них:

  • жесткая специализация - программа работает только с одним классом объектов, например только CD диски, только фильмы и т.п.
  • отсутсвие интеграции с PDA - как правило данный можно только экспортировать в урезанном "плоском" виде, т.е. как тестовый файл или файл электронных таблиц. Для больших коллекций это крайне затрудняет доступ к информации на PDA
  • жесткое фиксирование структуры данных - все программы предоставляют определенный, жестко фиксированный набор атрибутов. Не смотря на то что набор атрибутов очень большой (скажем для CD около 20 полей) все равно может возникнуть необходимость учитвать что то индивидуальное (цвет диска, расположение в лотке и т.п.). Как правило сделать это не возможно. Одноврменно с этим в 80% случаев не нужны все эти 20 полей, а достаточно скажем только имени фильма, или альбома.
  • жесткая структура каталогизации - т.е. заранее определенный набор атрибутов, которые можно присвоить объектам

В пакете программ SmartItems реализован гибкий подход к созданию и ведению коллекций, призванный решить все эти проблемы. В основу программы положена собственная разработка компактной базы данных, с возможностью портирования под PDA платфомы. Основные ее достоинства это максимально мальенкий размер как кода так и данных, и скорость работы. Стоит подчеркнуть что программа просмотра неплохо работает даже на перых PALM. Далее, на основе движка базы данных построена универсальная модель описания данных. Модель предусматривает определенные жесткие правила для объедиенние элементов в паgки (группы), вторичную категоризацию (когда элементы разных типов из разных папок могут быть объеденениы в "виртуальные" группы), систему и правила поиска информации, логику учета должников (кому какие элементы были отданы), экспорт (печать и вывод в HTML) и модификацию данных. Все это представляет универсальную основу для учета элементов коллекций.

Гибкость же системы определяться воможностью редактирования и создания пользовательских классов объектов, что я вляеться основной изюминкой пакета. Изменение\добавление классов объектов проводиться в программе SICreator. С ее помощью можно добавить новые классы объектов, или изменить существующие. Каждый класс объектов представлен набором полей. Для каждого поля нужно определитьт тип поля, и класс оторбражения. Мы надеемся что охватили все разумные классы оторбражения, среди них: тестовое поле, комбобокс, дерево, список, изображение, HTML text, plain text, unique ID. Т.о. даже если в программе нет нужного вам класса объектов мы можете создать его сами, добавим нужные именно вам поля. Важно, что в дальнешем вы сможете осуществлять печать, просмотр (в том числе и на ПДА) и поиск данных для ваших типов, точно также как и для встроенных типов. В программе существут утилиты быстрого импорта данных (CDDB, MP3 tags, file system), они не привязаны к классу обектов, а лишь требуют наличия определенных полей в классе, что опять же оставляет вам свободу выбора дополнительных атрибутов.

Платными компонентами являються только SIWin и SWCreator. Что означает что вы спокойно можете отдать коллекцию на просмтор вашим друзьям. Т.о. мы надемся что SmartItems станет вашим незаменимым и универсальным помощником по управлению коллекциями.


  • Введение
  • Содержание
  • Основы
  • Быстрый старт
  • Просмотр коллекции
    • Режимы просмотра
    • Поиск информации
    • Свойства коллекции
    • На PALM
    • На WinCE
    • На Windows
  • Управление коллекцией
    • Работа с должниками
    • Печать\экспорт в HTML
    • Изменение струкутры данных
  • Интерфейс пользователя
    • SIWin
      • Главное окно программы
      • Модификация\добавление элемента
      • Импорт данных
      • Работа с папками
      • Работа с категориями
      • Работа с должниками
      • Поиск
      • Печать\экспорт в HTML
      • Настройки
    • SICreator
      • Главное окно программы
      • Типы данных и их структура
    • SIConverter
    • SIPalm
    • SIWinViewer / SIce


Для ввода\изменения информации служит программа SI Editor. После ее запуска вам необходимо открыть существующую или созданть новую базу. Для открытия существующей применяеться меню File\Open или File\Recent files или кнопка [image]. Для создания новой базы меню File\New или кнопка [image]. Если вы производили изменения в базе данных, не забудте ее сохранить с помошью меню File\Save или кнопки [image].

Для случая новой базы, следующим вашим шагом должно быть создание структуры каталогов (или создания хотябы одного каталога). Делаеться это в дереве каталогов с помощью контекстного меню. Каждый каталог может содержать предметы только одного типа (класса). В новой базе вам доступны стандартные классы объектов, такие как: CD-DVD диск, CD-audio диск, книга, простой (записки), изображение (марки, фотографии), HTML (красивые описания, кулинарные рецепты). Однако при необходимости вы можете добавить свои классы объектов, или поменять существующие, в том случае если вам не достает стандартных. Делаеться это в программе SI Creator и более подробно описано в другом разделе.

После создания фолдера (обратите внимание что можно указывать для разных фолдеров разные иконки) вы можете добавлять в него данные. При добавлении данных вы можете осуществлять вторичную каталогизацию, использую дерево категорий. Каждый предмет, вне зависимости от его класса, может принадлежать одной или нескольким категориям. При вводе данных о предмете, вы можете использовать ряд стандартных процедур импорта. В данный момент можно автоматически импортировать данные об Audio диске (через CDDB), MP3 диске (по ID3 тагам) и диска с данными (чтение имен файлов и\или директорий). Важно, что данные процедуры импорта не привзяываються к конкретному классу объекта, а лишь требуют наличия определнных полей в данном классе. Т.о. создав производный от CD-audio новый тип данных (добавив нужные вам поля) вы по прежнему сможете пользоваться импортом.

Уже сущестующую базу вы можете просматривать, осуществлять поиск и печатать\экспортировать в HTML. Возможность экспорта в HTML позволит вам быстро разместить информацию о вашей коллекции на вашей персональной страничике. Также готовую базу данных вы можете отдать на просмотр знакомым (так как программы просмотра бесплатны). Просмотр может осущетсвляться на Windows, PALM, Windows CE. Программы просмотра не позволяют изменять данные, но вместе с тем имеют такие же возможности по поиску и фильрации информации. Эта особенность позволяет вам использовать PDA (Palm, Windows CE) для того чтобы: проверить наличие предмета при покупке нового (не секрет что коллекционеры зачастую ошибаюсться, и приобретают несколько дублей одного и тогоже), показать ваши предметы другу (например чтобы не брать с собой дорогие марки, а вместо этого показать их на PDA). Кроме того в системе предусмотрена работа с должниками, которая позволит вам не растерять ваши предметы у ваших друзей. Надеемся что программа окажеться полезной для Вас и для вашей семьи.


  1. Откройте базу данных примера в программе смарт итема. Это можно сделать запустив программу SIWin и открыв там базу home.sib, или же просто кликнув на ее имени в пусковом меню Start\Programs\Pushok Software\Smart Items\Samples\Home stuff database
  2. Добавьте новую папку тип "Book (magazine)" и назовите ее "Example". Иконку оставьте ту, что по-умолчанию. В итоге окно папок у вас должно принять следующий вид:
  3. Выделите папку "Example" и добавьте туда новый элемент. Заполните поля Name, Publisher и Comment значением "Test". Затем нажмите "Add". В окне списка элементов вы увидите следующую запись:

    Счетчик элементов в папке увеличится на 1. Имя созданной вами папки станет: "Example (1)".
  4. Теперь измените значения полей Year, Pages и Ratio с 0 на 2004, 1 и 1 соответственно. В окне списка вы увидите следующие данные:

  5. Теперь добавьте новую категорию с именем "Example". Окно категорий примет вид:

  6. Добавьте, созданный вами элемент папки "Example", к категории "Example". Сохраните изменения в базе данных.
  7. Найдите элементы, принадлежащие к категории "Example".
  8. Найдите все элементы базы (уберите фильтр по категории "Example").
  9. Найдите элемент базы данных с полем Name имеющим значение "Test". Вид окна папок и элементов показан ниже:

  10. Уберите все фильтры и строки поиска.
  11. Добавьте элемент (Sub Item) в элемент, созданный в пункте 3 данного руководства, папки "Example" . Заполните его поля Name, Publisher и Comment значением "Sub Test". А поля Year, Pages и Ratio значениями 2004, 1 и 1 соответственно. Окно папок и элементов примет вид:

  12. Сделайте двойное нажатие на элементе папки "Example". Окно папок и элементов примет вид:

  13. Добавьте созданный элемент к категории "Example".
  14. Чтобы подняться на уровень выше нажмите кнопку
  15. Распечатайте папку "Example" со всеми вложенными папками и элементами в режиме "Large". Результат печати показан ниже:

  16. Распечатайте элемент папки "Example" с полем Name равным "Test". Результат для сравнения показан ниже:

  17. Сохраните базу и выйдите из программы.


Прежде всего, просмотр базы данных (как и ее редактирование) осуществляеться в модуле SIWin. Однако это платная программа, и если вам нужно отдать базу на просмотр другу не имеющуюю ее, он сможет воспользоваться бесплатной программой просмотра на Windows. Кроме того, вы можете также экспортировать базу данных в HTML и передать ее вашему другу в таком виде, или выложить на ваш персональный сайт.


Файл с SmartItems DB (.sib) может быть просмотрен на Windows CE без каких либо изменений с помошью программы SI ce (бесплатная). Однако, поскольку некоторые поля базы данных могут иметь большой размер (и как результат больщой размер базы данных), можно использовать программу SIConverter. Данная программа удаляет большие поля из базы (тем самым уменьшая размер). Для вызова программы служит меню File\Convert DB for PDA.


Использование собственного формата хранения данных позволяет достаточно полноценно просматривать базу данных SmartItems на PALM OS совместимых устройствах. Однако в силу ограничения этой операционной системы такие поля как IMAGE и HTML не могут быть отображены. Это связано как с размером этих полей, так и невозможностью отображения (HTML). Поэтому для подготовки базы данных для PALM используеться программа SIConverter. Данная программа удаляет эти поля из базы (тем самым уменьшая размер) и конвертирует .sib файл в .pdb файл (Palm Data Base). Для вызова программы служит меню File\Convert DB for PDA. Полученный в результате конвертации .pdb файл можно просмотреть на PALM с помощью SI Palm. Программа просмотра бесплатна.


Данные пакета программ хранятся в *.sib файлах. Их организация аналогичено нормальным базам данных, за одним юсключением что она очень упрощена, и хорошо подходит для малопроизводительных систем таким как первые PALM. Каждый такой файл, помимо основых данных, содержит информацию об его свойствах: имя владельца, название и дату последней модификации. Для изменения данных исползуеться показанное ниже окно. Вызов из меню File\Information


Все компоненты системы предназанченые для просмотра или редактирования информации оснащены определенными возможностями по поиску. Существует быстрый поиск по каткгориям и детальный поиск с исползованием строки поиска.

Быстрый поиск по категориям осуществляеться в 'дереве категорий'. В дереве представлены добаленные пользователем категории а также ряд стандартных. Поиск осуществляеться выделением (включением checkbox) категории. При этом будут отображены только элементы, соотвествующие данной категории. Кроме заданных пользовталем присутсвует ряд "стандартных" категорий:

  • New items - 3 категории, позволяющие быстро посмотреть элемента добавленые за последний день, неделю, месяц. Используя их вы легко может ответить своему другу на вопрос "А что у тебя новенького?"
  • Debtors - содержит всех "активных должников", т.е. тех людей который вам что то должны в настоящий момент. Выбор всей группы или отдельного должника позволяет быстро посмотреть какие элементы вы одолжили, т.е. увидеть чего у вас нет в настоязий момент

Детальный поиск это поиск по строке, определенного формата. Строка похожа на WHERE условие SQL, если кто знаком с этим понятием. Для выполнения детального поиска вам необходимо ввести поисковую строку и нажать на кнопку "Search". Чтобы отменить поиск, сотрите строку и снова нажмите конпку "Search". Примером поисковой строки может быть:

  • "name LIKE 'C++'" - найти все элементы содержащие 'C++' в имени
  • "genre = "comedy" AND description LIKE 'funny'" - найти все комедии в описаниях которых встерчаеться слово 'funny'
Т.о. строка поиска это комбинация условий применяемым к полям элементов. Поле идентфицируеться его именем, и может не пристусвовать во всех классах объектов. Поле с именем поля, как и любая константа выступают в качестве _операнда_. Имена полей и операнды не чувствительны к регистру букв. В качестве условий или операции могут применяться следующие ключевые слова:
  • = - сравнение на точное совпадение операндов слева и справа от символа
    Синтаксис:
    (операнд1) = (операнд2)
    Пример:
    Label = Metalica
  • <,>,<=,>= - арифметическое сравнение
    Синтаксис:
    (операнд1) знак (операнд2)
    Пример:
    Ratio >= 4
  • LIKE - проверка значения поля, имя которого указанно слева, на содержание в нем фрагмента данных находящимся с права.
    Синтаксис:
    (операнд1) LIKE (операнд2)
    Пример:
    name LIKE 'C++'
  • IN - поиск совпадения значения поля, имя которого указанно слева, со значением из списка.
    Синтаксис:
    (операнд1) IN (операнд2,[операнд2],..,[операндN])
    Пример:
    Type IN ('DVD','CD')
  • OR - эта команда производит объединение двух условий (логическое ИЛИ ). В результат поиска попадут все записи, которые удовлетворяют любому из условий.
    Синтаксис:
    (операнд1) OR (операнд2)
    Пример:
    Label = Metallica OR Label = Scorpions
  • AND - пересечение двух условий ( логическое И ). В результат поиска попадут только те записи, которые удовлетворяют обоим условиям.
    Синтаксис:
    (операнд1) AND (операнд2)
    Пример:
    Type = CD AND Name = Load
  • NOT или ! - отрицание (инверсия). В данном случае в результат поиска попадут те записи для которых НЕ выполнится заданное условие поиска. Обратите внимание, что допустимо использование двух, идентичных по смыслу, форм записи команды.
    Синтаксис:
    NOT (операнд1) или ! (операнд1)
    Пример:
    NOT (Label = Metallica) или ! (Label = Metallica)

Здесь изложены общие правила поиска, более детально интерфейс ползователя расмотрен для каждой системы отдельно: SIWin, SIPalm, SIce / SIWinViewer,


Во всех компонентах системы существует два основных режима просмотра: нормальнй и плоский. Нормальный режим просмтора аналогичен просмтору файловой структуры, когда программа отображает только содержимое выбранной папки, со всеми возможными подробностями. Т.е. оторбражает все поля помеченные как 'Include in brief'. Это возможно поскольку данные в каждом фолдере однородны, т.е. имеют одинаковый класс.

Однако при поиске информации может оказаться удобным плоский вариант просмотра. В этом случае для элементы отображаеться только поле по умолчанию, и его путь. Т.о. можно объединить просмотр не однородных предметов. В плоском режиме просмотра отображаються предметы их текущей папки и всех вложенных. Кроме того в SIWin модуле существует 'виртуальная' папка 'All items' в которой отображаеються _абсолютно_ все предметы.

Детально способы включения описанных режимов просмотра описаны для каждого модуля отдельно:: SIWin, SIPalm, SIce / SIWinViewer,


Не секрет, что владельцы коллекций не очень любят отдавать в долг свои предметы. Одна из причин, что в результате таких действий предметы просто исчезают. И не потому что кто то специально не отдает предмет, просто оба действующих лица (владелец и должник) забывают об этом. Например один из авторов заметил такую закономерность, его коллекция видео дисков, после того как доросла приблизительно до 100 единиц, упорно не хотела перевалить за этой значение. Т.к. новоприобретаемые диски, компенсировались бесследно пропавшими. Чтобы решить эту проблемму в программе предсмотрена специальная функциональность.

Для работы с должниками существуют пункты меню Data\Give Item, Data\Return Item, Data\Prolong Item либо соответсующими иконками на тулбаре [image]. Однако перед тем как вызывать эти команды, вы должны добавить в папку 'People' информацию о поенциальном должнике. После этого выделив предмет в списке предметов вы можете: 'Give item' - зафиксировать факт передачи предмета, 'Return Item' - зафиксировать факт возврата предмета, 'Prolong Item' - проллить срок возврата. Важно, что если у вас есть должники (т.е. вы фиксировали факт передачи предмета), то для поиска отданных предметов вам будет нужно воспользоваться деревом категорий. Окно, возникающее при регистрации факта передачи предмета представлено ниже:

В этом окне вам предоставляеться возможность указать имя должника, зафиксировать дату передачи, и планируемый срок возврата. По умолчанию дата передачи это текущая дата, срок возврата на неделю позже.


Вызов команды печати (экспорта в HTML) доступен из раличных частей программы и контекстных меню. Однако в любом случае после вызова этой команды вы увидите окно представленное ниже:

Прежде всего в этом окне вы должны указать что именно вы хотите печатать:

  • Current item - будет печататься только один, текущий предмет
  • Current folder - будет печататься только один, выделенный каталог
  • Current category - будет печататься только одна, выделенная категория
  • All folders - будут печататься все предметы с разбивкой по каталогам
  • All categories - будут печататься все предметы с разбивкой по категориям
Обратите внимание что первые три опции могут быть запрещены (не выделены) если в программе не выделен предмет\каталог\категория.

Если вы печатаете более одного предмета то будет доступен комбобокс 'Print Mode'. В нем вы можете указать один из вариантов представления предметов: Large, Medium, Small. Выбор не влияет на представление отдельного предмета, или на колличество предметов, но определяет способ компоновки предметов. Попробуйте каждый из вариантов и выберите подходящий вам.

Кроме того, вы можете указать ряд опций печати:

  • Use filter conditions - если данная галочка устанволена печататься будут _только_ те предметы, которые в данный момент соответсвуют условия поиска. В противном случае печатаються все предметы.
  • Print subfolders/subcategories - Печатать только выделенную папку\категорию, или также ее под папки\категории
  • Print only 'Include in Brief' filds - Устанвока калочки заставляет выводить только часть полей в детальном представленни предмета, помеченных как 'Include in Brief' (поля отображаемые в списке предметов).
  • Prserve control size for images - Установка заставляет выводить изображения в соотвествии с устаноками (размерами) поля. Отсутвие галочки печататет изображения в масштабе 1:1

После выбора всех опция и нажатия 'Ok' вы увидите форму предварительного просмотра (показанную ниже). Если вас удовлетворяет ее содержимое вы можете распечатать ее, либо сохранить в HTML.


Как уже было сказано, одним из преимуществ пакета программ SmartItems является возможность работы с любыми предметами. Достигается это путем возможности создания своих классов предметов или редактирования существующих. Для этих целей в состав пакета програм входит программа SI Creator. Давайте попытаемся разобраться что же за всем этим скрываеться.

Итак, по умолчанию в программе существую класс предметов "Simple Image". В базе данных примера "home.sib" продемонстрирована попытка каталогизации коллекции марок на основе этого типа. Тип включает в себя три поля: название, описание и изображение. Вполне возможно, что настоящему коллекционеру марок хотелось бы учитывать также: год выпуска марки, альбом где она у него хранится и скажем рыночную цену. Если бы SmartItems не предусматривала воможности по редактивроанию классов объектов, то вероятно колекционер марок просто не стал бы пользоваться такой программой (где нет нужных ему полей). Однако в нашем случае совсем не сложно их добавить. Давайте пройдем всю операцию по шагам.

  1. Откройте базу данных примера в программе смарт итема. Это можно сделать запустив программу SI Editor и открыв там базу home.sib, или же просто кликнув на ее имени в пусковом меню Start\Programs\Pushok Software\Smart Items\Samples\Home stuff database
  2. Шелкните на каталоге 'Stamps collection' и предмете 'Flower' чтобы убедиться что действительно предмет имеет только 3 поля.
  3. Выбирите пункт меню File\Go to SI Creator чтобы перейти в программу редактирования классов
  4. Щелкните на типе Simple IMAGE чтобы увидеть его поля. Вы увидите только 3 поля: Name, Details, Image.
  5. Нажмите кнопку 'Append Column'. В нижней панели (редактирования поля) укажите: Field name - 'Year', View Type - 'Edit', Field Type - 'Date Time', Include in Brief - 'On'. Нажмите кнопку 'Apply'.
  6. Нажмите кнопку 'Append Column'. В нижней панели (редактирования поля) укажите: Field name - 'Album', View Type - 'ComboBox', Field Type - 'String', Include in Brief - 'On'. Нажмите кнопку 'Apply'.
  7. Нажмите кнопку 'Append Column'. В нижней панели (редактирования поля) укажите: Field name - 'Price', View Type - 'Edit', Field Type - 'String', Include in Brief - 'On'. Нажмите кнопку 'Apply'.
  8. Сохраните базу
  9. Выбирите пункт меню File\Go to SI Editor чтобы перейти в программу редактирования базы
  10. Шелкните на каталоге 'Stamps collection' и предмете 'Flower' чтобы убедиться что действительно предмет имеет только 3 поля.

Аналогичным способом вы можете изменить другие классы, или создать новые. Важно что внезависимости от изменения структуры данных все части пакета программ SmartItems будут работать с ними правильно.


После запуска программы вы увидете основное окно, представленное ниже. Чем то оно напоминает Windows Explorer. Окно разделяеться на 4 основных части: дерево каталогов, дерево категорий, список предметов, строка поиска и панель просмотра активного предмета. Также, как обычно присутсвуют стандартные элемнты, такие как меню, тулбар и строка состояния.

Список предметов

Список предметов, это панель в правом вехнем углу окна. Как правило она занимает больше всего места на экране, так как наиболее информативан. Панель списка предметов отображает предметы находящиеся в текущем каталоге (каталог можно выбирать в дереве каталогов). Панель отображаеть предметы согласно их классу, и отображет только поля помеченные как "Include in Brief". Основное назначение панели это просмотр предметов и выделение активного предмета. Многие операции в программе требуют наличие такого активного предмета. Щелчок мыши в любом месте панели активизирует конекстное меню, предназанченное для управления предметами. Через него можно добавить/удалить/отдать/вернуть/печатать предмет.

Панель может работать в двух режимах: нормальный и плоский. Переключение выполняеться через меню View\Flat mode или кнопку [image] на тулбаре.

Панель просмотра активного эелемнта

Панель распологаеться в правой нижней части окна, и показыват все поля текущего элемента. Значение полей не возможно изменить в этой панели, так как она случит только для просмотра. Для изменения элемена используйте двойной клик на предмете, или команду из конетекстного меню списка предметов.

Дерево каталогов

Отображает дерево каталогов и случит для выбора/отображения активного каталога. Каталог представляет из себя "физичиеское" месторасположение предметов внутри базы данных. Каждый каталог может содержать предметы _только_ одного класса. Все вложенные подкаталоги должны также содаержать предметы того же класса. Кроме каталогов, которыми полностью управляет полльзователь, существует два стандратных каталога: people и all folders(flat). Последний "аккумулирует" в себе все элементы базы, автоматически включая "flat" режим. Вся работа с деревом фолдеров производиться с помощью контекстного меню и описана отдельно

Дерево категорий

Отображает дерево категорий, служащее для вторичной "вирутальной" каталогизации элементов. Если физически элементы разных классов обязаны находиться в разных каталогах, то одновремнно с этим логически они могут принадлежать одной и тойже категории. Это позволяет например виртуально объединять одинаковые классы объектов (видео фильмы) находящиеся физически на рахныз носителях. Вся работа с деревом категорий производиться с помощью контекстного меню и описана отдельно

Строка поиска

Служит для расширенного поиска объектов. Смотрите детальное описание


Окно модификации служит для изменения информации о предмете. Окно появляеться в случае добавления нового предмета, или изменения существующего. Добавление доступно из главного меню Data\Add Item или Data\Add Sub Item, контекстного меню списка предметов, либо при нажатии кнопки [image] на тулбаре. Внешний вид окна представлен ниже.

В левой части окна представлено дерево категорий. Оно служит для того, чтобы устновкой чекбоксов рядом с именем категорий, указать к каким категориям относиться данный предмет. Обратите внимание, что для дерева доступно контекстное меню, работающее точно также как и в главном окне. Это позволяет создать/удалить необходимы категории сразу по ходу ввода данных.

Остальную часть окна занимают элементы отображения полей данных предмета. Состав полей, их размер, размещение зависит от конкретного класса предмета. Смотрите детальное опиание элементов управления. Кроме этого в окне предусмотрена возможность печати текущего элемента (кнопка Print) и импорта данных (кнопка Import). Импорт данных применяется для определенных известных предметов: CD диски, MP3 Диски, диски с данными.


    В программе SIWin существует три типа импорта данных:
  • Импорт из музыкального диска с поиском информации о треках в CDDB
  • Импорт данных с дисков MP3
  • Импорт данных из файловой системы

Импорт с музыкальных дисков

Вы должны указать CD-Rom, в котором находится диск. Если музыкальный диск не будет найден или вы укажете пустой привод, то вы увидите сообщение об ошибке. После выбора жмите кнопку "Search". Учтите, что для получения информации о диске вы должны быть подключены к сети Internet. В противном случае вы ее не получите. После того, как все данные о диске будут получены, вы сможете просмотреть их и выбрать то, что вам больше подходит. Об одном диске может быть более одного описания. Чтобы добавить в базу нажмите "Add CD to base".

Импорт с дисков MP3

Вы должны указать CD-Rom, в котором находится диск. Если вы укажете пустой привод, то будет выдано сообщение об ошибке. После выбора жмите кнопку "Search". Будет построено дерево из треков на диске. Если вы хотите, чтобы также были отражены папки, в которых находятся песни, то поставьте соответствующую галочку ("Use folders"). Чтобы добавить в базу нажмите "Add CD to base".

Импорт из файловой системы

Вы должны указать папку, из которой хотите импортировать данные. При этом вы можете импортировать только имена подпапок исключая при этом имена файлов. Для этого поставьте галочку "Use only folders". Иначе вместе с именами подпапок будут добавлены и имена файлов содержащихся в выбранной папке. Чтобы добавить в базу нажмите "Add data to base".

Помните! Вы не сможете добавить данные, если в выбранной вами папке не будет необходимых полей. Если вы попытаетесь импортировать данные в поля, которых не существует, то получите сообщение об этом. Запомните или перепишите информацию о необходимых полях и создайте их в SICreator.


Дерево каталогов располагаеться в левом верхнем углу главного окна программы. Каталог это физическое месторасположение предметов внутри базы данных. Каждый каталог содержит элементы _только_ одного класса и может содержать под каталоги с элементами того же класса. Каждый каталог характеризуеться именем и ассоцированной с ним иконкой. Иконка каталога ассоцируеться также со всеми предметами этого каталога. Управление каталогами осуществляеться с помощью контектсного меню, вызываемого нажатием правой кнопки мыши. При нажатии правой кнопки мыши на определенном каталоге доступны все команды контестного меню, в пустом месте дерева каталогов только часть. Дерево каталогов в открытым контекстным меню представлено ниже.

Команда New предназанчена для создания нового каталога или подкаталога. Если меню было вызвано на пустом месте, то будет создан корневой каталог. Если на одном из существующих каталогов, то подкаталог. При создании корневого каталога программа попросит указат класс предметов, которые планируеться хранить в данном каталоге:

В новой базе вам доступны стандартные классы объектов, такие как: CD-DVD диск, CD-audio диск, книга, простой (записки), изображение (марки, фотографии), HTML (красивые описания, кулинарные рецепты). Однако при необходимости вы можете добавить свои классы объектов, или поменять существующие, в том случае если вам не достает стандартных. Делаеться это в программе SI Creator и более подробно описано в другом разделе.

После указания класса объектов возникает диалоговое окно выбора имени каталога и иконки. Этоже диалоговое окно возникает при выполнении команды 'Rename'. В нем вам нужно указать имя папки и выбрать иконку.

Выбор команды 'Delete' приведет к удалению каталога со всеми подкаталогами и предметами. Будте осторожны с этой командой. Хотя если вы ошиблись просто не сохраняйте "плохую" базу данных. Команда печати вызывает окно печати\экспорта в HTML.


Дерево категорий располагаеться в левом нижнем углу главного окна программы. Категория выражает любой атрибут который может быть присущь объекту. Кроме того категория может содержать несколько под категорий. Любой предмет, внезависисмости от того в каком каталоге он распологаеться может принадлежать к нескольким категориям. Хороший пример это классификация видео фильмов. Видеофильмы могут распространяться на разных носителях: видеокасеты, CD диски, DVD диски. Все это предметы разного класса, и они должны могут располагаться в разных каталогах. Происходит это потому что они имеет разные атрибуты, например для видеокасеты может быть важен атрибут длинна (180 минут, 240) тогда как для CD диска такого атрибута нет. Безусловно ничто не мешает "проигнорировать" эти различия и поместить и видеокасеты и CD диски в один каталог, но, наверное это не очент здорово.

Так вот, мы пришли к выводу что видеокасеты и Video CD располагаються в разных папках. Однако несмотря на это и в том и в другом случае видеофильму присущб жанр, и собственно атрибут что это видеофильм. Так вот, если мы создадим категорию Video, и подкатегории Comedy, Triller, Action... мы можем виртуально "объеденить" разные классы объектов под одной и той же категорией. В дальнейшем подобное объединение позволит к примеру быстро найти или распечатать все ваши комедии, или видеофильмы, или драммы.

Кроме пользовательских категорий, окно категорий содержит две стандартные группы категорий: должники (если таковые есть), и новинки. Это категории которые существуют сами по себе, т.е. не требуют их создания. Категория должники позволяет быстро отфильтровать (показать) предметы которые у вас одолжили. Новинки, быстро посмотреть недавно добаленные элементы за день, неделю или месяц. Напомним, что этим возможности поиска не ограничиваються.

На рисунке представленном выше показано дерево категорий и вызванное нажатием правой кнопкой мыши контекстное меню. Меню содержит стандартные действия не требующие особого пояснения: создание новой категории (суб категории если клик был сделан на существующей категории), удаление, переименование и печать\экспорт в HTML


Для поиска предметов используеться дерево категорий и строка поиска. Смотрите детальное описание общих возможностей по поиску. Ниже показана строка поиска в программе SIWin.

Кнопка 'Search' служит для запкуска процедур поиска. 'Clear' сбрасывает текущее условие поиска и эквивалентна очистке строки поиска и нажатия на кнопку 'Search'. Сама по себе строка поиска представлена комбобоксом, и раскрыв его вы увидите предыдущие вводимые вами строки поиска.

Отдельно рассмотрим кнопку 'ID?'. Как вы можете узнать в описании программы SI Creator возможно для класса (типа объектов) указать что используеться 'unique id'. Т.е. некое поле, в котором храниться уникальный идентификатор предмета. Это может быть серийный номер диска, штрихкод на книге или другая инфрмация позволяющая однозначно идентифицировать предмет. Идея по созданию такого поля основываеться на том, что при вводе больших коллекций может возникнуть проблема когда вы не знаете занесли вы определенный предмет в базу данных или нет. Конечно, можно использовать строку поиска по вторичным атрибутам (имя, название и т.п.), однако это может отнять много времени. Поэтому и предусмотрено данное поле. Нажав кнопку 'ID?' вы увидите диалоговое окно ввода уникального идентификатора (показано ниже). В случае если речь идет о диске (CD-data, CD-audio, DVD) окно позволит считать с него уникальный идентификатор автоматически. Однако если речь идет о чем то другом, то идентификатор придеться ввести вручную (например штрих код). После того, как вы тем или иным способом введет уникальный идентификатор строка поиска будет сформирована автоматически и запущен поиск. Т.о. кнопка 'ID?' предназаначена для того чтобы быстро проверить наличие предмета в коллекции.


Для настройки определенных сервисных функций программы используеться окно опций, показанное ниже. Вызов опций осуществляеться из меню View\Options

    Доступны следующие опции
  • Create backup copy on exit
    Создать резервную копию файла при выходе (.bak). Включена по умолчанию. Рекомендуеться использовать для возможности отката при неправильных действиях.
  • Enable auto save
    Автоматичекси сохранять базу данных через заданный интервал времени. Может применяться для того, чтобы не потерять сделанные вами изменения в случае сбоя компьютера
  • Save on exit
    Автоматичекси сохранять базу при выходе из программы. Если опция не включена, программа спросит вас сохранить базу или нет
  • Language
    Язык интерфейса программы


Данная программа применяеться для изменения структуры базы данных Smart Items. Более точно для редактировани и изменения состава классов (предметов). Основное окно программы показано ниже.

Левая панель программы содержит список имеющихся в базе данных типов предметов. Вызвав конеткстное меню нажатием правой кнопки мыши вы сможете добавить, удалить или сделать копию существующего типа предметов.

Правая верхняя панель содержит список полей, выделелного в списке предметов типа объектов. Каждое поле характеризуеться его именем, типом данных и способом представления. Имя поля, это строка, которая в последующем будет идентифицировать это поле. Тип данных и способ представления определяет что храниться в этом поле и как оно будет отображаться. Более детально возможные типы данных и отображаения описаны в данном разделе. Кроме того, любое поле может быт помечено как 'Inlude in brief'. Что означает что поле будет отображаться в кратком списке предметов. Одно из полей может быть помечено как 'default', или поле по умолчанию. В качестве 'default' поля следуюет выбирать поле наиболее полно характеризующее предмет: название фильма, название CD альбома и т.п. Дефаулт поле будет оторжаться в плоском режиме просмотра и в других случаях когда не возможно отобразить сведения о предмете более детально. С помощью кнопок управления находяшимся рядом со списком полей вы можете: менять порядок следования полей (при отображении), добавлять и удалять поля, выбирать 'default' поле. Галочка 'use unique id' указывает пристусвует ли в выбранном типе данных поле 'uniqueid'. Поле предназанчено для быстрой идентификации предмета.

Нижняя левая панель содержит детальную информацию о выбранном в спике полей поле. В этой панели вы можете изменить название поля, типа данных и вид представления. Кроме того вы можете настроить ряд параметров определяющих способ отображения поля (как правило это размер, название колонок и т.п.). Левая панель программы содержит список имеющихся в базе данных типов предметов. Вызвав конеткстное меню нажатием правой кнопки мыши вы сможете добавить, удалить или сделать копию существующего типа предметов. Более детально возможные типы данных и отображаения описаны в данном разделе. Изменения параметров поля будут приняты только после нажатия кнопки 'Apply'.

Возможности по созданию, открытию и сохранению баз данных схожи с программой SI Editor. Отметим также, что обе программы (SI Editor, SI Creator) имеют парные пункты меню, File\Go to SI Creator и File\Go to SI Editor соответсвенно. Используя эти команды меню вы можете быстро переключаться из одной программы в другую, при этом работая с той же самой базой в обоих системах.


View types

Name: Appearance: Possible data type: Description: Format:
Checkbox
  • Unsigned Numeric
Этот контрол может вам понадобиться, когда поле будет принимать значение "Да" или "Нет". Например, свойство предмета "Старость". Вы можете указать старые предмет, установив галочку в поле, или новый сняв выделение, или не делая его совсем.
  • width - ширина контрола при отображении
Combobox
  • Signed Numeric
  • Unsigned Numeric
  • String
Этот контрол предназначен для отображения уникальных данных для группы однотипных элементов. Например, видео кассеты, где это поле может быть использовано для показа длины пленки. При загрузке, в выпадающий список будут загружены все возможные значения внутри выделенной таблицы и вы сможете выбрать необходимое для добавляемого элемента или добавить новое. Вам не надо будет вписывать каждый раз новое значение, достаточно выбрать из списка уже существующее.
  • width - ширина контрола при отображении
Edit
  • Signed Numeric
  • Unsigned Numeric
  • String
  • DateTime
Контрол является достаточно универсальным и может отображать данные различных типов. В поле данного типа вы можете хранить, например, цвет объекта, его какие-то особые описания, например, размеры и т.п.
  • width - ширина контрола при отображении
HTML
  • String
Данный контрол служит для отображения текста HTML, вы можете форматировать текст, добавлять картинки. Текущий тип может вам понадобиться для объемного описания свойств элемента или его характеристик. Его главное отличие от Memo - форматированный текст и картинки.
  • width - ширина контрола при отображении
  • bwidth - ширина кнопки "Modify" при отображении
  • height - высота контрола при отображении
  • binfield - имя бинарного поля, в котором хранятся изображения добавленные в контрол
Image
  • BLOB
Данный контрол предназначен только для хранения изображений. Вы можете выкладывать в него обложки музыкальных дисков, марки, титульные листы журналов и т.п.
  • width - ширина контрола при отображении
  • height - высота контрола при отображении
ListViewEx
  • String
Данный контрол может понадобиться в том случае, когда вам необходимо внести таблицу данных. Вы можете создать нужный вид таблицы в SICreator, а затем использовать его в своих целях.
  • width - ширина контрола при отображении
  • height - высота контрола при отображении
  • [column name,width] - список столбцов в контроле, с указанием их имен и ширины. В котроле должен быть как минимум один столбец! Имя и ширина должны быть указаны через запятую!
Memo
  • String
Этот контрол предназначен для хранения длинных записей. В отличие от HTML, он не позволяет добавлять картинки и форматировать текст, но при этом занимает меньше места в базе, т.к. хранит только набранный вами текст.
  • width - ширина контрола при отображении
  • height - высота контрола при отображении
Tree
  • String
Этот контрол может понадобиться вам, когда вам надо будет хранить данные в виде дерева. Элементы с подэлементами, простой пример - файловая система.
  • width - ширина контрола при отображении
  • height - высота контрола при отображении


Запуск программы.

При запуске программы SIPalm сканирует ваш Palm в поисках баз данных своего формата, при этом, что бы вы не скучали, на экран выводится заставка(Рис.1.1).

Если SIPalm не смог найти подходящих БД, то вы увидите сообщение о загрузочной ошибке(Рис.1.2). Для её исправления нужно всего лишь загрузть на ваш Palm БД формата Smart Items, предварительно конвертированную в Palm формат с помощью прилагаемой утилиты SIConverter.

Рис.1.1 Заставка. | Рис.1.2 Ошибка открытия базы данных. | Рис.1.3 Стартовая форма.

Cтартовая форма.

Если же на ваш Palm уже загруженна БД формата Smart Items ( хотя бы одна ), тогда вы увидите Стартовую форму(Рис.1.3).

На этой форме, с помощью комбобокса вы можете выбрать, для просмотра, одну из найденных баз данных ( если их несколько ). Сразу же после этого на форме будет отображена информация о выбранной базе данных - название БД, автор БД, количество записей БД и дата последнего редактирования БД.

После того как вы определились с Тем какую БД вы хотели бы посмотреть, можно переходить к следующим формам. Со Стартовой формы доступны две формы - Форма фильтра и форма Браузера.

Рис.2.1 Вид дерева категорий. | Рис.2.2 Поиск записей. | Рис.2.3 Окончание поиска.

Форма фильтра.

Эта форма нужна для поиска и фильтрации записей по какому либо признаку или условию, ассортимент инструментов для этого достаточно широк. Есть возможности поиска записей сделанных за последние день, неделю или месяц. Можно найти записи относящиеся к определенным категориям. Общий вид формы виден на рисунке (Рис.2.1).

И что самое интересное, вы можете посмотреть кому, что и когда вы одолжили. Список должников появляется автоматически в папке Должники ( если они конечно есть, но если вы счастливчик и вам ни кто ни чего не должен, то эта папка даже не появится ).

Так же есть строка для более сложного поиска. Она работает помедленнее, зато в ней вы можете создать запросы которые невозможно создать с помощью дерева категорий.

В низу формы есть три кнопки. Home - возврат на стартовую форму. Apply - установить фильтр с заданными параметрами. Учтите, что условия внутри дерева категорий складываются ( логическое ИЛИ ), а условия дерева категорий и командной строки пересекаются ( логическое И ). После нажатия этой кнопки, она автоматически заменяется на Reverse. Reverse -нажатие на эту кнопку приведет к отмене фильтра, при этом кнопка вернется в состояние Apply. Возврат в состояние Apply, произойдет так же и при изменении параметров фильтра. Browse - перейти на форму браузера.

Основную часть формы занимает дерево категорий. Сворачивая и разворачивая ветви вы можете устанавливать и снимать галочки с категорий, тем самым готовить запрос для поиска по базе данных.

При установке (снятии) галочки на категории автоматически устанавливается (снимается) галочки на всех вложенных в нее категориях. После нажатия кнопки Apply SIPalm осуществит поиск по всем категориям отмеченным в дереве категорий.

В дереве категорий есть две постоянные папки Debtors и New.

Папка Debtors появляется только в том случае, если на данный момент есть личности которые еще не вернули вам вашу собственность. Вы можете просто просмотреть список должников или выбрать интересующего должника (нескольких) и просмотреть что именно вы им отдали.

Папка New есть всегда, в ней содержится три категории Day, Week и Month. Выбрав одну из этих категорий вы сможете посмотреть что вы приобрели за последние сутки, неделю или месяц, соответственно. Более сложные поиски с датами можно будет осуществить в командной строке.

Все остальные категории не обязательны и вы можете сами их создавать и удалять по своему усмотрению ( с помощью SIWin ). Поиск по категориям будет осуществляться только в том случае, если своим Айтемам вы не забудете установите принадлежность к необходимым категориям.

Более сложным и медленным инструментом, но дающим больше возможностей поиска является командная строка. Она находится не посредственно над деревом категорий.

После того как вы зададите параметры фильтра ( с помощью дерева категорий или командной строки, или и того и другого ) и нажмете кнопку Apply SIPalm начнет поиск по вашему запросу, для подтверждения этого будут показаны песочные часы (Рис.2.2). После завершения поиска появится сообщение (Рис.2.3), в котором будет указанно количество найденных записей. Для того чтобы просмотреть найденные записи, необходимо закрыть диалог и на форме поиска нажать кнопку Browse. Вы перейдете в форму браузера, но доступны вам будут только найденные записи.

Рис.3.1 Вид формы броузера. | Рис.3.2 Вид формы информации.

Форма браузера.

Эта форма отвечает за отображение найденных записей (или всех записей если фильтр не установлен). При открытии формы вы видите список папок находящихся в корне дерева папок (Рис. 3.1). Отличительной особенностью папок является, то что перед названием папки в скобках указанно количество записей хранящихся в этой папке (а если фильтр наложен, то количество записей удовлетворяющих условию фильтра).

Может быть такой вариант: вы применили фильтр, он вам показал, что нашел какие то записи удовлетворяющие условиям, но при переходе в Вроузер вы видите только папки с нулями. Не пугайтесь, все нормально, просто в тех папках которые вы видите действительно нет записей удовлетворяющих условиям, но в них находятся вложенные папки в которых вы и найдете искомые записи.

Каждая запись представляется значением поля, которое было указанно как поле по умолчанию. Поэтому к указанию поля по умолчанию нужно отнестись со всей серьезностью. Если вы выберете, не очень удачное поле по умолчанию, то при просмотре БД могут возникнуть трудности с распознаванием записей и вам придется для каждой записи просматривать всю информацию, что очень медленно и не очень удобно.

Для того чтобы перейти внутрь заинтересовавшей вас папки достаточно одиночного клика на ней. Для возврата на уровень в верх одиночный клик на верхней строке с обозначением "..".

На форме есть три управляющие кнопки - Home, Filter и Flat/ Foldеrs.

Кнопка Home - дает возможность вернуться на стартовую форму и при желании выбрать другую БД для просмотра.

Кнопка Filter - позволяет перейти на форму фильтра для изменения параметров фильтра или просто отключения фильтра.

Кнопка Flat/ Foldеrs - позволяет переходить в режим просмотра записей без учета каталогов (и возвращаться из него), это является исключительной изюминкой наших просмотрщиков. Режим Flat позволяет существенно упростить поиск какой то записи или просто просмотр всего что есть в БД, если у вас очень разветвленная система каталогов, а вы не помните точно где разместили необходимые вам данные. В режиме Flat вы увидите все записи БД в одном списке. При большой БД это может быть не очень удобно, тогда вы можете попробовать наложить фильтр для уменьшения видимых записей и вернуться к просмотру.

Форма просмотра параметров айтема.

Эта форма самая простая и появляется при однократном клике на заинтересовавшей вас записи в форме браузера. На форме выводится вся информация о данной записи, даже дата и время создания этой записи (Рис. 3.2).

Необходимо только помнить, что при конвертации БД в Palm формат из нее удалятся те поля, которые не могут быть нормально отображенны на Palm. Такими полями являются - Мемо, ЛистВью, Картинки и HTML.

Имена полей выделены точками, для лучшего различения с данными этих полей.

Если вся выводимая информация не умещаются на экране Палма, то используя появляющиеся в уголках стрелки вверх или вниз можно просмотреть все что скрыто от вашего взора.

По окончанию изучения данных нажмите кнопку ОК для возврата в форму Браузера.


Программы для просмотра базы под WinCE и Windows имеют сходный интерфейс. Поэтому описание ниже будет приводиться с использованием интерфейса SIWinViewer. В данных программах вы можете работать и эксперементировать совершенно спокойно, они только отображают данные. Испортить базу вы не сможете.

Запуск программы

После запуска программы вы увидите окно показанное ниже. При нажатии на пункты меню без загруженной в программу базы будут выдаваться сообщения об ошибке. После открытия базы вы попадете сразу в раздел "Папки". Чтобы открыть базу выберите пункт меню "Base\Open". Чтобы работать в WinCE вы должны закачать в PDA базу.

Раздел "Folders"

Чтобы попасть в этот раздел нужно кликнуть на меню "Folders". В данном окне отображаются все папки в базе. Чтобы увидеть содержимое папки достаточно одного клика на ней. Если вы выделили папку, то можете перемещаться по базе, это выделение сохраняется, пока вы не выберете другую папку. Если вы находитесь в другом разделе и забыли какая папка у вас выделена, то нажмите на пункте меню "Folders" вы увидите, что выбранная вами папка подсвечена. Цифры в скобках - количество элементов в папке. При поиске и наложении фильтра это число может изменяться в зависимости от найденных элементов.

(Folders)

Раздел "Records"

Чтобы попасть в это окно вам надо нажать на меню "Records". Если вы не увидели записей, то либо выделенная папка их не содержит, либо вы не выделили папку. Элементы делятся на простые и составные. Составные содержат элементы внутри себя. Поэтому когда вы выбираете для просмотра составной элемент вам предлагается выбор: смотреть его данные или его элементы. Если самым верхним элементом является запись "..", то значит вы находитесь внутри итема. Чтобы выйти, нажмите на нее. Если вы хотите просмотреть поля элемента, то если он составной выберите "View item", если простой, то сразу попадете в диалог показа данных. В этот диалог (Item data) можно попасть только из записей.

(Records)

(Item data)

Раздел "Search"

Чтобы попасть в это окно вам надо нажать на меню "Search". Здесь вам предоставляется возможность поиска по категориям или по строке, вы также можете объединять эти две возможности. Для того, чтобы фильтр (поиск) заработал после всех изменений нажмите "Apply". После этого вы попадете в "Records", где будут показаны найденные записи. Если их нет, значит они были отсеяны фильтром. При этом из раздела "Folders" могут пропасть некоторые папки целиком, это значит, что в них не нашлись элементы подходящие под запрос.

(Search)


После запуска программы вы увидете основное окно, представленное ниже.

    С помощью данной программы вы можете конвертировать существующую базу под две платформы:
  • Palm
  • WinCE
В большинстве случаев конвертировать под платформу WinCE нет необходимости, это следует делать, если у вас слабенький наладонник и вы хотите уменьшить размер базы. Под Palm конвертировать данные надо потому, что в этой системе присутствуют не все элементы для корректного отображения данных.

Для конвертации вы должны выбрать базу, которую хотите преобразовать (Input file). Затем выберите имя, под которым будете сохранять конвертированную базу(Output file). Выберите платформу, под которую хотите конвертировать, и жмите "Convert".

Учтите, что если вы будете конвертировать базу под WinCE и при этом укажете то же имя и путь, что и у исходной базы данных, то при конвертации исходная база будет утеряна, перезаписана. Так как для баз под WinCE используется то же расширение файлов, что и для Windows. Во избежание подобных случаев не указывайте для новых баз имена, совпадающие с оригинальными или сохраняйте сокращенные базы в других папках.