Main Page

VideoSurveillanceSystem Documentation

Version_0100

Generated on Tue Dec 25 18:25:55 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


File Index

VideoSurveillanceSystem File List

Here is a list of all documented files with brief descriptions:
2DStruct.h |
Advisers.h | Advisers classes
ChannelDisplay.h | CChannelDisplay class
ChannelSwitcher.h | CChannelSwitcher class
ChannelSwitcherPropPage.h | CChannelSwitcherPropPage class
CloneObjectImpl.h | Clone support
DragDropSupport.h | Drag and drop support
ErrorHandlers.h | Header for simple error handle support
Lockers.h | Header for simple lock support
StreamHelpers.h | Stream support classes and functions
TemplateHelpers.h | Template classes and functions for programming helping
VideoSurvDll.idl |
Generated on Tue Dec 25 18:25:55 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


2DStruct.h File Reference

#include <math.h>

Compounds

class | CPoint
Point object. More...

class | CSize
Size object (see windows SIZE). More...

class | CRect
Rectangle object. More...

class | CCircle
Circle object. More...

Defines

#define | Round(f) (int)( (f) >= 0 ? (f) + .5 : (f) - .5 )
Round float value.

Functions

double | Distance (POINT &a, POINT &b)
Distance betwen two points.

void | NormalizeDbl (double &f, int nMaxPrec=2)
Round up value with pointed precision.

Detailed Description

Header for simple 2d math structs

Generated on Tue Dec 25 18:25:55 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Advisers.h File Reference

Advisers classes. More...

#include "DateTime.h"
#include "StructSupport.h"

Compounds

class | CSingleAdvisor
Advise to single object. More...

class | CMultiAdvisor
Advise to multile objects. More...

class | CLocAdvisor
Advise to localization manager. More...

class | CLocHelper
class uses as helper while loading strings. More...

class | CLogHelper
class used as helper to acces for log manager. More...

class | CSecurityHelper
class used as helper to security manager. More...

Detailed Description

Advisers classes.

Generated on Tue Dec 25 18:25:55 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


ChannelDisplay.h File Reference

CChannelDisplay class. More...

#include "resource.h"
#include <atlwin.h>
#include "Advisers.h"
#include "ChannelObjectHelpers.h"
#include "StructureLevelClasses.h"
#include "VideoSurvCP.h"

Compounds

class CChannelDisplay
CChannelDisplay class. More...

Detailed Description

CChannelDisplay class.

Generated on Tue Dec 25 18:25:55 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


ChannelSwitcher.h File Reference

CChannelSwitcher class. More...

#include "resource.h"
#include <atlwin.h>
#include "Advisers.h"
#include "ChannelObjectHelpers.h"
#include "VideoSurvCP.h"
#include "ChannelObjectsCP.h"

Compounds

class CChannelSwitcher
CChannelSwitcher class. More...

Detailed Description

CChannelSwitcher class.

Generated on Tue Dec 25 18:25:55 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


ChannelSwitcherPropPage.h File Reference

CChannelSwitcherPropPage class. More...

#include "resource.h"
#include "BasePropertyPage.h"

Compounds

class CChannelSwitcherPropPage
CChannelSwitcherPropPage class. More...

Detailed Description

CChannelSwitcherPropPage class.

Generated on Tue Dec 25 18:25:55 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


CloneObjectImpl.h File Reference

Clone support. More...

Compounds

class ICloneObjectImpl

Detailed Description

Clone support.

Generated on Tue Dec 25 18:25:55 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


DragDropSupport.h File Reference

Drag and drop support. More...

Compounds

class | IDataObjectMinImpl
base class for data object with minimal support. More...

Defines

#define | IDATAOBJECTMINIMPL_ENTRIES COM_INTERFACE_ENTRY(IDataObject) \
COM MAP entries.

Detailed Description

Drag and drop support.

Generated on Tue Dec 25 18:25:55 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


ErrorHandlers.h File Reference

Header for simple error handle support. More...

Defines

#define | TRACE TraceX
trace formated string to debug output.

#define | _Verify(b) { if ( ! ( b ) ) ATLASSERT( FALSE ); }
in case b fails only show debug warning.

#define | _ComVerify(hr) { if ( FAILED( hr ) ) ATLASSERT( FALSE ); }
perform COM call and if it failed only show debug warning.

#define | _VerifyRX(b, ret) { if ( ! ( b ) ) { ATLASSERT( FALSE ); return ret; } }
in case b fails show debug warning and return ret.

#define | _ComVerifyRX(hr, ret) { if ( FAILED( hr ) ) { ATLASSERT( FALSE ); return ret; } }
perform COM call and if it failed show debug warning and return ret.

#define | _CallRX(b, ret) { if ( ! ( b ) ) return ret; }
perform call and return ret if failed.

#define | _ComCallRX(hr, ret) { if ( FAILED( hr ) ) return ret; }
perform call and return ret if failed.

#define | _VerifyRV(b) { if ( ! ( b ) ) { ATLASSERT( FALSE ); return; } }
in case b fails show debug warning and return.

#define | _ComVerifyRV(hr) { if ( FAILED( hr ) ) { ATLASSERT( FALSE ); return; } }
perform COM call and if it failed show debug warning and return.

#define | _CallRV(b) { if ( ! ( b ) ) return; }
perform call and return if failed.

#define | _ComCallRV(hr) { if ( FAILED( hr ) ) return; }
perform call and return if failed.

#define | _VerifyES(b) { if ( ! ( b ) ) { ATLASSERT( FALSE ); throw AtlReportError( CLSID_NULL, ( std::string( "File " ) + __FILE__ + "\nLine " + itoa( __LINE__, __ERRORLINE__, 4 ) + "\n" + GetErrorDescription() ).c_str(), IID_NULL, NULL ); } }
perform call and if it failed explain line of code and file where error happens.

#define | _VerifyRS(b) { if ( ! ( b ) ) { ATLASSERT( FALSE ); return AtlReportError( CLSID_NULL, ( std::string( "File " ) + __FILE__ + "\nLine " + itoa( __LINE__, __ERRORLINE__, 4 ) + "\n" + GetErrorDescription() ).c_str(), IID_NULL, NULL ); } }
perform call and if it failed explain line of code and file where error happens.

#define | _CallES(b, er) { if ( ! ( b ) ) { throw AtlReportError( CLSID_NULL, (std::string(er)+"\n"+GetErrorDescription()).c_str(), IID_NULL, NULL ); } }
perform call and throw specified error item and COM error description.

#define | _CallRS(b, er) { if ( ! ( b ) ) { return AtlReportError( CLSID_NULL, (std::string(er)+"\n"+GetErrorDescription()).c_str(), IID_NULL, NULL ); } }
perform call and return specified error item and COM error description.

#define | _ComCallES(hr, er) { if ( FAILED( hr ) ) { throw AtlReportError( CLSID_NULL, (std::string(er)+"\n"+GetErrorDescription()).c_str(), IID_NULL, NULL ); } }
perform com call and throw specified error item and COM error description.

#define | _ComVerifyES(hr) { if ( FAILED( hr ) ) { ATLASSERT( FALSE ); throw AtlReportError( CLSID_NULL, ( std::string( "File " ) + __FILE__ + "\nLine " + itoa( __LINE__, __ERRORLINE__, 4 ) + "\n" + GetErrorDescription() ).c_str(), IID_NULL, NULL ); } }
perform COM call and if it failed explain line of code and file where error happens.

#define | _ComCallRS(hr, er) { if ( FAILED( hr ) ) { return AtlReportError( CLSID_NULL, (std::string(er)+"\n"+GetErrorDescription()).c_str(), IID_NULL, NULL ); } }
perform com call and return specified error item and COM error description.

#define | _ComCallRH(HR) { HRESULT hr = HR; if ( FAILED( hr ) ) { return hr; } }
Simply return error if call failed.

Functions

std::string | GetLastErrorStr (DWORD dwErrorCode=-1)
Get error string from error code.

std::string | GetErrorDescriptionStr (IUnknown *pI, REFIID riid)
Helper for retrieving error decription. More...

std::string | GetErrorDescription ()
Simple get error description. More...

void | TraceX (LPCTSTR szFormat,...)
trace formated string to debug output.

Detailed Description

Header for simple error handle support.

Generated on Tue Dec 25 18:25:55 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Lockers.h File Reference

Header for simple lock support. More...

Compounds

class | CAutoClassLocker
Class object locker. More...

class | CAutoCSLocker
Critical section object locker. More...

Defines

#define | AUTO_LOCKER CAutoClassLocker<_CoClass> _clsLoker( this )
AUTO_LOCKER macros. More...

#define | AUTO_LOCKER_LOCK _clsLoker.Lock()
AUTO_LOCKER_LOCK macros. More...

#define | AUTO_LOCKER_UNLOCK _clsLoker.Unlock()
AUTO_LOCKER_UNLOCK macros. More...

#define | AUTO_CS_LOCKER_LOCK _csLocksr.Lock()
AUTO_CS_LOCKER_LOCK macros. More...

#define | AUTO_CS_LOCKER_UNLOCK _csLocksr.Unlock()
AUTO_CS_LOCKER_UNLOCK macros. More...

#define | AUTO_CS_LOCKER(cs) CAutoCSLocker _csLocksr( &cs )
AUTO_CS_LOCKER macros. More...

Functions

template<class TClass, class TClassValue, class TValue> HRESULT | CopyClassValueTo (TClass *pClass, TClassValue &Value, TValue *pValue)
Safe copy class variable to pointered variable use thread locks. More...

template<class TClass, class TClassValue, class TValue> HRESULT | CopyClassInterfaceValueTo (TClass *pClass, TClassValue &oValue, TValue *pValue)
Safe copy class interface variable to pointered variable use thread locks. More...

template<class TClass, class TValue> TValue | CopyClassValue (TClass *pClass, TValue &ClassValue)
Safe get class variable use thread locks. More...

Detailed Description

Header for simple lock support.

Generated on Tue Dec 25 18:25:55 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


StreamHelpers.h File Reference

Stream support classes and functions. More...

Functions

template<class TVer> HRESULT | SaveVersion (IStream *pIStream, TVer Version)
save version to storage. More...

template<class TVer> TVer | LoadVersion (IStream *pIStream)
Load version from storage. More...

HRESULT | SaveSignature (IStream *pIStream, LPCTSTR szSignature)
save string signature to storage. More...

BOOL | CheckSignature (IStream *pIStream, LPCTSTR szSignature)
Check Signature with saved in storage. More...

Detailed Description

Stream support classes and functions.

Generated on Tue Dec 25 18:25:55 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


TemplateHelpers.h File Reference

Template classes and functions for programming helping. More...

Defines

#define | AR_SIZE(ARRAY) ( sizeof( ARRAY ) / sizeof( ARRAY[0] ) )
Calculate array size.

#define | _apiPOINT(pt) pt.x, pt.y
Replace pt with long version .x, .y.

#define | _apiRECT(rc) rc.left, rc.top, rc.right, rc.bottom
Replace rc with long version .x1, .y1, .x2, .y2.

#define | _apiRECT1(rc) rc.left, rc.top, rc.right - rc.left, rc.bottom - rc.top
Replace rc with long version .x1, .y1, .width, .height.

Functions

template<class T> void | Zero (T &var)
Zeroize specified object. More...

string | MakeUniqueFName (LPCTSTR szBase, LPCTSTR szExt, int nDigits=4)
making unique file name.

Detailed Description

Template classes and functions for programming helping.

Function Documentation

void Zero ( T & var )

Zeroize specified object.

Parameters:
var Variable (not a variable address) which must be zeroized.

Generated on Tue Dec 25 18:25:55 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


VideoSurvDll.idl File Reference

Namespaces

namespace | VIDEOSURVDLLLib

Compounds

interface | IChildWindow
interface for controlling child window. More...

interface | _IChildWindowEvents
Child window events. More...

interface | IChildWindowRegistrar
interface for registering a list of child windows. More...

interface | IChildWindowManager
interface for managing a list of child windows. More...

interface | _IChildWindowManagerEvents
Child window manager events. More...

interface | IApplication
Main interface of application object. More...

interface | _IApplicationStateEvents
Application object events. More...

interface | IAppWindow
Application window. More...

interface | _IAppWindowEvents
Application window events. More...

interface | IChannelDirector
Channel director interface. More...

interface | IStructureItem
Structure support. More...

interface | _IStructureItemEvents
Structure item object events. More...

interface | IEnumStructureItem
Enumerator of structure item objects. More...

interface | IStructureLevel
Structure level. More...

interface | _IStructureLevelEvents
Structure level object events. More...

interface | IChannelManager
Channel manager. More...

interface | IEnumLanguageCodes
Language codes enumerator. More...

interface | ILocalizationManager
Localization Manager. More...

interface | _ILocalizationEvents
Localization events. More...

interface | ILocalizationStorage
Localization storage interface. More...

interface | ILocalizationSetup
Manage localization for localization storage. More...

struct | LM_RECORD
log manager record. More...

interface | IEnumLogRecords
interface for acessing log records. More...

interface | ILogManager
Log manager. More...

interface | ILogManagerClient
Interface that recomended to support for any objects that acces log manager. More...

interface | IDriverManager
Driver manager. More...

interface | IChannel
Channel interface. More...

interface | _IChannelEvents
Channel Object Events. More...

struct | CONNECT_INFO
Structure with info about connection between two channel objects. More...

interface | IEnumConnectInfo
Connect info enumerator. More...

interface | IChannelStructure
Interface manage channel structure. More...

interface | IChannelContainerRegistrar
Channel container registrar interface. More...

interface | IChannelContainer
Channel container interface. More...

interface | IEnumConnectors
Channel connectors enumerator. More...

interface | IChannelObject
Channel object interface. More...

struct | GCO_HT_INFO
Hit test info. More...

interface | IGraphicsChannelObject
Graphics channel object interface (GUI). More...

interface | _IGraphicsChannelObject
Graphics Channel Object Events. More...

interface | IChannelData
Default interface of channel data. More...

interface | IImageData
Image data interface. More...

interface | IEnumChannelData
Channel data enumerator. More...

interface | IGroupData
Group data interface. More...

interface | ICustomControlsPopupWindow
Custom controls popup window. More...

interface | IMainBarNotifyListener
Main bar notifications. More...

interface | IMainBar
Main bar interface. More...

interface | IAppConfigDlg
Application config dialog interface. More...

interface | IConnector
Connector base interface. More...

interface | _IConnectorEvents
Connector events. More...

interface | IVideoInputConnector
Connector input interface. More...

interface | IVideoInputConnectorInternal
Internal interface for video input connector object. More...

interface | _IVideoInputConnectorEvents
Input video connector events. More...

interface | IVideoOutputConnector
Connector output interface. More...

interface | IVideoOutputConnectorInternal
Internal interface for video output connector object. More...

interface | _IVideoOutputConnectorEvents
Output Video connector events. More...

interface | ICloneObject
Clone object interface. More...

interface | ISecurityUser
Security user interface. More...

interface | IEnumSecurityUsers
Security users enumerator. More...

interface | ISecurityGroup
Security group interface. More...

interface | ISecurityManager
Security manager. More...

interface | IEnumBSTR
BSTR enumarator. More...

interface | IEnumLONG
LONG enumarator. More...

interface | ISecurityItem
Security item. More...

interface | IColorSettings
Color manager. More...

interface | IAppPropertySheet
Application property sheet interface. More...

Typedefs

typedef enum LM_RECTYPE | LM_RECTYPE
type of log manager record.

typedef LM_RECORD | LM_RECORD
log manager record.

typedef enum CHANNEL_MODE | CHANNEL_MODE
Type of channel process mode.

typedef CONNECT_INFO | CONNECT_INFO
Structure with info about connection between two channel objects.

typedef enum GCO_HTENUM | GCO_HTENUM
Hit test value type.

typedef enum GCO_HTFLAGS | GCO_HTFLAGS
Hit test flags.

typedef GCO_HT_INFO | GCO_HT_INFO
Hit test info.

typedef enum ALIGN_TYPE | ALIGN_TYPE
Security user type.

typedef enum SECURITY_USER_TYPE | SECURITY_USER_TYPE
Security user type.

typedef enum SECURITY_DEFAULT_LEVEL | SECURITY_DEFAULT_LEVEL
Default security level type.

Enumerations

enum | LM_RECTYPE { rctInfo = 0, rctWarning = 1, rctError = 2 }
type of log manager record. More...

enum | CHANNEL_MODE { ctmParallel = 0, ctmInterleave = 1, ctmWaitComplete = 2 }
Type of channel process mode. More...

enum | GCO_HTENUM { gohtNone, gohtBody, gohtInputConnector, gohtOutputConnector }
Hit test value type. More...

enum | GCO_HTFLAGS { gofNone = 0, gofLinked = 1 }
Hit test flags. More...

enum ALIGN_TYPE {
alignFree = 0, alignLeft = 1, alignRight = 2, alignTop = 3,
alignBottom = 4
}
Security user type. More...

enum | SECURITY_USER_TYPE { sutUser = 0, sutGroup = 1 }
Security user type. More...

enum | SECURITY_DEFAULT_LEVEL { sdlFullAccess = 0, sdlNormalAccess = 1, sdlMinAccess = 2 }
Default security level type. More...

Detailed Description

Program interfaces and types

Enumeration Type Documentation

enum LM_RECTYPE

type of log manager record.

Enumeration values:
rctInfo | Some info.
rctWarning | Non critical error.
rctError | Critical error.

enum CHANNEL_MODE

Type of channel process mode.

Enumeration values:
ctmParallel | all objects work parallel.
ctmInterleave | objects work in interleave mode.
ctmWaitComplete | only one object can work in channel.

enum GCO_HTENUM

Hit test value type.

Enumeration values:
gohtNone | not a object point.
gohtBody | body point.
gohtInputConnector | input connector point.
gohtOutputConnector | output connector point.

enum GCO_HTFLAGS

Hit test flags.

Enumeration values:
gofNone | Object is not linked to another.
gofLinked | Object is linked to another.

enum ALIGN_TYPE

Security user type.

Enumeration values:
alignFree | No align.
alignLeft | Left align.
alignRight | Right align.
alignTop | Top align.
alignBottom | Bottom align.

enum SECURITY_USER_TYPE

Security user type.

Enumeration values:
sutUser | User identifier.
sutGroup | Group identifier.

enum SECURITY_DEFAULT_LEVEL

Default security level type.

Enumeration values:
sdlFullAccess | Allow full access for object resources.
sdlNormalAccess | Allow normal access for object resources.
sdlMinAccess | Allow minimal access for object resources.

Generated on Tue Dec 25 18:25:55 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Annotated Index

VideoSurveillanceSystem Compound List

Here are the classes, structs, unions and interfaces with brief descriptions:
_IApplicationStateEvents | Application object events
_IAppWindowEvents | Application window events
_IChannelEvents | Channel Object Events
_IChildWindowEvents | Child window events
_IChildWindowManagerEvents | Child window manager events
_IConnectorEvents | Connector events
_IGraphicsChannelObject | Graphics Channel Object Events
_ILocalizationEvents | Localization events
_IStructureItemEvents | Structure item object events
_IStructureLevelEvents | Structure level object events
_IVideoInputConnectorEvents | Input video connector events
_IVideoOutputConnectorEvents | Output Video connector events
CAutoClassLocker | Class object locker
CAutoCSLocker | Critical section object locker
CChannelConnectors | Channel connectors array
CChannelDisplay | CChannelDisplay class
CChannelSwitcher | CChannelSwitcher class
CChannelSwitcherPropPage | CChannelSwitcherPropPage class
CCircle | Circle object
CConnectInfo | Helper class keeping information about two channel objects connection
CConnectionPairs | Helper class for iterating and keeping connections between channel objects
CDataObjects | Channel data array
CLocAdvisor | Advise to localization manager
CLocHelper | Class uses as helper while loading strings
CLogHelper | Class used as helper to acces for log manager
CMultiAdvisor | Advise to multile objects
CONNECT_INFO | Structure with info about connection between two channel objects
CPoint | Point object
CRect | Rectangle object
CRegistryList | List of COM objects retrieving from system registry
CSecurityHelper | Class used as helper to security manager
CSingleAdvisor | Advise to single object
CSize | Size object (see windows SIZE)
CStructureItems | Helper class for iterating and keeping structure level subitems
GCO_HT_INFO | Hit test info
IAppConfigDlg | Application config dialog interface
IApplication | Main interface of application object
IAppPropertySheet | Application property sheet interface
IAppWindow | Application window
IAVISource | AVI Source interface
IAVITarget | AVI Target interface
IChannel | Channel interface
IChannelContainer | Channel container interface
IChannelContainerRegistrar | Channel container registrar interface
IChannelData | Default interface of channel data
IChannelDirector | Channel director interface
IChannelDisplay | Channel display interface
IChannelManager | Channel manager
IChannelObject | Channel object interface
IChannelObjectImpl | Base class for channel object
IChannelStructure | Interface manage channel structure
IChannelSwitcher | Channel Switcher interface
IChildWindow | Interface for controlling child window
IChildWindowImpl | Child window interface support
IChildWindowManager | Interface for managing a list of child windows
IChildWindowRegistrar | Interface for registering a list of child windows
ICloneObject | Clone object interface
ICloneObjectImpl |
IColorProcessingFilter | Color Processing Filter interface
IColorSettings | Color manager
IConnector | Connector base interface
ICustomControlsPopupWindow | Custom controls popup window
IDataObjectMinImpl | Base class for data object with minimal support
idlAVICOMPRESSOPTIONS | IdlAVICOMPRESSOPTIONS
IDriverManager | Driver manager
IEnumBSTR | BSTR enumarator
IEnumChannelData | Channel data enumerator
IEnumConnectInfo | Connect info enumerator
IEnumConnectors | Channel connectors enumerator
IEnumLanguageCodes | Language codes enumerator
IEnumLogRecords | Interface for acessing log records
IEnumLONG | LONG enumarator
IEnumSecurityUsers | Security users enumerator
IEnumStructureItem | Enumerator of structure item objects
IGraphicsChannelObject | Graphics channel object interface (GUI)
IGroupData | Group data interface
IImageData | Image data interface
ILocalizationManager | Localization Manager
ILocalizationSetup | Manage localization for localization storage
ILocalizationStorage | Localization storage interface
ILogManager | Log manager
ILogManagerClient | Interface that recomended to support for any objects that acces log manager
IMainBar | Main bar interface
IMainBarNotifyListener | Main bar notifications
ISecurityGroup | Security group interface
ISecurityItem | Security item
ISecurityManager | Security manager
ISecurityUser | Security user interface
IStructureItem | Structure support
IStructureItemImpl | Base implementation of structure item
IStructureLevel | Structure level
IStructureLevelImpl | Base implementation of structure level object
IVideoInputConnector | Connector input interface
IVideoInputConnectorInternal | Internal interface for video input connector object
IVideoOutputConnector | Connector output interface
IVideoOutputConnectorInternal | Internal interface for video output connector object
LM_RECORD | Log manager record
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


_IApplicationStateEvents Interface Reference

Application object events. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

HRESULT | OnInitComplete ()
Init phase complete successfully.

HRESULT | OnAppLoadComplete ()
Load workspace phase complete successfully.

void | OnShowAppWindow ()
Show App window event.

HRESULT | OnGUIReady ()
Program GUI ready.

Detailed Description

Application object events.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


_IAppWindowEvents Interface Reference

Application window events. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

void OnScreenModeChanged ([in] BOOL bFullScreen)
Screen mode changed event.

Detailed Description

Application window events.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


_IChannelEvents Interface Reference

Channel Object Events. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

void OnTransferModeChanged ([in] CHANNEL_MODE newMode)
Channel transfer mode changed.

Detailed Description

Channel Object Events.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


_IChildWindowEvents Interface Reference

Child window events. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

void | OnChildWindowCreated ([in] IChildWindow *pIChildWindow)
Child window created.

void | BeforeChildWindowDestroy ([in] IChildWindow *pIChildWindow)
Child window will be destroy now.

void | AfterChildWindowDestroy ([in] IChildWindow *pIChildWindow)
Child window has been destroyed.

void | OnChildWindowRectChanged ([in] IChildWindow *pIChildWindow,[in] RECT WindowRect)
Child window rectangle has been changed.

void | OnChildWindowVisibilityChanged ([in] IChildWindow *pIChildWindow,[in] BOOL Visibled)
Child window visibility has been changed.

void | OnChildWindowFloatingStateChanged ([in] IChildWindow *pIChildWindow,[in] BOOL Float)
Child window float state has been changed.

Detailed Description

Child window events.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


_IChildWindowManagerEvents Interface Reference

Child window manager events. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

void | OnFloatStateChanged ([in] BOOL bNewState)
Float state changed.

void | OnCoveringFormChanged ([in] SIZE szNewCoveringForm)
Covering form changed.

Detailed Description

Child window manager events.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


_IConnectorEvents Interface Reference

Connector events. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

void | OnConnected ([in] IConnector *pIConnector)
Connector has been connected to another connector.

void | OnDisconnected ([in] IConnector *pIConnector)
Connector has been disconnected from another connector.

void | OnOffsetChanged ([in] IConnector *pIConnector,[in] POINT newVal)
Connector offset has been changed.

void | OnAlignChanged ([in] IConnector *pIConnector,[in] ALIGN_TYPE newVal)
Connector align has been changed.

Detailed Description

Connector events.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


_IGraphicsChannelObject Interface Reference

Graphics Channel Object Events. More...

#include <VideoSurvDll.idl>

List of all members.

Detailed Description

Graphics Channel Object Events.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


_ILocalizationEvents Interface Reference

Localization events. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

void OnLanguageChanged ()
Default language changed.

Detailed Description

Localization events.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


_IStructureItemEvents Interface Reference

Structure item object events. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

void | OnStructureItemNameChanged ([in] IStructureItem *pIStructureItem)
Structure item name changed.

void | OnStructureItemDescriptionChanged ([in] IStructureItem *pIStructureItem)
Structure item description changed.

Detailed Description

Structure item object events.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


_IStructureLevelEvents Interface Reference

Structure level object events. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

void | AfterAddItemToLevel ([in] IStructureItem *pIStructureItem)
Structure item was added to level.

void | BeforeRemoveItemFromLevel ([in] IStructureItem *pIStructureItem)
Structure item will be removed from level.

void | AfterRemoveItemFromLevel ()
Structure item was removed from level.

Detailed Description

Structure level object events.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


_IVideoInputConnectorEvents Interface Reference

Input video connector events. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

void | OnDataReady ([in] IVideoInputConnector *pIConnector)
Data ready to process.

void | OnDataReceived ([in] IVideoInputConnector *pIConnector)
Data has been received just now.

Detailed Description

Input video connector events.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


_IVideoOutputConnectorEvents Interface Reference

Output Video connector events. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

void | OnQueryData ([in] IVideoOutputConnector *pIConnector)
There are data query.

void | OnSendData ([in] IVideoOutputConnector *pIConnector)
Data has been sended just now.

Detailed Description

Output Video connector events.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


TemplateCAutoClassLocker class Reference

CAutoClassLocker Class Template Reference

Class object locker. More...

#include <Lockers.h>

List of all members.

Public Methods

CAutoClassLocker (TClass *pClass, BOOL bLock=TRUE)
create locker object and lock class.

~CAutoClassLocker ()
destruct locker object and unlock class.

void | Lock ()
Lock class object.

void | Unlock ()
Unlock class object.

Detailed Description

template<class TClass>
class CAutoClassLocker< TClass >

Class object locker.

Lock class object using Lock/Unlock public members

The documentation for this class was generated from the following file:
  • Lockers.h
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


CAutoCSLocker Class Reference

Critical section object locker. More...

#include <Lockers.h>

List of all members.

Public Methods

CAutoCSLocker (CComAutoCriticalSection *pCS, BOOL bLock=TRUE)
create locker object and lock critical section. More...

~CAutoCSLocker ()
destruct locker object and unlock critical section.

void | Lock ()
Lock critical section.

void | Unlock ()
Unlock critical section.

Detailed Description

Critical section object locker.

Lock critical section object using Lock/Unlock public members of CComAutoCriticalSection object

Constructor & Destructor Documentation

CAutoCSLocker | ( | CComAutoCriticalSection * | pCS,
 |  | BOOL | bLock = TRUE
 | ) | [inline]

create locker object and lock critical section.

Parameters:
pCS | pointer for used critical section
bLock | Lock critical section at locker object creation

The documentation for this class was generated from the following file:
  • Lockers.h
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


TemplateCChannelConnectors class Reference

CChannelConnectors Class Template Reference

Channel connectors array. More...

#include <ChannelObjectHelpers.h>

List of all members.

Public Methods

int | Init (IUnknown *pChannelObjUnk, BOOL bInputConnector)
retrieve connectors from specified channel object.

void | clear ()
clear connectors list.

HRESULT | GetConnector (long nID, IConnector **pIConnector)
get connector object with request ID from array.

bool | IsValidID (long nID)
check for index validity.

CPoint | ptOffset (long nID)
get connector center point.

Detailed Description

template<class I>
class CChannelConnectors< I >

Channel connectors array.

Helper class use for iterate and keeping information about connectors

Parameters:
I Requiest connector interface

The documentation for this class was generated from the following file:
  • ChannelObjectHelpers.h
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


CChannelDisplay Class Reference

CChannelDisplay class. More...

#include <ChannelDisplay.h>

Inheritance diagram for CChannelDisplay::

IChildWindowImpl IChannelDisplay IStructureItemImpl List of all members.

Public Methods

CChannelDisplay ()
Default constructor.

ISTRUCTUREITEMIMPL_ENTRIES
virtual ICHANNELOBJECTIMPL_ENTRIES
HRESULT 		RegisterCustomControls ()
Simple implementation.

virtual void | UnregisterCustomControls ()
Simple implementation.

virtual void | OnAddConnector (IConnector *pIConnector)
Add specified connector to a channel display.

virtual void | OnRemoveConnector (IConnector *pIConnector)
Remove specified connector from a channel display.

LRESULT | OnPaint (UINT uMsg, WPARAM wParam, LPARAM lParam, BOOL &bHandled)
Message handler.

LRESULT | OnEraseBkgnd (UINT uMsg, WPARAM wParam, LPARAM lParam, BOOL &bHandled)
Message handler.

STDMETHOD (InterfaceSupportsErrorInfo)(REFIID riid)
simple implementation.

STDMETHOD (CreateChildWindow)(HWND hParentWnd, RECT rcWnd)
Channel display creation.

STDMETHOD (DestroyChildWindow)()
Channel display destruction.

STDMETHOD (put_WindowRect)(RECT rcWnd)
Channel display geometry changing.

STDMETHOD (Init)()
simple implementation.

STDMETHOD (PostInit)()
simple implementation.

STDMETHOD_ (void, PreClose)()
simple implementation.

STDMETHOD_ (void, Close)()
simple implementation.

STDMETHOD (get_SIName)(BSTR *pVal)
simple implementation.

STDMETHOD (put_SIName)(BSTR newVal)
simple implementation.

STDMETHOD (Load)(IStream *pStm)
simple implementation.

STDMETHOD (Save)(IStream *pStm, BOOL fClearDirty)
simple implementation.

STDMETHOD (IsDirty)()
simple implementation.

Detailed Description

CChannelDisplay class.

The documentation for this class was generated from the following file:
  • ChannelDisplay.h
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


CChannelSwitcher Class Reference

CChannelSwitcher class. More...

#include <ChannelSwitcher.h>

Inheritance diagram for CChannelSwitcher::

IChannelSwitcher IStructureItemImpl List of all members.

Public Methods

CChannelSwitcher ()
Default constructor.

ISTRUCTUREITEMIMPL_ENTRIES
virtual ICHANNELOBJECTIMPL_ENTRIES
HRESULT 		RegisterCustomControls ()
Simple implementation.

virtual void | UnregisterCustomControls ()
Simple implementation.

virtual void | OnAddConnector (IConnector *pIConnector)
Add specified connector to a channel switcher.

virtual void | OnRemoveConnector (IConnector *pIConnector)
Remove specified connector from a channel switcher.

STDMETHOD (InterfaceSupportsErrorInfo)(REFIID riid)
simple implementation.

STDMETHOD (get_OutputConnectors)(UINT *pVal)
Property returns output connectors amount. More...

STDMETHOD (put_OutputConnectors)(UINT newVal)
Property changes output connectors amount to a new value. More...

STDMETHOD (Init)()
simple implementation.

STDMETHOD (PostInit)()
simple implementation.

STDMETHOD_ (void, PreClose)()
simple implementation.

STDMETHOD_ (void, Close)()
simple implementation.

STDMETHOD (get_SIName)(BSTR *pVal)
simple implementation.

STDMETHOD (put_SIName)(BSTR newVal)
simple implementation.

STDMETHOD (Load)(IStream *pStm)
Load state from stream.

STDMETHOD (Save)(IStream *pStm, BOOL fClearDirty)
Save state to stream.

STDMETHOD (IsDirty)()
simple implementation.

Protected Methods

bool | DeleteFreeConnector (REFCLSID clsidConnectorClass)
Delete free input or output connector.

Protected Attributes

CComPtr< IGroupData > | m_oStoredGroupData
Data that is intend to be copied into requested output connectors.

Detailed Description

CChannelSwitcher class.

Member Function Documentation

STDMETHOD ( get_OutputConnectors )

Property returns output connectors amount.

Parameters:
pVal is output connectors amount

Reimplemented from IStructureItemImpl.

STDMETHOD ( put_OutputConnectors )

Property changes output connectors amount to a new value.

Parameters:
newVal is new output connectors amount

Reimplemented from IStructureItemImpl.

The documentation for this class was generated from the following file:
  • ChannelSwitcher.h
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


CChannelSwitcherPropPage Class Reference

CChannelSwitcherPropPage class. More...

#include <ChannelSwitcherPropPage.h>

List of all members.

Public Methods

CChannelSwitcherPropPage ()
Default constructor.

STDMETHOD (get_SIName)(BSTR *pVal)
simple implementation.

Detailed Description

CChannelSwitcherPropPage class.

The documentation for this class was generated from the following file:
  • ChannelSwitcherPropPage.h
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


CCircle Class Reference

Circle object. More...

#include <2DStruct.h>

List of all members.

Public Methods

CRect GetExtent ()
Get extent of circle.

BOOL PointIn (POINT &pt)
Check if point is in circle.

Detailed Description

Circle object.

The documentation for this class was generated from the following file:
  • 2DStruct.h
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


CConnectInfo Class Reference

Helper class keeping information about two channel objects connection. More...

#include <ChannelClasses.h>

Inheritance diagram for CConnectInfo::

CONNECT_INFO List of all members.

Public Methods

CConnectInfo ()
Constructor.

CConnectInfo (long _nSourceObjectID, long _nOutConnectorID, long _nTargetObjectID, long _nInConnectorID)
Constructor.

CConnectInfo (CONNECT_INFO &ci)
Constructor.

void | operator= (CONNECT_INFO &ci)
Assign.

bool | operator== (CONNECT_INFO &ci)
Comparing with another CONNECT_INFO structure.

Detailed Description

Helper class keeping information about two channel objects connection.

The documentation for this class was generated from the following file:
  • ChannelClasses.h
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


CConnectionPairs Class Reference

Helper class for iterating and keeping connections between channel objects. More...

#include <ChannelClasses.h>

List of all members.

Public Methods

CConnectionPairs ()
Constructor.

CConnectionPairs (IUnknown *pChannelUnk)
Constructor. More...

int | Init (IUnknown *pChannelUnk)
Init channel object. More...

int | size ()
return connection pairs count.

CConnectInfo & | operator[] (int n)
return specified connection pair.

void | clear ()
clear connection pairs list.

Detailed Description

Helper class for iterating and keeping connections between channel objects.

Constructor & Destructor Documentation

CConnectionPairs ( IUnknown * pChannelUnk ) [inline]

Constructor.

Parameters:
pChannelUnk Channel object interface

Member Function Documentation

int Init ( IUnknown * pChannelUnk ) [inline]

Init channel object.

Parameters:
pChannelUnk Channel object interface

The documentation for this class was generated from the following file:
  • ChannelClasses.h
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


TemplateCDataObjects class Reference

CDataObjects Class Template Reference

Channel data array. More...

#include <ChannelClasses.h>

List of all members.

Public Methods

CDataObjects (IGroupData *pIGroupData)
Constructor. More...

template<class I2> | CDataObjects (CDataObjects< I2 > &Items)
Copy constructor.

int | Init (IGroupData *pIGroupData)
Init object. More...

int | size ()
return size of level subitems.

I * | operator[] (int n)
get specified subitem.

void | clear ()
clear arry.

template<class I2> void | operator= (CDataObjects< I2 > &Items)
copy items to another array (may be with another required interface).

Detailed Description

template<class I>
class CDataObjects< I >

Channel data array.

Helper class retrieve and keep information about data objects stored in group data object

Parameters:
I Request interface

Constructor & Destructor Documentation

CDataObjects ( IGroupData * pIGroupData ) [inline]

Constructor.

Parameters:
pLevelUnk Group data object

Member Function Documentation

int Init ( IGroupData * pIGroupData ) [inline]

Init object.

Parameters:
pIGroupData Group data object

The documentation for this class was generated from the following file:
  • ChannelClasses.h
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


TemplateCLocAdvisor class Reference

CLocAdvisor Class Template Reference

Advise to localization manager. More...

#include <Advisers.h>

List of all members.

Public Methods

CLocAdvisor (REFIID guidObject)
guidObject used for localize object.

HRESULT | LocInit (IUnknown *pIAppUnk)
init object localization, pIAppUnk - application object.

void | LocUninit ()
uninit object localization.

HRESULT | LoadString (long nResID, string *ps)
load localized string.

HRESULT | LoadString (long nResID, BSTR *pbs)
load localized string.

HRESULT | LoadString (REFGUID guidObject, long nResID, string *ps)
load localized string.

Public Attributes

REFIID | m_guidObject
localization guid.

CComQIPtr< ILocalizationManager > | m_oLocManager
localization manager.

CComPtr< ILocalizationStorage > | m_oLocStorage
localization storage.

Detailed Description

template<class TClass, class Base = CSingleAdvisor<TClass>>
class CLocAdvisor< TClass, Base >

Advise to localization manager.

Parameters:
TClass | last class object
Base | class for advise manipulations

The documentation for this class was generated from the following file:
  • Advisers.h
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


CLocHelper Class Reference

class uses as helper while loading strings. More...

#include <Advisers.h>

List of all members.

Public Methods

CLocHelper (REFIID guidObject)
guidObject used for localize object.

HRESULT | LocInit (IUnknown *pIAppUnk)
init object localization, pIAppUnk - application object.

void | LocUninit ()
uninit object localization.

HRESULT | LoadString (long nResID, string *ps)
load localized string.

HRESULT | LoadString (long nResID, BSTR *pbs)
load localized string.

HRESULT | LoadString (REFGUID guidObject, long nResID, string *ps)
load localized string.

Detailed Description

class uses as helper while loading strings.

The documentation for this class was generated from the following file:
  • Advisers.h
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


TemplateCLogHelper class Reference

CLogHelper Class Template Reference

class used as helper to acces for log manager. More...

#include <Advisers.h>

List of all members.

Public Methods

CLogHelper (TClass *pT)
Constructor.

HRESULT | LogInit (IUnknown *pIAppUnk, long nLocIDName)
init object localization, pIAppUnk - application object.

HRESULT | AddLogMessage (LM_RECTYPE lmrt, long nLocID)
Add message to logs.

HRESULT | AddLogMessage (LM_RECTYPE lmrt, LPCTSTR lpsz)
Add message to logs.

HRESULT | AddLogMessage (LM_RECTYPE lmrt, BSTR bsMess)
Add message to logs.

Detailed Description

template<class TClass>
class CLogHelper< TClass >

class used as helper to acces for log manager.

Parameters:
TClass last class object

The documentation for this class was generated from the following file:
  • Advisers.h
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


TemplateCMultiAdvisor class Reference

CMultiAdvisor Class Template Reference

Advise to multile objects. More...

#include <Advisers.h>

List of all members.

Public Methods

CMultiAdvisor (REFIID iid)
iid - interface identifier for advise.

HRESULT | Advise (IUnknown *pUnkCP)
advise to the object.

HRESULT | Unadvise ()
unadvise from all objects.

HRESULT | Unadvise (IUnknown *pUnkCP)
unadvise from the object.

BOOL | IsAdvised ()
check for advised state.

BOOL | IsAdvised (IUnknown *pUnkCP)
check for advised state.

Public Attributes

REFIID | m_iid
interface identifier for advise.

vector< CComPtr< IUnknown > > | m_aroUnkCP
advised objects.

vector< DWORD > | m_ardwCookie
advise cookies.

Detailed Description

template<class TClass, int n = 0>
class CMultiAdvisor< TClass, n >

Advise to multile objects.

Parameters:
TClass | last class object
n | uses for differ one base class of other

The documentation for this class was generated from the following file:
  • Advisers.h
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


CONNECT_INFO Struct Reference

Structure with info about connection between two channel objects. More...

#include <VideoSurvDll.idl>

Inheritance diagram for CONNECT_INFO::

CConnectInfo List of all members.

Public Attributes

long | nSourceObjectID
Source object ID.

long | nOutConnectorID
Out connector ID.

long | nTargetObjectID
Target object ID.

long | nInConnectorID
In connector ID.

Detailed Description

Structure with info about connection between two channel objects.

The documentation for this struct was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


CPoint Class Reference

Point object. More...

#include <2DStruct.h>

List of all members.

Public Methods

CPoint | operator- (POINT &pt)
binary operator-(point offset).

CPoint | operator- () const
unary operator-(distance).

CPoint | operator+ (POINT &pt)
binary operator+(point offset).

CPoint | operator+ (SIZE &sz)
binary operator+(size offset).

CPoint | operator- (SIZE &sz)
binary operator-(point offset).

Detailed Description

Point object.

The documentation for this class was generated from the following file:
  • 2DStruct.h
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


CRect Class Reference

Rectangle object. More...

#include <2DStruct.h>

List of all members.

Public Methods

int | Width ()
Rectangle Width.

int | Height ()
Rectangle Height.

void | Normalize ()
Normalize function, top must be lesser bottom and left < right.

CRect & | UnionRect (RECT &Rect)
Get uninon with another rectangle.

BOOL | IntersectRect (RECT &Rect)
Get intersection betwen to rects.

BOOL | IsEmpty ()
Check rect is emty.

void | Empty ()
Construct empty rectangle.

CRect | operator- (POINT &pt)
operator-(shift).

CRect & | operator-= (POINT &pt)
operator-=(shift).

CRect | operator+ (POINT &pt)
operator+(shift).

CRect & | operator+= (POINT &pt)
operator+=(shift).

CPoint & TopLeft ()
Topleft corner of rect.

CPoint & BottomRight ()
BottomRight corner of rect.

CPoint CenterPoint ()
Center point of rect.

BOOL | PointIn (POINT pt)
Check is point in rect or not.

CRect & | InflateRect (int dx, int dy)
Inflate source Rect.

Detailed Description

Rectangle object.

The documentation for this class was generated from the following file:
  • 2DStruct.h
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


CRegistryList Class Reference

List of COM objects retrieving from system registry. More...

#include <StructureLevelClasses.h>

List of all members.

Public Methods

void | Init (LPCTSTR szGroupKey, HKEY hRootKey=HKEY_CLASSES_ROOT)
Load list from specified registry path. More...

void | RemoveAll ()
clear COM objects info array.

int | size ()
get size of COM objects info array.

CRegistryItemInfo & | operator[] (int n)
get COM objects info array item.

Detailed Description

List of COM objects retrieving from system registry.

Member Function Documentation

void Init | ( | LPCTSTR | szGroupKey,
 |  | HKEY | hRootKey = HKEY_CLASSES_ROOT
 | ) | [inline]

Load list from specified registry path.

Parameters:
szGroupKey | registry path
hRootKey | registry root key

The documentation for this class was generated from the following file:
  • StructureLevelClasses.h
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


CSecurityHelper Class Reference

class used as helper to security manager. More...

#include <Advisers.h>

List of all members.

Public Methods

HRESULT | SecurityInit (IUnknown *pIAppUnk, IUnknown *pSecItem)
init object localization, pIAppUnk - application object.

BOOL | CheckSecurityRights (long nPropID)
Check Security rights.

BOOL | CheckSecurityRights (IUnknown *pSecItem, long nPropID)
Check Security rights.

Detailed Description

class used as helper to security manager.

The documentation for this class was generated from the following file:
  • Advisers.h
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


TemplateCSingleAdvisor class Reference

CSingleAdvisor Class Template Reference

Advise to single object. More...

#include <Advisers.h>

List of all members.

Public Methods

CSingleAdvisor (REFIID iid)
iid - interface identifier used for advise.

HRESULT | Advise (IUnknown *pUnkCP)
advise to the object.

HRESULT | Unadvise ()
unadvise from object.

BOOL | IsAdvised ()
check for advised state.

Public Attributes

REFIID | m_iid
interface identifier for advise.

CComPtr< IUnknown > | m_oUnkCP
advised object.

DWORD | m_dwCookie
advise cookie.

Detailed Description

template<class TClass, int n = 0>
class CSingleAdvisor< TClass, n >

Advise to single object.

Parameters:
TClass | last class object
n | uses for differ one base class of other

The documentation for this class was generated from the following file:
  • Advisers.h
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


CSize Class Reference

Size object (see windows SIZE). More...

#include <2DStruct.h>

List of all members.

Public Methods

CSize | operator * (int nk)
binary operator *(scale offset).

CSize | operator/ (int nk)
binary operator/(scale offset).

Detailed Description

Size object (see windows SIZE).

The documentation for this class was generated from the following file:
  • 2DStruct.h
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


TemplateCStructureItems class Reference

CStructureItems Class Template Reference

Helper class for iterating and keeping structure level subitems. More...

#include <StructureLevelClasses.h>

List of all members.

Public Methods

CStructureItems (IUnknown *pLevelUnk)
Constructor. More...

template<class I2> | CStructureItems (CStructureItems< I2 > &Items)
Copy constructor. More...

int | Init (IUnknown *pLevelUnk)
set level object. More...

int | size ()
return size of level subitems.

I * | operator[] (int n)
get specified subitem.

void | clear ()
clear arry.

template<class I2> void | operator= (CStructureItems< I2 > &Items)
copy items to another array (may be with another required interface).

Detailed Description

template<class I>
class CStructureItems< I >

Helper class for iterating and keeping structure level subitems.

Parameters:
I required interface of items

Constructor & Destructor Documentation

CStructureItems ( IUnknown * pLevelUnk ) [inline]

Constructor.

Parameters:
pLevelUnk Structure level object

CStructureItems ( CStructureItems< I2 > & Items ) [inline]

Copy constructor.

Parameters:
Items CStructureItems object

Member Function Documentation

int Init ( IUnknown * pLevelUnk ) [inline]

set level object.

Parameters:
pLevelUnk Structure level object

The documentation for this class was generated from the following file:
  • StructureLevelClasses.h
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


GCO_HT_INFO Struct Reference

Hit test info. More...

#include <VideoSurvDll.idl>

List of all members.

Public Attributes

GCO_HTENUM htCode
hit test code.

long | nObjectID
object id, if exist.

long | nConnectorID
connector id, if exist.

UINT | dwFlags
object flags.

Detailed Description

Hit test info.

The documentation for this struct was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IAppConfigDlg Interface Reference

Application config dialog interface. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

HRESULT DoConfig ([in] IApplication *pApplocation)
Start configurate program objects.

Detailed Description

Application config dialog interface.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IApplication Interface Reference

Main interface of application object. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

HRESULT | CanCloseApplication ()
Check for closing application.

HRESULT | CloseApplication ([in] BOOL bSaveState)
Close application.

HRESULT | IsRunning ()
Check for application already running.

HRESULT | Run ([in] long hInstance,[in] long hPrevInstance,[in] BSTR bsCmdLine,[in] int nCmdShow)
Run application object.

HRESULT | AppWindow ([out, retval] IAppWindow **pVal)
Get application main window.

HRESULT | LoadWorkspace ([in] BSTR bsFName)
Load workspace from.

HRESULT | SaveWorkspace ([in] BSTR bsFName)
Save workspace to.

Detailed Description

Main interface of application object.

See also:
_IApplicationStateEvents

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IAppPropertySheet Interface Reference

Application property sheet interface. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

HRESULT | AddObject ([in] IUnknown *pObjectUnk)
Add object for configurating.

HRESULT | DoModal ([in] IApplication *pIApplication)
Config objects.

Detailed Description

Application property sheet interface.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IAppWindow Interface Reference

Application window. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

HRESULT | RegisterMainBarButton ([in] long nTopOffsetFactor,[in] BSTR bsTitle,[in] HBITMAP hBmp,[in] IMainBarNotifyListener *pClickListener,[out] DWORD *pdwCookie)
Register bar button.

HRESULT | UnregisterMainBarButton ([in] DWORD dwCookie)
Unregister bar button.

HRESULT | SetMainBarButtonTitle ([in] DWORD dwCookie,[in] BSTR bsTitle)
Set bar button title.

HRESULT | hWnd ([out, retval] HWND *pVal)
Get HWND of bar window.

HRESULT | FullScreen ([out, retval] BOOL *pVal)
Get full screen mode.

HRESULT | FullScreen ([in] BOOL newVal)
Set full screen mode.

Detailed Description

Application window.

See also:
_IAppWindowEvents

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IAVISource Interface Reference

AVI Source interface. More...

#include <ChannelObjects.idl>

List of all members.

Public Methods

HRESULT | AVIFileName ([out, retval] BSTR *pVal)
Get AVIFileName.

HRESULT | AVIFileName ([in] BSTR newVal)
Set AVIFileName.

Detailed Description

AVI Source interface.

The documentation for this interface was generated from the following files:
  • ChannelObjects.h
  • ChannelObjects.idl
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IAVITarget Interface Reference

AVI Target interface. More...

#include <ChannelObjects.idl>

List of all members.

Public Methods

HRESULT | AVIFileNameBase ([out, retval] BSTR *pVal)
Get AVIFileNameBase.

HRESULT | AVIFileNameBase ([in] BSTR newVal)
Set AVIFileNameBase.

HRESULT | CompressOptions ([out, retval] idlAVICOMPRESSOPTIONS *pVal)
Get CompressOptions.

HRESULT | CompressOptions ([in] idlAVICOMPRESSOPTIONS newVal)
Set CompressOptions.

Detailed Description

AVI Target interface.

The documentation for this interface was generated from the following files:
  • ChannelObjects.h
  • ChannelObjects.idl
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IChannel Interface Reference

Channel interface. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

HRESULT | TransferMode ([out, retval] CHANNEL_MODE *pVal)
Get channel process mode.

HRESULT | TransferMode ([in] CHANNEL_MODE newVal)
Set channel process mode.

Detailed Description

Channel interface.

See also:
_IChannelEvents

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IChannelContainer Interface Reference

Channel container interface. More...

#include <VideoSurvDll.idl>

List of all members.

Detailed Description

Channel container interface.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IChannelContainerRegistrar Interface Reference

Channel container registrar interface. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

HRESULT | RegisterCustomControl ([in] BSTR sProgID,[in] long nWidth,[in] long nHeight,[in] REFIID iid,[out] IUnknown **ppCtrlUnk,[out] DWORD *pdwCookie)
Register custom control.

HRESULT | UnregisterCustomControl ([in] DWORD dwCookie)
Unregister custom control.

Detailed Description

Channel container registrar interface.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IChannelData Interface Reference

Default interface of channel data. More...

#include <VideoSurvDll.idl>

List of all members.

Detailed Description

Default interface of channel data.

The documentation for this interface was generated from the following file:
  • VideoSurvDll.h
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IChannelDirector Interface Reference

Channel director interface. More...

#include <VideoSurvDll.idl>

List of all members.

Detailed Description

Channel director interface.

The documentation for this interface was generated from the following file:
  • VideoSurvDll.h
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IChannelDisplay Interface Reference

Channel display interface. More...

#include <ChannelObjects.idl>

Inheritance diagram for IChannelDisplay::

CChannelDisplay

Detailed Description

Channel display interface.

The documentation for this interface was generated from the following file:
  • ChannelObjects.idl
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IChannelManager Interface Reference

Channel manager. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

HRESULT | CreateNewChannel ([out, retval] IChannel **Channel)
Create new channel object.

HRESULT | EraseChannel ([in] IChannel *pIChannel)
Erase channel object.

Detailed Description

Channel manager.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IChannelObject Interface Reference

Channel object interface. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

HRESULT | Channel ([out, retval] IChannel **pVal)
Get channel object.

HRESULT | Channel ([in] IChannel *newVal)
Set channel object.

HRESULT | InputConnectors ([out, retval] IEnumConnectors **ppEnum)
Get input connectors enumerator.

HRESULT | OutputConnectors ([out, retval] IEnumConnectors **ppEnum)
Get output connectors enumerator.

Detailed Description

Channel object interface.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


TemplateIChannelObjectImpl class Reference

IChannelObjectImpl Class Template Reference

Base class for channel object. More...

#include <ChannelObjectHelpers.h>

List of all members.

Public Methods

HRESULT | PostInitChannelObject ()
initialization of channel object.

BOOL | UninitChannelObject ()
uninitialization of channel object.

HRESULT | AddControlCookie2AutoUnregister (DWORD dwCookie)
add cookie for autounregistration.

virtual HRESULT | RegisterCustomControls () PURE
must be implemented in target class.

virtual void | UnregisterCustomControls () PURE
must be implemented in target class.

Protected Methods

void | RecalcCoordinates ()
recalc coordinates of object.

HRESULT | AddConnector (REFCLSID clsidConnectorClass, REFGUID guidDataType, ALIGN_TYPE Align, long nID=-1)
add new connector and it's type.

HRESULT | RemoveConnector (long nID)
remove connector.

HRESULT | RemoveConnector (IConnector *pIConnector)
remove input connector.

virtual void | OnAddConnector (IConnector *pIConnector)
Called when connector added.

virtual void | OnRemoveConnector (IConnector *pIConnector)
Called before connector will be removed.

HRESULT | Save (IStream *pIStream)
Save Channel Item Object.

HRESULT | Load (IStream *pIStream)
Load Channel Item Object.

Protected Attributes

CPoint m_ptPos
channel object position.

CRect m_rcBounds
bounds rect.

CComPtr< IChannel > | m_oChannel
channel of object.

CComPtr< IChannelContainerRegistrar > | m_oContainerRegistrar
container of object.

TConnectors | m_aroConnectors
connectors list.

vector< DWORD > | m_arAutoUnregisterControlCookies
autounregistered AX controls list.

long | m_nConnectorID
max connectors identifier.

Detailed Description

template<class T>
class IChannelObjectImpl< T >

Base class for channel object.

Base class for channel object. It realize common channel implementations.

Parameters:
T target class

The documentation for this class was generated from the following file:
  • ChannelObjectHelpers.h
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IChannelStructure Interface Reference

Interface manage channel structure. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

HRESULT | ContainerRegistrar ([out, retval] IChannelContainerRegistrar **pVal)
Get container registrar object.

HRESULT | AddObjectToChannel ([in] IUnknown *ObjectUnk,[out] long *ObjectID)
Add object to channel.

HRESULT | RemoveObjectFromChannel ([in] IUnknown *pObjectUnk)
Remove object from channel.

HRESULT | ConnectObjects ([in] CONNECT_INFO *pci)
Connect two channel objects.

HRESULT | DisconnectObjects ([in] CONNECT_INFO *pci)
Disconnect two channel objects.

HRESULT | ConnectionPairs ([out, retval] IEnumConnectInfo **ppEnum)
Get connect pairs enumerator.

Detailed Description

Interface manage channel structure.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IChannelSwitcher Interface Reference

Channel Switcher interface. More...

#include <ChannelObjects.idl>

Inheritance diagram for IChannelSwitcher::

CChannelSwitcher List of all members.

Public Methods

HRESULT | OutputConnectors ([out, retval] UINT *nVal)
Get Output Connectors amount value 1..10.

HRESULT | OutputConnectors ([in] UINT newVal)
Set Output Connectors amount value 1..10.

Detailed Description

Channel Switcher interface.

The documentation for this interface was generated from the following file:
  • ChannelObjects.idl
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IChildWindow Interface Reference

interface for controlling child window. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

HRESULT | CreateChildWindow ([in] HWND hParentWnd,[in] RECT rcWnd)
Create child window.

HRESULT | DestroyChildWindow ()
Destroy child window.

HRESULT | WindowRect ([out, retval] RECT *pVal)
Get child window rect.

HRESULT | WindowRect ([in] RECT newVal)
Set child window rect.

HRESULT | WindowVisibled ([out, retval] BOOL *pVal)
Get child window visibility.

HRESULT | WindowVisibled ([in] BOOL newVal)
Set child window visibility.

HRESULT | FloatingState ([out, retval] BOOL *pVal)
Get child window floating state.

HRESULT | FloatingState ([in] BOOL newVal)
Set child window floating state.

Detailed Description

interface for controlling child window.

See also:
_IChildWindowEvents

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IChildWindowImpl Class Reference

Child window interface support. More...

#include <StructureLevelClasses.h>

Inheritance diagram for IChildWindowImpl::

CChannelDisplay List of all members.

Detailed Description

Child window interface support.

implement all IChildWindow extra function and return no implemented error

The documentation for this class was generated from the following file:
  • StructureLevelClasses.h
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IChildWindowManager Interface Reference

interface for managing a list of child windows. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

HRESULT | FloatEnabled ([out, retval] BOOL *pVal)
Get float mode.

HRESULT | FloatEnabled ([in] BOOL newVal)
Set float mode.

HRESULT | CoveringForm ([out, retval] SIZE *pVal)
Get covering form.

HRESULT | CoveringForm ([in] SIZE newVal)
Set covering form.

Detailed Description

interface for managing a list of child windows.

See also:
_IChildWindowManagerEvents

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IChildWindowRegistrar Interface Reference

interface for registering a list of child windows. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

HRESULT | RegisterChildWindow ([in] IUnknown *pChildWindowUnk)
Register child window in window manager.

HRESULT | UnregisterChildWindow ([in] IUnknown *pChildWindowUnk)
Unregister child window in window manager.

Detailed Description

interface for registering a list of child windows.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


ICloneObject Interface Reference

Clone object interface. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

HRESULT | Clone ([in] REFIID riid,[out, iid_is(riid)] void **pClone)
Clone object.

HRESULT | Assign ([in] IUnknown *pSourseObj)
Assign object.

HRESULT | CloneID ([out, retval] CLSID *pVal)
Get object CLSID.

HRESULT | IsEqual ([in] IUnknown *pUnk,[out, retval] BOOL *bEqual)
Is equal objects.

HRESULT | AssignPart ([in] REFIID riid,[in] IUnknown *pSource)
Assign part of object.

Detailed Description

Clone object interface.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


TemplateICloneObjectImpl class Reference

ICloneObjectImpl Class Template Reference

#include <CloneObjectImpl.h>

List of all members.

Public Methods

ICloneObjectImpl (TClass *pObj)
Constructor.

STDMETHOD (get_CloneID)(CLSID *pVal)
get clone ID for check purposes.

STDMETHOD (IsEqual)(IUnknown *pUnk, BOOL *bEqual)
check object for equal.

STDMETHOD (Clone)(REFIID iid, void **pClone)
do clone.

Detailed Description

template<class TClass>
class ICloneObjectImpl< TClass >

Parameters:
TClass last class object

The documentation for this class was generated from the following file:
  • CloneObjectImpl.h
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IColorProcessingFilter Interface Reference

Color Processing Filter interface. More...

#include <ChannelObjects.idl>

List of all members.

Detailed Description

Color Processing Filter interface.

The documentation for this interface was generated from the following file:
  • ChannelObjects.h
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IColorSettings Interface Reference

Color manager. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

HRESULT | Brightness ([out, retval] double *pVal)
Get Brightness value 0..1000.

HRESULT | Brightness ([in] double newVal)
Set Brightness value 0..1000.

HRESULT | Contrast ([out, retval] double *pVal)
Get Contrast value 0..1000.

HRESULT | Contrast ([in] double newVal)
Set Contrast value 0..1000.

HRESULT | Hue ([out, retval] double *pVal)
Get Hue value 0..1000.

HRESULT | Hue ([in] double newVal)
Set Hue value 0..1000.

HRESULT | Saturation ([out, retval] double *pVal)
Get Saturation value 0..1000.

HRESULT | Saturation ([in] double newVal)
Set Saturation value 0..1000.

Detailed Description

Color manager.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IConnector Interface Reference

Connector base interface. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

HRESULT | DataType ([out, retval] GUID *pVal)
Retrieve connector data type.

HRESULT | DataType ([in] REFGUID newVal)
Set connector data type.

HRESULT | ClassType ([out, retval] CLSID *pVal)
Retrieve connector class type.

HRESULT | IsConnectorInput ()
Ask for connector kind. More...

HRESULT | Connect ([in] IConnector *pIConnector)
Connect to another connector.

HRESULT | Disconnect ()
Disconnect from another connector.

HRESULT | IsConnected ()
Check for connect existing.

HRESULT | Offset ([out, retval] POINT *pVal)
Retrieve GUI connector offset.

HRESULT | Offset ([in] POINT newVal)
Set GUI connector offset.

HRESULT | ID ([out, retval] long *pVal)
Get connector identifier.

HRESULT | ID ([in] long newVal)
Set connector identifier.

HRESULT | Align ([out, retval] ALIGN_TYPE *pVal)
Get connector align.

HRESULT | Align ([in] ALIGN_TYPE newVal)
Set connector align.

Detailed Description

Connector base interface.

Member Function Documentation

HRESULT IsConnectorInput ( )

Ask for connector kind.

Return values:
S_OK | Input connector
S_FALSE | Output connector

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


ICustomControlsPopupWindow Interface Reference

Custom controls popup window. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

HRESULT | RegisterCustomControl ([in] BSTR sProgID,[in] long nWidth,[in] long nHeight,[in] REFIID iid,[out] IUnknown **ppCtrlUnk,[out] DWORD *pdwCookie)
Register custom control.

HRESULT | UnregisterCustomControl ([in] DWORD dwCookie)
Unregister custom control.

HRESULT | UpdateWindowPos ()
Update custom controls popup window position.

Detailed Description

Custom controls popup window.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IDataObjectMinImpl Class Reference

base class for data object with minimal support. More...

#include <DragDropSupport.h>

List of all members.

Public Methods

STDMETHOD (GetData)(FORMATETC *pformatetcIn, STGMEDIUM *pmedium)
Simple implementation
Exceptions:
E_NOTIMPL .

STDMETHOD (GetDataHere)(FORMATETC *, STGMEDIUM *)
Simple implementation
Exceptions:
E_NOTIMPL .

STDMETHOD (QueryGetData)(FORMATETC *)
Simple implementation
Exceptions:
E_NOTIMPL .

STDMETHOD (GetCanonicalFormatEtc)(FORMATETC *,FORMATETC *)
Simple implementation
Exceptions:
E_NOTIMPL .

STDMETHOD (SetData)(FORMATETC *, STGMEDIUM *, BOOL)
Simple implementation
Exceptions:
E_NOTIMPL .

STDMETHOD (EnumFormatEtc)(DWORD, IEnumFORMATETC **)
Simple implementation
Exceptions:
E_NOTIMPL .

STDMETHOD (DAdvise)(FORMATETC *pformatetc, DWORD advf, IAdviseSink *pAdvSink, DWORD *pdwConnection)
Simple implementation
Exceptions:
E_NOTIMPL .

STDMETHOD (DUnadvise)(DWORD dwConnection)
Simple implementation
Exceptions:
E_NOTIMPL .

STDMETHOD (EnumDAdvise)(IEnumSTATDATA **ppenumAdvise)
Simple implementation
Exceptions:
E_NOTIMPL .

Detailed Description

base class for data object with minimal support.

The documentation for this class was generated from the following file:
  • DragDropSupport.h
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


idlAVICOMPRESSOPTIONS Struct Reference

idlAVICOMPRESSOPTIONS. More...

#include <ChannelObjects.idl>

List of all members.

Detailed Description

idlAVICOMPRESSOPTIONS.

The documentation for this struct was generated from the following files:
  • ChannelObjects.h
  • ChannelObjects.idl
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IDriverManager Interface Reference

Driver manager. More...

#include <VideoSurvDll.idl>

List of all members.

Detailed Description

Driver manager.

The documentation for this interface was generated from the following file:
  • VideoSurvDll.h
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IEnumBSTR Interface Reference

BSTR enumarator. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

HRESULT | Next ([in] ULONG celt,[out, size_is(celt), length_is(*pCeltFetched)] BSTR *bsVar,[out] ULONG *pCeltFetched)
Get next BSTR.

HRESULT | Skip ([in] ULONG celt)
Skip next BSTR.

HRESULT | Reset ()
Reset enumerator.

HRESULT | Clone ([out] IEnumBSTR **ppEnum)
Clone enumerator.

Detailed Description

BSTR enumarator.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IEnumChannelData Interface Reference

Channel data enumerator. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

HRESULT | Next ([in] ULONG celt,[out, size_is(celt), length_is(*pCeltFetched)] IChannelData **rgVar,[out] ULONG *pCeltFetched)
Get next channel data.

HRESULT | Skip ([in] ULONG celt)
Skip next channel data.

HRESULT | Reset ()
Reset enumerator.

HRESULT | Clone ([out] IEnumChannelData **ppEnum)
Clone enumerator.

Detailed Description

Channel data enumerator.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IEnumConnectInfo Interface Reference

Connect info enumerator. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

HRESULT | Next ([in] ULONG celt,[out, size_is(celt), length_is(*pCeltFetched)] CONNECT_INFO *rgVar,[out] ULONG *pCeltFetched)
Get next connect info structure.

HRESULT | Skip ([in] ULONG celt)
Skip next connect info structure.

HRESULT | Reset ()
Reset enumerator.

HRESULT | Clone ([out] IEnumConnectInfo **ppEnum)
Clone enumerator.

Detailed Description

Connect info enumerator.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IEnumConnectors Interface Reference

Channel connectors enumerator. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

HRESULT | Next ([in] ULONG celt,[out, size_is(celt), length_is(*pCeltFetched)] IConnector **rgVar,[out] ULONG *pCeltFetched)
Get next input connectors.

HRESULT | Skip ([in] ULONG celt)
Skip next input connectors.

HRESULT | Reset ()
Reset enumerator.

HRESULT | Clone ([out] IEnumConnectors **ppEnum)
Clone enumerator.

Detailed Description

Channel connectors enumerator.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IEnumLanguageCodes Interface Reference

Language codes enumerator. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

HRESULT | Next ([in] ULONG celt,[out, size_is(celt), length_is(*pCeltFetched)] BSTR *rgVar,[out] ULONG *pCeltFetched)
Get next language codes.

HRESULT | Skip ([in] ULONG celt)
Skip next language codes.

HRESULT | Reset ()
Reset enumerator.

HRESULT | Clone ([out] IEnumLanguageCodes **ppEnum)
Clone enumerator.

Detailed Description

Language codes enumerator.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IEnumLogRecords Interface Reference

interface for acessing log records. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

HRESULT | Next ([in] ULONG celt,[out, size_is(celt), length_is(*pCeltFetched)] LM_RECORD *rgVar,[out] ULONG *pCeltFetched)
iterate throw records. More...

HRESULT | Skip ([in] ULONG celt)
skip some items in sequence. More...

HRESULT | Reset ()
reset or reinit iterator to sequence start. More...

HRESULT | Clone ([out] IEnumLogRecords **ppEnum)
make the identical enumerator. More...

Detailed Description

interface for acessing log records.

Member Function Documentation

HRESULT Next | ( | [in] ULONG | celt,
 |  | [out,size_is(celt),length_is(*pCeltFetched)] LM_RECORD * | rgVar,
 |  | [out] ULONG * | pCeltFetched
 | ) |

iterate throw records.

Return values:
S_OK | - if all items successfuly retrieved
S_FALSE | - if not all (or non) items retrieved
E_ | -if any critical errror
Parameters:
celt | how many items to retieve
rgVar | pointer to array of retrieved items
pCeltFetched | how many retrived

HRESULT Skip ( [in] ULONG celt )

skip some items in sequence.

Return values:
S_OK | - if all items successfuly skiped
E_ | -if any critical errror
Parameters:
celt how many items to skip

HRESULT Reset ( )

reset or reinit iterator to sequence start.

Return values:
S_OK | - if all items successfuly skiped
E_ | -if any critical errror

HRESULT Clone ( [out] IEnumLogRecords ** ppEnum )

make the identical enumerator.

Return values:
S_OK | - if all items successfuly skiped
E_ | -if any critical errror

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IEnumLONG Interface Reference

LONG enumarator. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

HRESULT | Next ([in] ULONG celt,[out, size_is(celt), length_is(*pCeltFetched)] long *nVar,[out] ULONG *pCeltFetched)
Get next LONG.

HRESULT | Skip ([in] ULONG celt)
Skip next LONG.

HRESULT | Reset ()
Reset enumerator.

HRESULT | Clone ([out] IEnumLONG **ppEnum)
Clone enumerator.

Detailed Description

LONG enumarator.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IEnumSecurityUsers Interface Reference

Security users enumerator. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

HRESULT | Next ([in] ULONG celt,[out, size_is(celt), length_is(*pCeltFetched)] ISecurityUser **rgVar,[out] ULONG *pCeltFetched)
Get next user.

HRESULT | Skip ([in] ULONG celt)
Skip next user.

HRESULT | Reset ()
Reset enumerator.

HRESULT | Clone ([out] IEnumSecurityUsers **ppEnum)
Clone enumerator.

Detailed Description

Security users enumerator.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IEnumStructureItem Interface Reference

Enumerator of structure item objects. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

HRESULT | Next ([in] ULONG celt,[out, size_is(celt), length_is(*pCeltFetched)] IStructureItem **rgVar,[out] ULONG *pCeltFetched)
Get next structure item object.

HRESULT | Skip ([in] ULONG celt)
Skip next structure item object.

HRESULT | Reset ()
Reset objects iterating.

HRESULT | Clone ([out] IEnumStructureItem **ppEnum)
Clone objects iterator.

Detailed Description

Enumerator of structure item objects.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IGraphicsChannelObject Interface Reference

Graphics channel object interface (GUI). More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

HRESULT | Position ([out, retval] POINT *pVal)
Get object position in editor.

HRESULT | Position ([in] POINT newVal)
Set object position in editor.

HRESULT | DrawChannelItem ([in] HDC hDC,[in] long nXShift,[in] long nYShift)
Draw channel object.

HRESULT | HitTest ([in] POINT pt,[out] GCO_HT_INFO *pHitTestInfo)
Hit test area of editor.

HRESULT | GetBoundsRect ([out] RECT *prcBounds)
Get bounds rect of object.

Detailed Description

Graphics channel object interface (GUI).

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IGroupData Interface Reference

Group data interface. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

HRESULT | GetDataEnum ([out] IEnumChannelData **ppEnum)
Get channel data enumerator.

HRESULT | AddData ([in] IChannelData *Data)
Add data to group.

HRESULT | RemoveData ([in] IChannelData *Data)
Remove data from group.

HRESULT | RemoveAllData ()
Remove all data from group.

Detailed Description

Group data interface.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IImageData Interface Reference

Image data interface. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

HRESULT | Width ([out, retval] long *pVal)
Get width of image.

HRESULT | Width ([in] long newVal)
Set width of image.

HRESULT | Height ([out, retval] long *pVal)
Get height of image.

HRESULT | Height ([in] long newVal)
Set height of image.

HRESULT | BPP ([out, retval] long *pVal)
Get BPP of image.

HRESULT | BPP ([in] long newVal)
Set BPP of image.

HRESULT | LockBuffer ([out] void **ppBuffer)
Lock buffer in memory and return it's address.

HRESULT | UnlockBuffer ()
Unlock buffer.

HRESULT | BPL ([out, retval] long *pVal)
Get BPL of image.

HRESULT | BPL ([in] long newVal)
Set BPL of image.

Detailed Description

Image data interface.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


ILocalizationManager Interface Reference

Localization Manager. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

HRESULT | SetLocalization ([in] BSTR Language)
Set language code.

HRESULT | GetStorage ([out] ILocalizationStorage **pStorage)
Get localization storage.

HRESULT | GetLocalization ([out] BSTR *pLanguage)
Get default language code.

HRESULT | Languages ([out, retval] IEnumLanguageCodes **pVal)
Get language codes enumerator.

HRESULT | LanguageName ([in] BSTR bsLangCode,[out, retval] BSTR *pVal)
Get language name for specified code.

HRESULT | LanguageName ([in] BSTR bsLangCode,[in] BSTR newVal)
Set language name for specified code.

HRESULT | AddLanguage ([in] BSTR bsLangCode,[in] BSTR bsLangName)
Add new localization language.

HRESULT | RemoveLanguage ([in] BSTR bsLangCode)
remove localization language.

Detailed Description

Localization Manager.

See also:
_ILocalizationEvents

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


ILocalizationSetup Interface Reference

Manage localization for localization storage. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

HRESULT RebuildStorageForLanguage ([in] BSTR bsLang)
Rebuild storage for new language code.

Detailed Description

Manage localization for localization storage.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:59 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


ILocalizationStorage Interface Reference

Localization storage interface. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

HRESULT LoadString ([in] REFGUID refguid,[in] long resId,[out, retval] BSTR *pVal)
Load string from storage.

Detailed Description

Localization storage interface.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:59 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


ILogManager Interface Reference

Log manager. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

HRESULT | AllRecords ([out, retval] IEnumLogRecords **ppEnum)
get enumerator for all records. More...

HRESULT | ShowLogWindow ([in] HWND hOwner)
Show log records view dlg. More...

HRESULT | InsertRecord ([in] LM_RECORD *pRecord)
insert new log record. More...

Detailed Description

Log manager.

Member Function Documentation

HRESULT AllRecords ( [out, retval] IEnumLogRecords ** ppEnum )

get enumerator for all records.

Return values:
S_OK | - if all ok
E_ | -if any critical errror

HRESULT ShowLogWindow ( [in] HWND hOwner )

Show log records view dlg.

Parameters:
hOwner parent window

HRESULT InsertRecord ( [in] LM_RECORD * pRecord )

insert new log record.

Return values:
S_OK | - if all ok
E_ | -if any critical errror
Parameters:
pRecord reference to LM_RECORD structure

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:59 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


ILogManagerClient Interface Reference

Interface that recomended to support for any objects that acces log manager. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

HRESULT | LogManager ([out, retval] ILogManager **ppVal)
HRESULT | EnableLoging ([in] BOOL bEnable)
Enable or disable logging for object. More...

Detailed Description

Interface that recomended to support for any objects that acces log manager.

Member Function Documentation

HRESULT LogManager ( [out, retval] ILogManager ** ppVal )

Return values:
S_OK | - if all ok
E_ | -if any critical errror
Currently | used pointer to log manager

HRESULT EnableLoging ( [in] BOOL bEnable )

Enable or disable logging for object.

Return values:
S_OK | - if all ok
E_ | -if any critical errror

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:59 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IMainBar Interface Reference

Main bar interface. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

HRESULT | RegisterMainBarButton ([in] long nTopOffsetFactor,[in] BSTR bsTitle,[in] HBITMAP hBmp,[in] IMainBarNotifyListener *pClickListener,[out] DWORD *pdwCookie)
Register bar button.

HRESULT | UnregisterMainBarButton ([in] DWORD dwCookie)
Unregister bar button.

HRESULT | SetMainBarButtonTitle ([in] DWORD dwCookie,[in] BSTR bsTitle)
Set bar button title.

Detailed Description

Main bar interface.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:59 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IMainBarNotifyListener Interface Reference

Main bar notifications. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

HRESULT OnMainBarButtonClicked ([in] DWORD dwCookie)
Clicked on bar button.

Detailed Description

Main bar notifications.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:59 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


ISecurityGroup Interface Reference

Security group interface. More...

#include <VideoSurvDll.idl>

List of all members.

Detailed Description

Security group interface.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:59 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


ISecurityItem Interface Reference

Security item. More...

#include <VideoSurvDll.idl>

List of all members.

Detailed Description

Security item.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:25:59 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


ISecurityManager Interface Reference

Security manager. More...

#include <VideoSurvDll.idl>

List of all members.

Detailed Description

Security manager.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:26:00 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


ISecurityUser Interface Reference

Security user interface. More...

#include <VideoSurvDll.idl>

List of all members.

Detailed Description

Security user interface.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:26:00 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IStructureItem Interface Reference

Structure support. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

HRESULT | SIName ([out, retval] BSTR *pVal)
Get structure item name.

HRESULT | SIName ([in] BSTR newVal)
Set structure item name.

HRESULT | SIDescription ([out, retval] BSTR *pVal)
Get structure item description.

HRESULT | SIDescription ([in] BSTR newVal)
Set structure item description.

HRESULT | ClsID ([out, retval] CLSID *pVal)
Get structure item CLSID.

HRESULT | ObjectID ([out, retval] long *pVal)
Get structure item object ID.

HRESULT | ObjectID ([in] long newVal)
Set structure item object ID.

HRESULT | Application ([out, retval] IApplication **pVal)
Get structure item Application property.

HRESULT | Application ([in] IApplication *newVal)
Set structure item Application property.

HRESULT | Parent ([out, retval] IStructureItem **pVal)
Get structure item Parent property.

HRESULT | Parent ([in] IStructureItem *newVal)
Set structure item Parent property.

HRESULT | CanClose ()
Can close structure item object?

HRESULT | Init ()
Init structure item object.

HRESULT | PostInit ()
Post init structure item object.

void | PreClose ()
Pre close structure item object.

void | Close ()
Close structure item object.

HRESULT | LoadItem ([in] IStorage *pIParentStorage,[in] BOOL bGlobalWorkspace)
Load structure item object from storage.

HRESULT | SaveItem ([in] IStorage *pIParentStorage,[in] BOOL bGlobalWorkspace)
Save structure item object to storage.

Detailed Description

Structure support.

See also:
_IStructureItemEvents

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:26:00 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IStructureItemImpl Class Reference

Base implementation of structure item. More...

#include <StructSupport.h>

Inheritance diagram for IStructureItemImpl::

CChannelDisplay CChannelSwitcher IStructureLevelImpl List of all members.

Public Methods

STDMETHOD (Init)()
simple implementation.

STDMETHOD (PostInit)()
simple implementation.

STDMETHOD (CanClose)()
simple implementation.

STDMETHOD_ (void, PreClose)()
simple implementation.

STDMETHOD_ (void, Close)()
simple implementation.

STDMETHOD (get_ClsID)(CLSID *pVal)
simple implementation.

STDMETHOD (get_Application)(IApplication **pVal)
simple implementation.

STDMETHOD (put_Application)(IApplication *pVal)
simple implementation.

STDMETHOD (get_Parent)(IStructureItem **pVal)
simple implementation.

STDMETHOD (put_Parent)(IStructureItem *pVal)
simple implementation.

STDMETHOD (get_SIName)(BSTR *pVal)
simple implementation
Exceptions:
E_NOTIMPL .

STDMETHOD (put_SIName)(BSTR newVal)
simple implementation
Exceptions:
E_NOTIMPL .

STDMETHOD (get_SIDescription)(BSTR *pVal)
simple implementation
Exceptions:
E_NOTIMPL .

STDMETHOD (put_SIDescription)(BSTR newVal)
simple implementation
Exceptions:
E_NOTIMPL .

STDMETHOD (get_ObjectID)(long *pVal)
simple implementation.

STDMETHOD (put_ObjectID)(long newVal)
simple implementation.

STDMETHOD (LoadItem)(IStorage *pIParentStorage, BOOL bGlobalWorkspace)
simple implementation.

STDMETHOD (SaveItem)(IStorage *pIParentStorage, BOOL bGlobalWorkspace)
simple implementation.

HRESULT | SISave (IStream *pIStream)
Save Structure Item Object. More...

HRESULT | SILoad (IStream *pIStream)
Load Structure Item Object. More...

HRESULT | AssignIStructureItem (IUnknown *pSrc)
Copy all data through IStructureItem interface from pSrc.

Public Attributes

REFCLSID | m_ClsID
class identifier of object.

long | m_nObjectID
object id.

CComPtr< IStructureItem > | m_oParent
parent object.

CComPtr< IApplication > | m_oApplication
application object.

Protected Methods

virtual void | LockObjectFunc () PURE
abstract lock function. More...

virtual void | UnlockObjectFunc () PURE
abstract unlock function. More...

Detailed Description

Base implementation of structure item.

Member Function Documentation

virtual void LockObjectFunc ( ) [protected, virtual]

abstract lock function.

See also:
DECLARE_OBJECT_LOCKS_FUNCTIONS()

virtual void UnlockObjectFunc ( ) [protected, virtual]

abstract unlock function.

See also:
DECLARE_OBJECT_LOCKS_FUNCTIONS()

HRESULT SISave ( IStream * pIStream ) [inline]

Save Structure Item Object.

See also:
SaveVersion() , WriteSignature()

HRESULT SILoad ( IStream * pIStream ) [inline]

Load Structure Item Object.

See also:
SaveVersion() , WriteSignature()

The documentation for this class was generated from the following file:
  • StructSupport.h
Generated on Tue Dec 25 18:26:00 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IStructureLevel Interface Reference

Structure level. More...

#include <VideoSurvDll.idl>

List of all members.

Public Methods

HRESULT | SubItems ([out] IEnumStructureItem **ppEnum)
Get subitems iterator.

HRESULT | SubItemByClsID ([in] REFIID clsid,[out] IEnumStructureItem **ppEnum)
Get specified subitems iterator.

HRESULT | SubItemByID ([in] long ObjectID,[out, retval] IStructureItem **pVal)
Get specified subitem.

Detailed Description

Structure level.

See also:
_IStructureLevelEvents

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:26:00 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IStructureLevelImpl Class Reference

Base implementation of structure level object. More...

#include <StructSupport.h>

Inheritance diagram for IStructureLevelImpl::

IStructureItemImpl List of all members.

Public Methods

virtual HRESULT | DoPreInitStructureItem (IStructureItem *pIObject)
overload this funcntion for additional initializing object.

virtual HRESULT | DoPostUninitStructureItem (IStructureItem *pIObject)
overload this funcntion for additional uninitializing object.

virtual void | AfterAddObjectToLevelVrt (IStructureItem *pIObject)
overload this method for additional managing (for example notify).

virtual void | BeforeRemoveObjectFromLevelVrt (IStructureItem *pIObject)
overload this method for additional managing (for example notify).

virtual void | AfterRemoveObjectFromLevelVrt ()
overload this method for additional managing (for example notify).

STDMETHOD (Init)()
structure level realization of method.

STDMETHOD (PostInit)()
structure level realization of method.

STDMETHOD (CanClose)()
structure level realization of method.

STDMETHOD_ (void, PreClose)()
structure level realization of method.

STDMETHOD_ (void, Close)()
structure level realization of method.

STDMETHOD (get_SubItems)(IEnumStructureItem **ppEnum)
structure level method.

STDMETHOD (get_SubItemByClsID)(REFIID clsid, IEnumStructureItem **ppEnum)
structure level method.

STDMETHOD (get_SubItemByID)(long ObjectID, IStructureItem **pVal)
structure level method.

HRESULT | AddObjectToLevel (IUnknown *pIObjUnk, long *pnObjectID=NULL, BOOL bInit=FALSE)
add specified object to structure level.

HRESULT | RemoveObjectFromLevel (IUnknown *pObjectUnk)
remove object from level.

HRESULT | RemoveAllObjectsFromLevel (BOOL bDoUninit=FALSE)
remove all objects from level.

HRESULT | LoadItemsFromWorkspace (IStorage *pIStorage, BOOL bGlobalWorkspace)
call this method for load items state from Workspace Storage.

HRESULT | SaveItemsToWorkspace (IStorage *pIStorage, BOOL bGlobalWorkspace)
call this method for save items state to Workspace Storage.

int | GenerateNewObjectID ()
generate new ObjectID.

HRESULT | SLSave (IStream *pIStream, BOOL bRecursed=TRUE)
Save Structure Level Object.

HRESULT | SLLoad (IStream *pIStream, BOOL bRecursed=TRUE)
Load Structure Level Object.

Protected Attributes

vector< CComPtr< IStructureItem > > | m_arSubItems
structure level list.

long | m_nLastObjectsID
Object ID counter.

Detailed Description

Base implementation of structure level object.

The documentation for this class was generated from the following file:
  • StructSupport.h
Generated on Tue Dec 25 18:26:00 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IVideoInputConnector Interface Reference

Connector input interface. More...

#include <VideoSurvDll.idl>

List of all members.

Detailed Description

Connector input interface.

See also:
_IVideoInputConnectorEvents

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:26:00 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IVideoInputConnectorInternal Interface Reference

Internal interface for video input connector object. More...

#include <VideoSurvDll.idl>

List of all members.

Detailed Description

Internal interface for video input connector object.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:26:00 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IVideoOutputConnector Interface Reference

Connector output interface. More...

#include <VideoSurvDll.idl>

List of all members.

Detailed Description

Connector output interface.

See also:
_IVideoOutputConnectorEvents

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:26:01 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IVideoOutputConnectorInternal Interface Reference

Internal interface for video output connector object. More...

#include <VideoSurvDll.idl>

List of all members.

Detailed Description

Internal interface for video output connector object.

The documentation for this interface was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:26:01 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


LM_RECORD Struct Reference

log manager record. More...

#include <VideoSurvDll.idl>

List of all members.

Public Attributes

LM_RECTYPE nRecType
log manager type.

DATE | tTime
time.

BSTR | bsExciter
log record exciter, i.e. hoo write this action.

BSTR | bsUser
user loged at the same time when record writen.

BSTR | bsText
log record text.

Detailed Description

log manager record.

The documentation for this struct was generated from the following files:
  • VideoSurvDll.h
  • VideoSurvDll.idl
Generated on Tue Dec 25 18:26:01 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Hierarchical Index

VideoSurveillanceSystem Class Hierarchy

This inheritance list is sorted roughly, but not completely, alphabetically:
  • _IApplicationStateEvents
  • _IAppWindowEvents
  • _IChannelEvents
  • _IChildWindowEvents
  • _IChildWindowManagerEvents
  • _IConnectorEvents
  • _IGraphicsChannelObject
  • _ILocalizationEvents
  • _IStructureItemEvents
  • _IStructureLevelEvents
  • _IVideoInputConnectorEvents
  • _IVideoOutputConnectorEvents
  • CAutoClassLocker
  • CAutoCSLocker
  • CChannelConnectors
  • CChannelSwitcherPropPage
  • CCircle
  • CConnectionPairs
  • CDataObjects
  • CLocAdvisor
  • CLocHelper
  • CLogHelper
  • CMultiAdvisor
  • CONNECT_INFO
    • CConnectInfo
  • CPoint
  • CRect
  • CRegistryList
  • CSecurityHelper
  • CSingleAdvisor
  • CSize
  • CStructureItems
  • GCO_HT_INFO
  • IAppConfigDlg
  • IApplication
  • IAppPropertySheet
  • IAppWindow
  • IAVISource
  • IAVITarget
  • IChannel
  • IChannelContainer
  • IChannelContainerRegistrar
  • IChannelData
  • IChannelDirector
  • IChannelDisplay
    • CChannelDisplay
  • IChannelManager
  • IChannelObject
  • IChannelObjectImpl
  • IChannelStructure
  • IChannelSwitcher
    • CChannelSwitcher
  • IChildWindow
  • IChildWindowImpl
    • CChannelDisplay
  • IChildWindowManager
  • IChildWindowRegistrar
  • ICloneObject
  • ICloneObjectImpl
  • IColorProcessingFilter
  • IColorSettings
  • IConnector
  • ICustomControlsPopupWindow
  • IDataObjectMinImpl
  • idlAVICOMPRESSOPTIONS
  • IDriverManager
  • IEnumBSTR
  • IEnumChannelData
  • IEnumConnectInfo
  • IEnumConnectors
  • IEnumLanguageCodes
  • IEnumLogRecords
  • IEnumLONG
  • IEnumSecurityUsers
  • IEnumStructureItem
  • IGraphicsChannelObject
  • IGroupData
  • IImageData
  • ILocalizationManager
  • ILocalizationSetup
  • ILocalizationStorage
  • ILogManager
  • ILogManagerClient
  • IMainBar
  • IMainBarNotifyListener
  • ISecurityGroup
  • ISecurityItem
  • ISecurityManager
  • ISecurityUser
  • IStructureItem
  • IStructureItemImpl
    • CChannelDisplay
    • CChannelSwitcher
    • IStructureLevelImpl
  • IStructureLevel
  • IVideoInputConnector
  • IVideoInputConnectorInternal
  • IVideoOutputConnector
  • IVideoOutputConnectorInternal
  • LM_RECORD
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Compound Member Index

VideoSurveillanceSystem Compound Members

a | b | c | d | e | f | g | h | i | l | m | n | o | p | r | s | t | u | w | ~

Here is a list of all documented class members with links to the classes they belong to:

- a -

  • AddConnector() : IChannelObjectImpl
  • AddControlCookie2AutoUnregister() : IChannelObjectImpl
  • AddData() : IGroupData
  • AddLanguage() : ILocalizationManager
  • AddLogMessage() : CLogHelper
  • AddObject() : IAppPropertySheet
  • AddObjectToChannel() : IChannelStructure
  • AddObjectToLevel() : IStructureLevelImpl
  • Advise() : CMultiAdvisor, CSingleAdvisor
  • AfterAddItemToLevel() : _IStructureLevelEvents
  • AfterAddObjectToLevelVrt() : IStructureLevelImpl
  • AfterChildWindowDestroy() : _IChildWindowEvents
  • AfterRemoveItemFromLevel() : _IStructureLevelEvents
  • AfterRemoveObjectFromLevelVrt() : IStructureLevelImpl
  • Align() : IConnector
  • AllRecords() : ILogManager
  • Application() : IStructureItem
  • AppWindow() : IApplication
  • Assign() : ICloneObject
  • AssignIStructureItem() : IStructureItemImpl
  • AssignPart() : ICloneObject
  • AVIFileName() : IAVISource
  • AVIFileNameBase() : IAVITarget

- b -
  • BeforeChildWindowDestroy() : _IChildWindowEvents
  • BeforeRemoveItemFromLevel() : _IStructureLevelEvents
  • BeforeRemoveObjectFromLevelVrt() : IStructureLevelImpl
  • BottomRight() : CRect
  • BPL() : IImageData
  • BPP() : IImageData
  • Brightness() : IColorSettings
  • bsExciter : LM_RECORD
  • bsText : LM_RECORD
  • bsUser : LM_RECORD

- c -
  • CanClose() : IStructureItem
  • CanCloseApplication() : IApplication
  • CAutoClassLocker() : CAutoClassLocker
  • CAutoCSLocker() : CAutoCSLocker
  • CChannelDisplay() : CChannelDisplay
  • CChannelSwitcher() : CChannelSwitcher
  • CChannelSwitcherPropPage() : CChannelSwitcherPropPage
  • CConnectInfo() : CConnectInfo
  • CConnectionPairs() : CConnectionPairs
  • CDataObjects() : CDataObjects
  • CenterPoint() : CRect
  • Channel() : IChannelObject
  • CheckSecurityRights() : CSecurityHelper
  • ClassType() : IConnector
  • clear() : CStructureItems, CChannelConnectors, CConnectionPairs, CDataObjects
  • CLocAdvisor() : CLocAdvisor
  • CLocHelper() : CLocHelper
  • CLogHelper() : CLogHelper
  • Clone() : IEnumLONG, IEnumBSTR, IEnumSecurityUsers, ICloneObject, IEnumChannelData, IEnumConnectors, IEnumConnectInfo, IEnumLogRecords, IEnumLanguageCodes, IEnumStructureItem
  • CloneID() : ICloneObject
  • Close() : IStructureItem
  • CloseApplication() : IApplication
  • ClsID() : IStructureItem
  • CMultiAdvisor() : CMultiAdvisor
  • CompressOptions() : IAVITarget
  • Connect() : IConnector
  • ConnectionPairs() : IChannelStructure
  • ConnectObjects() : IChannelStructure
  • ContainerRegistrar() : IChannelStructure
  • Contrast() : IColorSettings
  • CoveringForm() : IChildWindowManager
  • CreateChildWindow() : IChildWindow
  • CreateNewChannel() : IChannelManager
  • CSingleAdvisor() : CSingleAdvisor
  • CStructureItems() : CStructureItems

- d -
  • DataType() : IConnector
  • DeleteFreeConnector() : CChannelSwitcher
  • DestroyChildWindow() : IChildWindow
  • Disconnect() : IConnector
  • DisconnectObjects() : IChannelStructure
  • DoConfig() : IAppConfigDlg
  • DoModal() : IAppPropertySheet
  • DoPostUninitStructureItem() : IStructureLevelImpl
  • DoPreInitStructureItem() : IStructureLevelImpl
  • DrawChannelItem() : IGraphicsChannelObject
  • dwFlags : GCO_HT_INFO

- e -
  • Empty() : CRect
  • EnableLoging() : ILogManagerClient
  • EraseChannel() : IChannelManager

- f -
  • FloatEnabled() : IChildWindowManager
  • FloatingState() : IChildWindow
  • FullScreen() : IAppWindow

- g -
  • GenerateNewObjectID() : IStructureLevelImpl
  • GetBoundsRect() : IGraphicsChannelObject
  • GetConnector() : CChannelConnectors
  • GetDataEnum() : IGroupData
  • GetExtent() : CCircle
  • GetLocalization() : ILocalizationManager
  • GetStorage() : ILocalizationManager

- h -
  • Height() : IImageData, CRect
  • HitTest() : IGraphicsChannelObject
  • htCode : GCO_HT_INFO
  • Hue() : IColorSettings
  • hWnd() : IAppWindow

- i -
  • ICloneObjectImpl() : ICloneObjectImpl
  • ID() : IConnector
  • InflateRect() : CRect
  • Init() : IStructureItem, CStructureItems, CRegistryList, CChannelConnectors, CConnectionPairs, CDataObjects
  • InputConnectors() : IChannelObject
  • InsertRecord() : ILogManager
  • IntersectRect() : CRect
  • IsAdvised() : CMultiAdvisor, CSingleAdvisor
  • IsConnected() : IConnector
  • IsConnectorInput() : IConnector
  • IsEmpty() : CRect
  • IsEqual() : ICloneObject
  • IsRunning() : IApplication
  • IsValidID() : CChannelConnectors

- l -
  • LanguageName() : ILocalizationManager
  • Languages() : ILocalizationManager
  • Load() : IChannelObjectImpl
  • LoadItem() : IStructureItem
  • LoadItemsFromWorkspace() : IStructureLevelImpl
  • LoadString() : ILocalizationStorage, CLocHelper, CLocAdvisor
  • LoadWorkspace() : IApplication
  • LocInit() : CLocHelper, CLocAdvisor
  • Lock() : CAutoCSLocker, CAutoClassLocker
  • LockBuffer() : IImageData
  • LockObjectFunc() : IStructureItemImpl
  • LocUninit() : CLocHelper, CLocAdvisor
  • LogInit() : CLogHelper
  • LogManager() : ILogManagerClient

- m -
  • m_arAutoUnregisterControlCookies : IChannelObjectImpl
  • m_ardwCookie : CMultiAdvisor
  • m_aroConnectors : IChannelObjectImpl
  • m_aroUnkCP : CMultiAdvisor
  • m_arSubItems : IStructureLevelImpl
  • m_ClsID : IStructureItemImpl
  • m_dwCookie : CSingleAdvisor
  • m_guidObject : CLocAdvisor
  • m_iid : CMultiAdvisor, CSingleAdvisor
  • m_nConnectorID : IChannelObjectImpl
  • m_nLastObjectsID : IStructureLevelImpl
  • m_nObjectID : IStructureItemImpl
  • m_oApplication : IStructureItemImpl
  • m_oChannel : IChannelObjectImpl
  • m_oContainerRegistrar : IChannelObjectImpl
  • m_oLocManager : CLocAdvisor
  • m_oLocStorage : CLocAdvisor
  • m_oParent : IStructureItemImpl
  • m_oStoredGroupData : CChannelSwitcher
  • m_oUnkCP : CSingleAdvisor
  • m_ptPos : IChannelObjectImpl
  • m_rcBounds : IChannelObjectImpl

- n -
  • nConnectorID : GCO_HT_INFO
  • Next() : IEnumLONG, IEnumBSTR, IEnumSecurityUsers, IEnumChannelData, IEnumConnectors, IEnumConnectInfo, IEnumLogRecords, IEnumLanguageCodes, IEnumStructureItem
  • nInConnectorID : CONNECT_INFO
  • nObjectID : GCO_HT_INFO
  • Normalize() : CRect
  • nOutConnectorID : CONNECT_INFO
  • nRecType : LM_RECORD
  • nSourceObjectID : CONNECT_INFO
  • nTargetObjectID : CONNECT_INFO

- o -
  • ObjectID() : IStructureItem
  • Offset() : IConnector
  • OnAddConnector() : IChannelObjectImpl, CChannelSwitcher, CChannelDisplay
  • OnAlignChanged() : _IConnectorEvents
  • OnAppLoadComplete() : _IApplicationStateEvents
  • OnChildWindowCreated() : _IChildWindowEvents
  • OnChildWindowFloatingStateChanged() : _IChildWindowEvents
  • OnChildWindowRectChanged() : _IChildWindowEvents
  • OnChildWindowVisibilityChanged() : _IChildWindowEvents
  • OnConnected() : _IConnectorEvents
  • OnCoveringFormChanged() : _IChildWindowManagerEvents
  • OnDataReady() : _IVideoInputConnectorEvents
  • OnDataReceived() : _IVideoInputConnectorEvents
  • OnDisconnected() : _IConnectorEvents
  • OnEraseBkgnd() : CChannelDisplay
  • OnFloatStateChanged() : _IChildWindowManagerEvents
  • OnGUIReady() : _IApplicationStateEvents
  • OnInitComplete() : _IApplicationStateEvents
  • OnLanguageChanged() : _ILocalizationEvents
  • OnMainBarButtonClicked() : IMainBarNotifyListener
  • OnOffsetChanged() : _IConnectorEvents
  • OnPaint() : CChannelDisplay
  • OnQueryData() : _IVideoOutputConnectorEvents
  • OnRemoveConnector() : IChannelObjectImpl, CChannelSwitcher, CChannelDisplay
  • OnScreenModeChanged() : _IAppWindowEvents
  • OnSendData() : _IVideoOutputConnectorEvents
  • OnShowAppWindow() : _IApplicationStateEvents
  • OnStructureItemDescriptionChanged() : _IStructureItemEvents
  • OnStructureItemNameChanged() : _IStructureItemEvents
  • OnTransferModeChanged() : _IChannelEvents
  • operator *() : CSize
  • operator+() : CRect, CPoint
  • operator+=() : CRect
  • operator-() : CRect, CPoint
  • operator-=() : CRect
  • operator/() : CSize
  • operator=() : CStructureItems, CConnectInfo, CDataObjects
  • operator==() : CConnectInfo
  • operator[]() : CStructureItems, CRegistryList, CConnectionPairs, CDataObjects
  • OutputConnectors() : IChannelObject, IChannelSwitcher

- p -
  • Parent() : IStructureItem
  • PointIn() : CCircle, CRect
  • Position() : IGraphicsChannelObject
  • PostInit() : IStructureItem
  • PostInitChannelObject() : IChannelObjectImpl
  • PreClose() : IStructureItem
  • ptOffset() : CChannelConnectors

- r -
  • RebuildStorageForLanguage() : ILocalizationSetup
  • RecalcCoordinates() : IChannelObjectImpl
  • RegisterChildWindow() : IChildWindowRegistrar
  • RegisterCustomControl() : ICustomControlsPopupWindow, IChannelContainerRegistrar
  • RegisterCustomControls() : IChannelObjectImpl, CChannelSwitcher, CChannelDisplay
  • RegisterMainBarButton() : IMainBar, IAppWindow
  • RemoveAll() : CRegistryList
  • RemoveAllData() : IGroupData
  • RemoveAllObjectsFromLevel() : IStructureLevelImpl
  • RemoveConnector() : IChannelObjectImpl
  • RemoveData() : IGroupData
  • RemoveLanguage() : ILocalizationManager
  • RemoveObjectFromChannel() : IChannelStructure
  • RemoveObjectFromLevel() : IStructureLevelImpl
  • Reset() : IEnumLONG, IEnumBSTR, IEnumSecurityUsers, IEnumChannelData, IEnumConnectors, IEnumConnectInfo, IEnumLogRecords, IEnumLanguageCodes, IEnumStructureItem
  • Run() : IApplication

- s -
  • Saturation() : IColorSettings
  • Save() : IChannelObjectImpl
  • SaveItem() : IStructureItem
  • SaveItemsToWorkspace() : IStructureLevelImpl
  • SaveWorkspace() : IApplication
  • SecurityInit() : CSecurityHelper
  • SetLocalization() : ILocalizationManager
  • SetMainBarButtonTitle() : IMainBar, IAppWindow
  • ShowLogWindow() : ILogManager
  • SIDescription() : IStructureItem
  • SILoad() : IStructureItemImpl
  • SIName() : IStructureItem
  • SISave() : IStructureItemImpl
  • size() : CStructureItems, CRegistryList, CConnectionPairs, CDataObjects
  • Skip() : IEnumLONG, IEnumBSTR, IEnumSecurityUsers, IEnumChannelData, IEnumConnectors, IEnumConnectInfo, IEnumLogRecords, IEnumLanguageCodes, IEnumStructureItem
  • SLLoad() : IStructureLevelImpl
  • SLSave() : IStructureLevelImpl
  • STDMETHOD() : IStructureLevelImpl, IStructureItemImpl, IDataObjectMinImpl, ICloneObjectImpl, CChannelSwitcherPropPage, CChannelSwitcher, CChannelDisplay
  • STDMETHOD_() : IStructureLevelImpl, IStructureItemImpl, CChannelSwitcher, CChannelDisplay
  • SubItemByClsID() : IStructureLevel
  • SubItemByID() : IStructureLevel
  • SubItems() : IStructureLevel

- t -
  • TopLeft() : CRect
  • TransferMode() : IChannel
  • tTime : LM_RECORD

- u -
  • Unadvise() : CMultiAdvisor, CSingleAdvisor
  • UninitChannelObject() : IChannelObjectImpl
  • UnionRect() : CRect
  • Unlock() : CAutoCSLocker, CAutoClassLocker
  • UnlockBuffer() : IImageData
  • UnlockObjectFunc() : IStructureItemImpl
  • UnregisterChildWindow() : IChildWindowRegistrar
  • UnregisterCustomControl() : ICustomControlsPopupWindow, IChannelContainerRegistrar
  • UnregisterCustomControls() : IChannelObjectImpl, CChannelSwitcher, CChannelDisplay
  • UnregisterMainBarButton() : IMainBar, IAppWindow
  • UpdateWindowPos() : ICustomControlsPopupWindow

- w -
  • Width() : IImageData, CRect
  • WindowRect() : IChildWindow
  • WindowVisibled() : IChildWindow

- ~ -
  • ~CAutoClassLocker() : CAutoClassLocker
  • ~CAutoCSLocker() : CAutoCSLocker
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Module Index

VideoSurveillanceSystem Modules

Here is a list of all modules:
  • Channel Items
  • Mathematic functions and classes
  • Common program types
  • Advisers classes
  • Channel support helpers
  • Drag and Drop support
  • Lock helpers
  • Errors handling
  • Stream support
  • Structure support helpers
  • Windows managing
  • Application structure
  • Program localization
  • Program events logging
  • Connectors group
  • Clonning objects
  • Security subsystem
  • Configurating application objects
Generated on Tue Dec 25 18:26:02 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Channel Items

Files

file | ChannelDisplay.h
CChannelDisplay class.

file | ChannelSwitcher.h
CChannelSwitcher class.

file | ChannelSwitcherPropPage.h
CChannelSwitcherPropPage class.

Compounds

class | CChannelDisplay
CChannelDisplay class. More...

struct | idlAVICOMPRESSOPTIONS
idlAVICOMPRESSOPTIONS. More...

interface | IAVISource
AVI Source interface. More...

interface | IAVITarget
AVI Target interface. More...

interface | IChannelDisplay
Channel display interface. More...

interface | IColorProcessingFilter
Color Processing Filter interface. More...

interface | IChannelSwitcher
Channel Switcher interface. More...

class | CChannelSwitcher
CChannelSwitcher class. More...

class | CChannelSwitcherPropPage
CChannelSwitcherPropPage class. More...

Typedefs

typedef idlAVICOMPRESSOPTIONS | idlAVICOMPRESSOPTIONS
idlAVICOMPRESSOPTIONS.

Generated on Tue Dec 25 18:26:01 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Mathematic functions and classes

Defines

#define | Round(f) (int)( (f) >= 0 ? (f) + .5 : (f) - .5 )
Round float value.

Functions

double | Distance (POINT &a, POINT &b)
Distance betwen two points.

void | NormalizeDbl (double &f, int nMaxPrec=2)
Round up value with pointed precision.

Generated on Tue Dec 25 18:26:01 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common program types

Files

file | 2DStruct.h
file | VideoSurvDll.idl

Compounds

class | CPoint
Point object. More...

class | CSize
Size object (see windows SIZE). More...

class | CRect
Rectangle object. More...

class | CCircle
Circle object. More...

Generated on Tue Dec 25 18:26:01 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Advisers classes

Files

file | Advisers.h
Advisers classes.

Compounds

class | CSingleAdvisor
Advise to single object. More...

class | CMultiAdvisor
Advise to multile objects. More...

class | CLocAdvisor
Advise to localization manager. More...

class | CLocHelper
class uses as helper while loading strings. More...

class | CLogHelper
class used as helper to acces for log manager. More...

class | CSecurityHelper
class used as helper to security manager. More...

Generated on Tue Dec 25 18:26:01 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Channel support helpers

Compounds

class | CDataObjects
Channel data array. More...

class | CConnectInfo
Helper class keeping information about two channel objects connection. More...

class | CConnectionPairs
Helper class for iterating and keeping connections between channel objects. More...

class | IChannelObjectImpl
Base class for channel object. More...

interface | IChannel
Channel interface. More...

interface | IChannelStructure
Interface manage channel structure. More...

interface | IChannelContainerRegistrar
Channel container registrar interface. More...

interface | IChannelContainer
Channel container interface. More...

interface | IEnumConnectors
Channel connectors enumerator. More...

interface | IChannelObject
Channel object interface. More...

interface | ICustomControlsPopupWindow
Custom controls popup window. More...

Defines

#define | ICHANNELOBJECTIMPL_ENTRIES
COM MAP entries for channel object. More...

Define Documentation

#define ICHANNELOBJECTIMPL_ENTRIES

Value:

COM_INTERFACE_ENTRY(IChannelObject)                             \
        COM_INTERFACE_ENTRY(IGraphicsChannelObject)     \
COM MAP entries for channel object.

Generated on Tue Dec 25 18:26:01 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Drag and Drop support

Files

file | DragDropSupport.h
Drag and drop support.

Compounds

class | IDataObjectMinImpl
base class for data object with minimal support. More...

Defines

#define | IDATAOBJECTMINIMPL_ENTRIES COM_INTERFACE_ENTRY(IDataObject) \
COM MAP entries.

Generated on Tue Dec 25 18:26:01 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Lock helpers

Files

file | Lockers.h
Header for simple lock support.

Compounds

class | CAutoClassLocker
Class object locker. More...

class | CAutoCSLocker
Critical section object locker. More...

Defines

#define | AUTO_LOCKER CAutoClassLocker<_CoClass> _clsLoker( this )
AUTO_LOCKER macros. More...

#define | AUTO_LOCKER_LOCK _clsLoker.Lock()
AUTO_LOCKER_LOCK macros. More...

#define | AUTO_LOCKER_UNLOCK _clsLoker.Unlock()
AUTO_LOCKER_UNLOCK macros. More...

#define | AUTO_CS_LOCKER_LOCK _csLocksr.Lock()
AUTO_CS_LOCKER_LOCK macros. More...

#define | AUTO_CS_LOCKER_UNLOCK _csLocksr.Unlock()
AUTO_CS_LOCKER_UNLOCK macros. More...

#define | AUTO_CS_LOCKER(cs) CAutoCSLocker _csLocksr( &cs )
AUTO_CS_LOCKER macros. More...

Functions

template<class TClass, class TClassValue, class TValue> HRESULT | CopyClassValueTo (TClass *pClass, TClassValue &Value, TValue *pValue)
Safe copy class variable to pointered variable use thread locks. More...

template<class TClass, class TClassValue, class TValue> HRESULT | CopyClassInterfaceValueTo (TClass *pClass, TClassValue &oValue, TValue *pValue)
Safe copy class interface variable to pointered variable use thread locks. More...

template<class TClass, class TValue> TValue | CopyClassValue (TClass *pClass, TValue &ClassValue)
Safe get class variable use thread locks. More...

Define Documentation

#define AUTO_LOCKER CAutoClassLocker<_CoClass> _clsLoker( this )

AUTO_LOCKER macros.

Insert class locker object and construct it.

#define AUTO_LOCKER_LOCK _clsLoker.Lock()

AUTO_LOCKER_LOCK macros.

Lock class locker object

#define AUTO_LOCKER_UNLOCK _clsLoker.Unlock()

AUTO_LOCKER_UNLOCK macros.

Unlock class locker object

#define AUTO_CS_LOCKER_LOCK _csLocksr.Lock()

AUTO_CS_LOCKER_LOCK macros.

Lock locker object for critical section

#define AUTO_CS_LOCKER_UNLOCK _csLocksr.Unlock()

AUTO_CS_LOCKER_UNLOCK macros.

Unlock locker object for critical section

#define AUTO_CS_LOCKER ( cs ) CAutoCSLocker _csLocksr( &cs )

AUTO_CS_LOCKER macros.

Insert critical section locker object and construct it.

Parameters:
cs Name of critical section variable

Function Documentation

HRESULT CopyClassValueTo | ( | TClass * | pClass,
 |  | TClassValue & | Value,
 |  | TValue * | pValue
 | ) |

Safe copy class variable to pointered variable use thread locks.

Parameters:
pClass | class
Value | value
pValue | pointer to variable

HRESULT CopyClassInterfaceValueTo | ( | TClass * | pClass,
 |  | TClassValue & | oValue,
 |  | TValue * | pValue
 | ) |

Safe copy class interface variable to pointered variable use thread locks.

Parameters:
pClass | class
oValue | value
pValue | pointer to variable

TValue CopyClassValue | ( | TClass * | pClass,
 |  | TValue & | ClassValue
 | ) |

Safe get class variable use thread locks.

Parameters:
pClass | class
ClassValue | variable

Generated on Tue Dec 25 18:26:01 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Errors handling

Files

file | ErrorHandlers.h
Header for simple error handle support.

Defines

#define | _Verify(b) { if ( ! ( b ) ) ATLASSERT( FALSE ); }
in case b fails only show debug warning.

#define | _ComVerify(hr) { if ( FAILED( hr ) ) ATLASSERT( FALSE ); }
perform COM call and if it failed only show debug warning.

#define | _VerifyRX(b, ret) { if ( ! ( b ) ) { ATLASSERT( FALSE ); return ret; } }
in case b fails show debug warning and return ret.

#define | _ComVerifyRX(hr, ret) { if ( FAILED( hr ) ) { ATLASSERT( FALSE ); return ret; } }
perform COM call and if it failed show debug warning and return ret.

#define | _CallRX(b, ret) { if ( ! ( b ) ) return ret; }
perform call and return ret if failed.

#define | _ComCallRX(hr, ret) { if ( FAILED( hr ) ) return ret; }
perform call and return ret if failed.

#define | _VerifyRV(b) { if ( ! ( b ) ) { ATLASSERT( FALSE ); return; } }
in case b fails show debug warning and return.

#define | _ComVerifyRV(hr) { if ( FAILED( hr ) ) { ATLASSERT( FALSE ); return; } }
perform COM call and if it failed show debug warning and return.

#define | _CallRV(b) { if ( ! ( b ) ) return; }
perform call and return if failed.

#define | _ComCallRV(hr) { if ( FAILED( hr ) ) return; }
perform call and return if failed.

#define | _VerifyES(b) { if ( ! ( b ) ) { ATLASSERT( FALSE ); throw AtlReportError( CLSID_NULL, ( std::string( "File " ) + __FILE__ + "\nLine " + itoa( __LINE__, __ERRORLINE__, 4 ) + "\n" + GetErrorDescription() ).c_str(), IID_NULL, NULL ); } }
perform call and if it failed explain line of code and file where error happens.

#define | _VerifyRS(b) { if ( ! ( b ) ) { ATLASSERT( FALSE ); return AtlReportError( CLSID_NULL, ( std::string( "File " ) + __FILE__ + "\nLine " + itoa( __LINE__, __ERRORLINE__, 4 ) + "\n" + GetErrorDescription() ).c_str(), IID_NULL, NULL ); } }
perform call and if it failed explain line of code and file where error happens.

#define | _CallES(b, er) { if ( ! ( b ) ) { throw AtlReportError( CLSID_NULL, (std::string(er)+"\n"+GetErrorDescription()).c_str(), IID_NULL, NULL ); } }
perform call and throw specified error item and COM error description.

#define | _CallRS(b, er) { if ( ! ( b ) ) { return AtlReportError( CLSID_NULL, (std::string(er)+"\n"+GetErrorDescription()).c_str(), IID_NULL, NULL ); } }
perform call and return specified error item and COM error description.

#define | _ComCallES(hr, er) { if ( FAILED( hr ) ) { throw AtlReportError( CLSID_NULL, (std::string(er)+"\n"+GetErrorDescription()).c_str(), IID_NULL, NULL ); } }
perform com call and throw specified error item and COM error description.

#define | _ComVerifyES(hr) { if ( FAILED( hr ) ) { ATLASSERT( FALSE ); throw AtlReportError( CLSID_NULL, ( std::string( "File " ) + __FILE__ + "\nLine " + itoa( __LINE__, __ERRORLINE__, 4 ) + "\n" + GetErrorDescription() ).c_str(), IID_NULL, NULL ); } }
perform COM call and if it failed explain line of code and file where error happens.

#define | _ComCallRS(hr, er) { if ( FAILED( hr ) ) { return AtlReportError( CLSID_NULL, (std::string(er)+"\n"+GetErrorDescription()).c_str(), IID_NULL, NULL ); } }
perform com call and return specified error item and COM error description.

#define | _ComCallRH(HR) { HRESULT hr = HR; if ( FAILED( hr ) ) { return hr; } }
Simply return error if call failed.

Functions

std::string | GetLastErrorStr (DWORD dwErrorCode=-1)
Get error string from error code.

std::string | GetErrorDescriptionStr (IUnknown *pI, REFIID riid)
Helper for retrieving error decription. More...

std::string | GetErrorDescription ()
Simple get error description. More...

Function Documentation

std::string GetErrorDescriptionStr | ( | IUnknown * | pI,
 |  | REFIIDriid |
 | ) | [inline]

Helper for retrieving error decription.

Parameters:
pI interface, which return error

std::string GetErrorDescription ( ) [inline]

Simple get error description.

Get string from global error object. Not using interface or interface identifiers.

Generated on Tue Dec 25 18:26:01 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Stream support

Files

file | StreamHelpers.h
Stream support classes and functions.

Functions

template<class TVer> HRESULT | SaveVersion (IStream *pIStream, TVer Version)
save version to storage. More...

template<class TVer> TVer | LoadVersion (IStream *pIStream)
Load version from storage. More...

HRESULT | SaveSignature (IStream *pIStream, LPCTSTR szSignature)
save string signature to storage. More...

BOOL | CheckSignature (IStream *pIStream, LPCTSTR szSignature)
Check Signature with saved in storage. More...

Function Documentation

HRESULT SaveVersion | ( | IStream * | pIStream,
 |  | TVer | Version
 | ) |

save version to storage.

Parameters:
TVer | Type of version variable
pIStream | Stream for save
Version | current version

TVer LoadVersion ( IStream * pIStream )

Load version from storage.

Parameters:
TVer | Type of version variable
pIStream | Stream for load
Exceptions:
Stream error if fail

HRESULT SaveSignature | ( | IStream * | pIStream,
 |  | LPCTSTR | szSignature
 | ) | [inline]

save string signature to storage.

Parameters:
pIStream | Stream for save
szSignature | Signature for saving

BOOL CheckSignature | ( | IStream * | pIStream,
 |  | LPCTSTR | szSignature
 | ) | [inline]

Check Signature with saved in storage.

Parameters:
pIStream | Stream for load
szSignature | Signature for checking
Exceptions:
Stream error if fail

Generated on Tue Dec 25 18:26:01 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Structure support helpers

Compounds

class | IStructureItemImpl
Base implementation of structure item. More...

class | IStructureLevelImpl
Base implementation of structure level object. More...

class | CRegistryList
List of COM objects retrieving from system registry. More...

class | CStructureItems
Helper class for iterating and keeping structure level subitems. More...

interface | IStructureItem
Structure support. More...

interface | IEnumStructureItem
Enumerator of structure item objects. More...

interface | IStructureLevel
Structure level. More...

Defines

#define | DECLARE_OBJECT_LOCKS_FUNCTIONS()
MultiThread protection. More...

#define | ISTRUCTUREITEMIMPL_ENTRIES COM_INTERFACE_ENTRY(IStructureItem) \
COM MAP entries for structure item object.

#define | DECLARE_NOTIFY_LEVEL_CHANGES()
Realize event notifications. More...

#define | ISTRUCTURELEVELIMPL_ENTRIES
COM MAP entries for structure level object. More...

Functions

HRESULT | InitStructureObject (IUnknown *pIObjUnk)
Init and post init structure object. More...

template<class I> HRESULT | GetSertainSubItem (IUnknown *pStructireLevelObj, REFCLSID ClsID, I **ppISubItem)
get specified structure subitem from structure level object, return specified inerface (I). More...

long | GetObjectID (IUnknown *pObjectUnk)
Get channel object ID. More...

Define Documentation

#define DECLARE_OBJECT_LOCKS_FUNCTIONS ( )

Value:

virtual void LockObjectFunc() { Lock(); }                       \
        virtual void UnlockObjectFunc() { Unlock(); }   \
MultiThread protection.

Realize abstruct functions in last level class

#define DECLARE_NOTIFY_LEVEL_CHANGES ( )

Value:

virtual void AfterAddObjectToLevelVrt( IStructureItem* pIObject ) { Fire_AfterAddItemToLevel( pIObject ); }\
        virtual void BeforeRemoveObjectFromLevelVrt( IStructureItem* pIObject ) { Fire_BeforeRemoveItemFromLevel( pIObject ); } \
        virtual void AfterRemoveObjectFromLevelVrt() { Fire_AfterRemoveItemFromLevel(); }
Realize event notifications.

Realize abstruct functions in last level class

#define ISTRUCTURELEVELIMPL_ENTRIES

Value:

COM_INTERFACE_ENTRY(IStructureLevel)    \
        ISTRUCTUREITEMIMPL_ENTRIES                                      \
COM MAP entries for structure level object.

Function Documentation

HRESULT InitStructureObject ( IUnknown * pIObjUnk ) [inline]

Init and post init structure object.

Parameters:
pIObjUnk structure item object interface

HRESULT GetSertainSubItem | ( | IUnknown * | pStructireLevelObj,
 |  | REFCLSIDClsID | ,
 |  | I ** | ppISubItem
 | ) |

get specified structure subitem from structure level object, return specified inerface (I).

Parameters:
pStructireLevelObj | interface of structure level object
ppISubItem | result interface pointer

long GetObjectID ( IUnknown * pObjectUnk ) [inline]

Get channel object ID.

Parameters:
pObjectUnk stricture item object interface

Generated on Tue Dec 25 18:26:01 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Windows managing

Compounds

class | IChildWindowImpl
Child window interface support. More...

interface | IChildWindow
interface for controlling child window. More...

interface | IChildWindowRegistrar
interface for registering a list of child windows. More...

interface | IChildWindowManager
interface for managing a list of child windows. More...

Generated on Tue Dec 25 18:26:01 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Application structure

Compounds

interface | IApplication
Main interface of application object. More...

interface | IAppWindow
Application window. More...

interface | IChannelManager
Channel manager. More...

interface | ILocalizationManager
Localization Manager. More...

interface | ILocalizationSetup
Manage localization for localization storage. More...

interface | ILogManager
Log manager. More...

interface | IDriverManager
Driver manager. More...

interface | IGraphicsChannelObject
Graphics channel object interface (GUI). More...

interface | ISecurityManager
Security manager. More...

Generated on Tue Dec 25 18:26:01 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Program localization

Compounds

interface | IEnumLanguageCodes
Language codes enumerator. More...

interface | ILocalizationManager
Localization Manager. More...

interface | ILocalizationStorage
Localization storage interface. More...

Generated on Tue Dec 25 18:26:01 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Program events logging

Compounds

interface | IEnumLogRecords
interface for acessing log records. More...

interface | ILogManager
Log manager. More...

interface | ILogManagerClient
Interface that recomended to support for any objects that acces log manager. More...

Generated on Tue Dec 25 18:26:01 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Connectors group

Classes and interfaces for data transfer. More...

Compounds

class | CChannelConnectors
Channel connectors array. More...

interface | IConnector
Connector base interface. More...

interface | IVideoInputConnector
Connector input interface. More...

interface | IVideoInputConnectorInternal
Internal interface for video input connector object. More...

interface | IVideoOutputConnector
Connector output interface. More...

interface | IVideoOutputConnectorInternal
Internal interface for video output connector object. More...

Functions

HRESULT | ConnectConnectors (CComPtr< IConnector > oOutputConnector, CComPtr< IConnector > oInputConnector)
connect two connectors: output and input.

Detailed Description

Classes and interfaces for data transfer.

This classes and interfaces are used for object connectiong and data transferring between objects

Generated on Tue Dec 25 18:26:01 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Clonning objects

Files

file | CloneObjectImpl.h
Clone support.

Compounds

class | ICloneObjectImpl
interface | ICloneObject
Clone object interface. More...

Generated on Tue Dec 25 18:26:01 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Security subsystem

Compounds

interface | ISecurityUser
Security user interface. More...

interface | IEnumSecurityUsers
Security users enumerator. More...

interface | ISecurityGroup
Security group interface. More...

interface | ISecurityManager
Security manager. More...

interface | ISecurityItem
Security item. More...

Generated on Tue Dec 25 18:26:01 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Configurating application objects

Compounds

interface IAppPropertySheet
Application property sheet interface. More...

Generated on Tue Dec 25 18:26:01 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


File Member Index

VideoSurveillanceSystem File Members

_ | a | c | d | g | i | l | m | n | r | s | t | z

Here is a list of all documented file members with links to the documentation:

- _ -

  • _apiPOINT : TemplateHelpers.h
  • _apiRECT : TemplateHelpers.h
  • _apiRECT1 : TemplateHelpers.h
  • _CallES : ErrorHandlers.h
  • _CallRS : ErrorHandlers.h
  • _CallRV : ErrorHandlers.h
  • _CallRX : ErrorHandlers.h
  • _ComCallES : ErrorHandlers.h
  • _ComCallRH : ErrorHandlers.h
  • _ComCallRS : ErrorHandlers.h
  • _ComCallRV : ErrorHandlers.h
  • _ComCallRX : ErrorHandlers.h
  • _ComVerify : ErrorHandlers.h
  • _ComVerifyES : ErrorHandlers.h
  • _ComVerifyRV : ErrorHandlers.h
  • _ComVerifyRX : ErrorHandlers.h
  • _Verify : ErrorHandlers.h
  • _VerifyES : ErrorHandlers.h
  • _VerifyRS : ErrorHandlers.h
  • _VerifyRV : ErrorHandlers.h
  • _VerifyRX : ErrorHandlers.h

- a -
  • ALIGN_TYPE : VideoSurvDll.idl
  • alignBottom : VideoSurvDll.idl
  • alignFree : VideoSurvDll.idl
  • alignLeft : VideoSurvDll.idl
  • alignRight : VideoSurvDll.idl
  • alignTop : VideoSurvDll.idl
  • AR_SIZE : TemplateHelpers.h
  • AUTO_CS_LOCKER : Lockers.h
  • AUTO_CS_LOCKER_LOCK : Lockers.h
  • AUTO_CS_LOCKER_UNLOCK : Lockers.h
  • AUTO_LOCKER : Lockers.h
  • AUTO_LOCKER_LOCK : Lockers.h
  • AUTO_LOCKER_UNLOCK : Lockers.h

- c -
  • CHANNEL_MODE : VideoSurvDll.idl
  • CheckSignature() : StreamHelpers.h
  • CONNECT_INFO : VideoSurvDll.idl
  • CopyClassInterfaceValueTo() : Lockers.h
  • CopyClassValue() : Lockers.h
  • CopyClassValueTo() : Lockers.h
  • ctmInterleave : VideoSurvDll.idl
  • ctmParallel : VideoSurvDll.idl
  • ctmWaitComplete : VideoSurvDll.idl

- d -
  • Distance() : 2DStruct.h

- g -
  • GCO_HT_INFO : VideoSurvDll.idl
  • GCO_HTENUM : VideoSurvDll.idl
  • GCO_HTFLAGS : VideoSurvDll.idl
  • GetErrorDescription() : ErrorHandlers.h
  • GetErrorDescriptionStr() : ErrorHandlers.h
  • GetLastErrorStr() : ErrorHandlers.h
  • gofLinked : VideoSurvDll.idl
  • gofNone : VideoSurvDll.idl
  • gohtBody : VideoSurvDll.idl
  • gohtInputConnector : VideoSurvDll.idl
  • gohtNone : VideoSurvDll.idl
  • gohtOutputConnector : VideoSurvDll.idl

- i -
  • IDATAOBJECTMINIMPL_ENTRIES : DragDropSupport.h

- l -
  • LM_RECORD : VideoSurvDll.idl
  • LM_RECTYPE : VideoSurvDll.idl
  • LoadVersion() : StreamHelpers.h

- m -
  • MakeUniqueFName() : TemplateHelpers.h

- n -
  • NormalizeDbl() : 2DStruct.h

- r -
  • rctError : VideoSurvDll.idl
  • rctInfo : VideoSurvDll.idl
  • rctWarning : VideoSurvDll.idl
  • Round : 2DStruct.h

- s -
  • SaveSignature() : StreamHelpers.h
  • SaveVersion() : StreamHelpers.h
  • sdlFullAccess : VideoSurvDll.idl
  • sdlMinAccess : VideoSurvDll.idl
  • sdlNormalAccess : VideoSurvDll.idl
  • SECURITY_DEFAULT_LEVEL : VideoSurvDll.idl
  • SECURITY_USER_TYPE : VideoSurvDll.idl
  • sutGroup : VideoSurvDll.idl
  • sutUser : VideoSurvDll.idl

- t -
  • TRACE : ErrorHandlers.h
  • TraceX() : ErrorHandlers.h

- z -
  • Zero() : TemplateHelpers.h
Generated on Tue Dec 25 18:26:02 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

CChannelDisplay Member List

This is the complete list of members for CChannelDisplay, including all inherited members.
  • AddConnector(REFCLSID clsidConnectorClass, REFGUID guidDataType, ALIGN_TYPE Align, long nID=-1) [inline, protected]
  • AddControlCookie2AutoUnregister(DWORD dwCookie) [inline]
  • CLocAdvisor< CChannelDisplay >::Advise(IUnknown *pUnkCP) [inline]
  • CSingleAdvisor< CChannelDisplay, 1 >::Advise(IUnknown *pUnkCP) [inline]
  • CMultiAdvisor< CChannelDisplay, 0 >::Advise(IUnknown *pUnkCP) [inline]
  • AssignIStructureItem(IUnknown *pSrc) [inline]
  • CChannelDisplay() [inline]
  • CLocAdvisor(REFIID guidObject) [inline]
  • CMultiAdvisor(REFIID iid) [inline]
  • CLocAdvisor< CChannelDisplay >::CSingleAdvisor(REFIID iid) [inline]
  • CSingleAdvisor< CChannelDisplay, 1 >::CSingleAdvisor(REFIID iid) [inline]
  • CLocAdvisor< CChannelDisplay >::IsAdvised() [inline]
  • CSingleAdvisor< CChannelDisplay, 1 >::IsAdvised() [inline]
  • CMultiAdvisor< CChannelDisplay, 0 >::IsAdvised() [inline]
  • CMultiAdvisor< CChannelDisplay, 0 >::IsAdvised(IUnknown *pUnkCP) [inline]
  • Load(IStream *pIStream) [inline, protected]
  • LoadString(long nResID, string *ps) [inline]
  • LoadString(long nResID, BSTR *pbs) [inline]
  • LoadString(REFGUID guidObject, long nResID, string *ps) [inline]
  • LocInit(IUnknown *pIAppUnk) [inline]
  • LockObjectFunc() PURE [protected, virtual]
  • LocUninit() [inline]
  • m_arAutoUnregisterControlCookies [protected]
  • m_ardwCookie
  • m_aroConnectors [protected]
  • m_aroUnkCP
  • m_ClsID
  • CLocAdvisor< CChannelDisplay >::m_dwCookie
  • CSingleAdvisor< CChannelDisplay, 1 >::m_dwCookie
  • m_guidObject
  • CLocAdvisor< CChannelDisplay >::m_iid
  • CSingleAdvisor< CChannelDisplay, 1 >::m_iid
  • CMultiAdvisor< CChannelDisplay, 0 >::m_iid
  • m_nConnectorID [protected]
  • m_nObjectID
  • m_oApplication
  • m_oChannel [protected]
  • m_oContainerRegistrar [protected]
  • m_oLocManager
  • m_oLocStorage
  • m_oParent
  • CLocAdvisor< CChannelDisplay >::m_oUnkCP
  • CSingleAdvisor< CChannelDisplay, 1 >::m_oUnkCP
  • m_ptPos [protected]
  • m_rcBounds [protected]
  • OnAddConnector(IConnector *pIConnector) [inline, virtual]
  • IChannelObjectImpl< CChannelDisplay >::OnAddConnector(IConnector *pIConnector) [inline, virtual]
  • OnEraseBkgnd(UINT uMsg, WPARAM wParam, LPARAM lParam, BOOL &bHandled)
  • OnPaint(UINT uMsg, WPARAM wParam, LPARAM lParam, BOOL &bHandled)
  • OnRemoveConnector(IConnector *pIConnector) [inline, virtual]
  • IChannelObjectImpl< CChannelDisplay >::OnRemoveConnector(IConnector *pIConnector) [inline, virtual]
  • PostInitChannelObject() [inline]
  • RecalcCoordinates() [inline, protected]
  • RegisterCustomControls() [virtual]
  • IChannelObjectImpl< CChannelDisplay >::RegisterCustomControls() PURE [virtual]
  • RemoveConnector(long nID) [inline, protected]
  • RemoveConnector(IConnector *pIConnector) [inline, protected]
  • Save(IStream *pIStream) [inline, protected]
  • SILoad(IStream *pIStream) [inline]
  • SISave(IStream *pIStream) [inline]
  • STDMETHOD(InterfaceSupportsErrorInfo)(REFIID riid)
  • STDMETHOD(CreateChildWindow)(HWND hParentWnd, RECT rcWnd)
  • STDMETHOD(DestroyChildWindow)()
  • STDMETHOD(put_WindowRect)(RECT rcWnd)
  • STDMETHOD(Init)()
  • STDMETHOD(PostInit)()
  • STDMETHOD(get_SIName)(BSTR *pVal) [inline]
  • STDMETHOD(put_SIName)(BSTR newVal) [inline]
  • STDMETHOD(Load)(IStream *pStm)
  • STDMETHOD(Save)(IStream *pStm, BOOL fClearDirty)
  • STDMETHOD(IsDirty)() [inline]
  • STDMETHOD_(void, PreClose)()
  • STDMETHOD_(void, Close)()
  • CLocAdvisor< CChannelDisplay >::Unadvise() [inline]
  • CSingleAdvisor< CChannelDisplay, 1 >::Unadvise() [inline]
  • CMultiAdvisor< CChannelDisplay, 0 >::Unadvise() [inline]
  • CMultiAdvisor< CChannelDisplay, 0 >::Unadvise(IUnknown *pUnkCP) [inline]
  • UninitChannelObject() [inline]
  • UnlockObjectFunc() PURE [protected, virtual]
  • UnregisterCustomControls() [virtual]
  • IChannelObjectImpl< CChannelDisplay >::UnregisterCustomControls() PURE [virtual]
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

idlAVICOMPRESSOPTIONS Member List

This is the complete list of members for idlAVICOMPRESSOPTIONS, including all inherited members.
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IAVISource Member List

This is the complete list of members for IAVISource, including all inherited members.
  • AVIFileName([out, retval] BSTR *pVal)
  • AVIFileName([in] BSTR newVal)
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IAVITarget Member List

This is the complete list of members for IAVITarget, including all inherited members.
  • AVIFileNameBase([out, retval] BSTR *pVal)
  • AVIFileNameBase([in] BSTR newVal)
  • CompressOptions([out, retval] idlAVICOMPRESSOPTIONS *pVal)
  • CompressOptions([in] idlAVICOMPRESSOPTIONS newVal)
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IColorProcessingFilter Member List

This is the complete list of members for IColorProcessingFilter, including all inherited members.
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IChannelSwitcher Member List

This is the complete list of members for IChannelSwitcher, including all inherited members.
  • OutputConnectors([out, retval] UINT *nVal)
  • OutputConnectors([in] UINT newVal)
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

CChannelSwitcher Member List

This is the complete list of members for CChannelSwitcher, including all inherited members.
  • AddConnector(REFCLSID clsidConnectorClass, REFGUID guidDataType, ALIGN_TYPE Align, long nID=-1) [inline, protected]
  • AddControlCookie2AutoUnregister(DWORD dwCookie) [inline]
  • CLocAdvisor< CChannelSwitcher >::Advise(IUnknown *pUnkCP) [inline]
  • CSingleAdvisor< CChannelSwitcher, 1 >::Advise(IUnknown *pUnkCP) [inline]
  • CMultiAdvisor< CChannelSwitcher, 0 >::Advise(IUnknown *pUnkCP) [inline]
  • CMultiAdvisor< CChannelSwitcher, 1 >::Advise(IUnknown *pUnkCP) [inline]
  • AssignIStructureItem(IUnknown *pSrc) [inline]
  • CChannelSwitcher() [inline]
  • CLocAdvisor(REFIID guidObject) [inline]
  • CMultiAdvisor< CChannelSwitcher, 0 >::CMultiAdvisor(REFIID iid) [inline]
  • CMultiAdvisor< CChannelSwitcher, 1 >::CMultiAdvisor(REFIID iid) [inline]
  • CLocAdvisor< CChannelSwitcher >::CSingleAdvisor(REFIID iid) [inline]
  • CSingleAdvisor< CChannelSwitcher, 1 >::CSingleAdvisor(REFIID iid) [inline]
  • DeleteFreeConnector(REFCLSID clsidConnectorClass) [protected]
  • CLocAdvisor< CChannelSwitcher >::IsAdvised() [inline]
  • CSingleAdvisor< CChannelSwitcher, 1 >::IsAdvised() [inline]
  • CMultiAdvisor< CChannelSwitcher, 0 >::IsAdvised() [inline]
  • CMultiAdvisor< CChannelSwitcher, 0 >::IsAdvised(IUnknown *pUnkCP) [inline]
  • CMultiAdvisor< CChannelSwitcher, 1 >::IsAdvised() [inline]
  • CMultiAdvisor< CChannelSwitcher, 1 >::IsAdvised(IUnknown *pUnkCP) [inline]
  • Load(IStream *pIStream) [inline, protected]
  • LoadString(long nResID, string *ps) [inline]
  • LoadString(long nResID, BSTR *pbs) [inline]
  • LoadString(REFGUID guidObject, long nResID, string *ps) [inline]
  • LocInit(IUnknown *pIAppUnk) [inline]
  • LockObjectFunc() PURE [protected, virtual]
  • LocUninit() [inline]
  • m_arAutoUnregisterControlCookies [protected]
  • CMultiAdvisor< CChannelSwitcher, 0 >::m_ardwCookie
  • CMultiAdvisor< CChannelSwitcher, 1 >::m_ardwCookie
  • m_aroConnectors [protected]
  • CMultiAdvisor< CChannelSwitcher, 0 >::m_aroUnkCP
  • CMultiAdvisor< CChannelSwitcher, 1 >::m_aroUnkCP
  • m_ClsID
  • CLocAdvisor< CChannelSwitcher >::m_dwCookie
  • CSingleAdvisor< CChannelSwitcher, 1 >::m_dwCookie
  • m_guidObject
  • CLocAdvisor< CChannelSwitcher >::m_iid
  • CSingleAdvisor< CChannelSwitcher, 1 >::m_iid
  • CMultiAdvisor< CChannelSwitcher, 0 >::m_iid
  • CMultiAdvisor< CChannelSwitcher, 1 >::m_iid
  • m_nConnectorID [protected]
  • m_nObjectID
  • m_oApplication
  • m_oChannel [protected]
  • m_oContainerRegistrar [protected]
  • m_oLocManager
  • m_oLocStorage
  • m_oParent
  • m_oStoredGroupData [protected]
  • CLocAdvisor< CChannelSwitcher >::m_oUnkCP
  • CSingleAdvisor< CChannelSwitcher, 1 >::m_oUnkCP
  • m_ptPos [protected]
  • m_rcBounds [protected]
  • OnAddConnector(IConnector *pIConnector) [inline, virtual]
  • IChannelObjectImpl< CChannelSwitcher >::OnAddConnector(IConnector *pIConnector) [inline, virtual]
  • OnRemoveConnector(IConnector *pIConnector) [inline, virtual]
  • IChannelObjectImpl< CChannelSwitcher >::OnRemoveConnector(IConnector *pIConnector) [inline, virtual]
  • OutputConnectors([out, retval] UINT *nVal)
  • OutputConnectors([in] UINT newVal)
  • PostInitChannelObject() [inline]
  • RecalcCoordinates() [inline, protected]
  • RegisterCustomControls() [virtual]
  • IChannelObjectImpl< CChannelSwitcher >::RegisterCustomControls() PURE [virtual]
  • RemoveConnector(long nID) [inline, protected]
  • RemoveConnector(IConnector *pIConnector) [inline, protected]
  • Save(IStream *pIStream) [inline, protected]
  • SILoad(IStream *pIStream) [inline]
  • SISave(IStream *pIStream) [inline]
  • STDMETHOD(InterfaceSupportsErrorInfo)(REFIID riid)
  • STDMETHOD(get_OutputConnectors)(UINT *pVal)
  • STDMETHOD(put_OutputConnectors)(UINT newVal)
  • STDMETHOD(Init)()
  • STDMETHOD(PostInit)()
  • STDMETHOD(get_SIName)(BSTR *pVal) [inline]
  • STDMETHOD(put_SIName)(BSTR newVal) [inline]
  • STDMETHOD(Load)(IStream *pStm)
  • STDMETHOD(Save)(IStream *pStm, BOOL fClearDirty)
  • STDMETHOD(IsDirty)() [inline]
  • IStructureItemImpl::STDMETHOD(CanClose)() [inline]
  • STDMETHOD_(void, PreClose)()
  • STDMETHOD_(void, Close)()
  • CLocAdvisor< CChannelSwitcher >::Unadvise() [inline]
  • CSingleAdvisor< CChannelSwitcher, 1 >::Unadvise() [inline]
  • CMultiAdvisor< CChannelSwitcher, 0 >::Unadvise() [inline]
  • CMultiAdvisor< CChannelSwitcher, 0 >::Unadvise(IUnknown *pUnkCP) [inline]
  • CMultiAdvisor< CChannelSwitcher, 1 >::Unadvise() [inline]
  • CMultiAdvisor< CChannelSwitcher, 1 >::Unadvise(IUnknown *pUnkCP) [inline]
  • UninitChannelObject() [inline]
  • UnlockObjectFunc() PURE [protected, virtual]
  • UnregisterCustomControls() [virtual]
  • IChannelObjectImpl< CChannelSwitcher >::UnregisterCustomControls() PURE [virtual]
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

CChannelSwitcherPropPage Member List

This is the complete list of members for CChannelSwitcherPropPage, including all inherited members.
  • Advise(IUnknown *pUnkCP) [inline]
  • AssignIStructureItem(IUnknown *pSrc) [inline]
  • CChannelSwitcherPropPage() [inline]
  • CLocAdvisor(REFIID guidObject) [inline]
  • CSingleAdvisor(REFIID iid) [inline]
  • IsAdvised() [inline]
  • LoadString(long nResID, string *ps) [inline]
  • LoadString(long nResID, BSTR *pbs) [inline]
  • LoadString(REFGUID guidObject, long nResID, string *ps) [inline]
  • LocInit(IUnknown *pIAppUnk) [inline]
  • LockObjectFunc() PURE [protected, virtual]
  • LocUninit() [inline]
  • m_ClsID
  • m_dwCookie
  • m_guidObject
  • m_iid
  • m_nObjectID
  • m_oApplication
  • m_oLocManager
  • m_oLocStorage
  • m_oParent
  • m_oUnkCP
  • SILoad(IStream *pIStream) [inline]
  • SISave(IStream *pIStream) [inline]
  • STDMETHOD(get_SIName)(BSTR *pVal)
  • IStructureItemImpl::STDMETHOD(Init)() [inline]
  • IStructureItemImpl::STDMETHOD(CanClose)() [inline]
  • IStructureItemImpl::STDMETHOD(put_Application)(IApplication *pVal) [inline]
  • IStructureItemImpl::STDMETHOD(LoadItem)(IStorage *pIParentStorage, BOOL bGlobalWorkspace) [inline]
  • IStructureItemImpl::STDMETHOD(SaveItem)(IStorage *pIParentStorage, BOOL bGlobalWorkspace) [inline]
  • IStructureItemImpl::STDMETHOD_(void, Close)() [inline]
  • Unadvise() [inline]
  • UnlockObjectFunc() PURE [protected, virtual]
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

CPoint Member List

This is the complete list of members for CPoint, including all inherited members.
  • operator+(POINT &pt) [inline]
  • operator+(SIZE &sz) [inline]
  • operator-(POINT &pt) [inline]
  • operator-() const [inline]
  • operator-(SIZE &sz) [inline]
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

CSize Member List

This is the complete list of members for CSize, including all inherited members.
  • operator *(int nk) [inline]
  • operator/(int nk) [inline]
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

CRect Member List

This is the complete list of members for CRect, including all inherited members.
  • BottomRight() [inline]
  • CenterPoint() [inline]
  • Empty() [inline]
  • Height() [inline]
  • InflateRect(int dx, int dy) [inline]
  • IntersectRect(RECT &Rect) [inline]
  • IsEmpty() [inline]
  • Normalize() [inline]
  • operator+(POINT &pt) [inline]
  • operator+=(POINT &pt) [inline]
  • operator-(POINT &pt) [inline]
  • operator-=(POINT &pt) [inline]
  • PointIn(POINT pt) [inline]
  • TopLeft() [inline]
  • UnionRect(RECT &Rect) [inline]
  • Width() [inline]
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

CCircle Member List

This is the complete list of members for CCircle, including all inherited members.
  • GetExtent() [inline]
  • PointIn(POINT &pt) [inline]
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

CSingleAdvisor Member List

This is the complete list of members for CSingleAdvisor, including all inherited members.
  • Advise(IUnknown *pUnkCP) [inline]
  • CSingleAdvisor(REFIID iid) [inline]
  • IsAdvised() [inline]
  • m_dwCookie
  • m_iid
  • m_oUnkCP
  • Unadvise() [inline]
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

CMultiAdvisor Member List

This is the complete list of members for CMultiAdvisor, including all inherited members.
  • Advise(IUnknown *pUnkCP) [inline]
  • CMultiAdvisor(REFIID iid) [inline]
  • IsAdvised() [inline]
  • IsAdvised(IUnknown *pUnkCP) [inline]
  • m_ardwCookie
  • m_aroUnkCP
  • m_iid
  • Unadvise() [inline]
  • Unadvise(IUnknown *pUnkCP) [inline]
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

CLocAdvisor Member List

This is the complete list of members for CLocAdvisor, including all inherited members.
  • CLocAdvisor(REFIID guidObject) [inline]
  • LoadString(long nResID, string *ps) [inline]
  • LoadString(long nResID, BSTR *pbs) [inline]
  • LoadString(REFGUID guidObject, long nResID, string *ps) [inline]
  • LocInit(IUnknown *pIAppUnk) [inline]
  • LocUninit() [inline]
  • m_guidObject
  • m_oLocManager
  • m_oLocStorage
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

CLocHelper Member List

This is the complete list of members for CLocHelper, including all inherited members.
  • CLocHelper(REFIID guidObject) [inline]
  • LoadString(long nResID, string *ps) [inline]
  • LoadString(long nResID, BSTR *pbs) [inline]
  • LoadString(REFGUID guidObject, long nResID, string *ps) [inline]
  • LocInit(IUnknown *pIAppUnk) [inline]
  • LocUninit() [inline]
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

CLogHelper Member List

This is the complete list of members for CLogHelper, including all inherited members.
  • AddLogMessage(LM_RECTYPE lmrt, long nLocID) [inline]
  • AddLogMessage(LM_RECTYPE lmrt, LPCTSTR lpsz) [inline]
  • AddLogMessage(LM_RECTYPE lmrt, BSTR bsMess) [inline]
  • CLogHelper(TClass *pT) [inline]
  • LogInit(IUnknown *pIAppUnk, long nLocIDName) [inline]
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

CSecurityHelper Member List

This is the complete list of members for CSecurityHelper, including all inherited members.
  • CheckSecurityRights(long nPropID) [inline]
  • CheckSecurityRights(IUnknown *pSecItem, long nPropID) [inline]
  • SecurityInit(IUnknown *pIAppUnk, IUnknown *pSecItem) [inline]
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

CDataObjects Member List

This is the complete list of members for CDataObjects, including all inherited members.
  • CDataObjects(IGroupData *pIGroupData) [inline]
  • CDataObjects(CDataObjects< I2 > &Items) [inline]
  • clear() [inline]
  • Init(IGroupData *pIGroupData) [inline]
  • operator=(CDataObjects< I2 > &Items) [inline]
  • operator[](int n) [inline]
  • size() [inline]
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

CConnectInfo Member List

This is the complete list of members for CConnectInfo, including all inherited members.
  • CConnectInfo() [inline]
  • CConnectInfo(long _nSourceObjectID, long _nOutConnectorID, long _nTargetObjectID, long _nInConnectorID) [inline]
  • CConnectInfo(CONNECT_INFO &ci) [inline]
  • nInConnectorID
  • nOutConnectorID
  • nSourceObjectID
  • nTargetObjectID
  • operator=(CONNECT_INFO &ci) [inline]
  • operator==(CONNECT_INFO &ci) [inline]
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

CConnectionPairs Member List

This is the complete list of members for CConnectionPairs, including all inherited members.
  • CConnectionPairs() [inline]
  • CConnectionPairs(IUnknown *pChannelUnk) [inline]
  • clear() [inline]
  • Init(IUnknown *pChannelUnk) [inline]
  • operator[](int n) [inline]
  • size() [inline]
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IChannelObjectImpl Member List

This is the complete list of members for IChannelObjectImpl, including all inherited members.
  • AddConnector(REFCLSID clsidConnectorClass, REFGUID guidDataType, ALIGN_TYPE Align, long nID=-1) [inline, protected]
  • AddControlCookie2AutoUnregister(DWORD dwCookie) [inline]
  • Load(IStream *pIStream) [inline, protected]
  • m_arAutoUnregisterControlCookies [protected]
  • m_aroConnectors [protected]
  • m_nConnectorID [protected]
  • m_oChannel [protected]
  • m_oContainerRegistrar [protected]
  • m_ptPos [protected]
  • m_rcBounds [protected]
  • OnAddConnector(IConnector *pIConnector) [inline, protected, virtual]
  • OnRemoveConnector(IConnector *pIConnector) [inline, protected, virtual]
  • PostInitChannelObject() [inline]
  • RecalcCoordinates() [inline, protected]
  • RegisterCustomControls() PURE [virtual]
  • RemoveConnector(long nID) [inline, protected]
  • RemoveConnector(IConnector *pIConnector) [inline, protected]
  • Save(IStream *pIStream) [inline, protected]
  • UninitChannelObject() [inline]
  • UnregisterCustomControls() PURE [virtual]
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

CChannelConnectors Member List

This is the complete list of members for CChannelConnectors, including all inherited members.
  • clear() [inline]
  • GetConnector(long nID, IConnector **pIConnector) [inline]
  • Init(IUnknown *pChannelObjUnk, BOOL bInputConnector) [inline]
  • IsValidID(long nID) [inline]
  • ptOffset(long nID) [inline]
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

ICloneObjectImpl Member List

This is the complete list of members for ICloneObjectImpl, including all inherited members.
  • ICloneObjectImpl(TClass *pObj) [inline]
  • STDMETHOD(get_CloneID)(CLSID *pVal) [inline]
  • STDMETHOD(IsEqual)(IUnknown *pUnk, BOOL *bEqual) [inline]
  • STDMETHOD(Clone)(REFIID iid, void **pClone) [inline]
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IDataObjectMinImpl Member List

This is the complete list of members for IDataObjectMinImpl, including all inherited members.
  • STDMETHOD(GetData)(FORMATETC *pformatetcIn, STGMEDIUM *pmedium) [inline]
  • STDMETHOD(GetDataHere)(FORMATETC *, STGMEDIUM *) [inline]
  • STDMETHOD(QueryGetData)(FORMATETC *) [inline]
  • STDMETHOD(GetCanonicalFormatEtc)(FORMATETC *,FORMATETC *) [inline]
  • STDMETHOD(SetData)(FORMATETC *, STGMEDIUM *, BOOL) [inline]
  • STDMETHOD(EnumFormatEtc)(DWORD, IEnumFORMATETC **) [inline]
  • STDMETHOD(DAdvise)(FORMATETC *pformatetc, DWORD advf, IAdviseSink *pAdvSink, DWORD *pdwConnection) [inline]
  • STDMETHOD(DUnadvise)(DWORD dwConnection) [inline]
  • STDMETHOD(EnumDAdvise)(IEnumSTATDATA **ppenumAdvise) [inline]
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

CAutoClassLocker Member List

This is the complete list of members for CAutoClassLocker, including all inherited members.
  • CAutoClassLocker(TClass *pClass, BOOL bLock=TRUE) [inline]
  • Lock() [inline]
  • Unlock() [inline]
  • ~CAutoClassLocker() [inline]
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

CAutoCSLocker Member List

This is the complete list of members for CAutoCSLocker, including all inherited members.
  • CAutoCSLocker(CComAutoCriticalSection *pCS, BOOL bLock=TRUE) [inline]
  • Lock() [inline]
  • Unlock() [inline]
  • ~CAutoCSLocker() [inline]
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IStructureItemImpl Member List

This is the complete list of members for IStructureItemImpl, including all inherited members.
  • AssignIStructureItem(IUnknown *pSrc) [inline]
  • LockObjectFunc() PURE [protected, virtual]
  • m_ClsID
  • m_nObjectID
  • m_oApplication
  • m_oParent
  • SILoad(IStream *pIStream) [inline]
  • SISave(IStream *pIStream) [inline]
  • STDMETHOD(Init)() [inline]
  • STDMETHOD(PostInit)() [inline]
  • STDMETHOD(CanClose)() [inline]
  • STDMETHOD(get_ClsID)(CLSID *pVal) [inline]
  • STDMETHOD(get_Application)(IApplication **pVal) [inline]
  • STDMETHOD(put_Application)(IApplication *pVal) [inline]
  • STDMETHOD(get_Parent)(IStructureItem **pVal) [inline]
  • STDMETHOD(put_Parent)(IStructureItem *pVal) [inline]
  • STDMETHOD(get_SIName)(BSTR *pVal) [inline]
  • STDMETHOD(put_SIName)(BSTR newVal) [inline]
  • STDMETHOD(get_SIDescription)(BSTR *pVal) [inline]
  • STDMETHOD(put_SIDescription)(BSTR newVal) [inline]
  • STDMETHOD(get_ObjectID)(long *pVal) [inline]
  • STDMETHOD(put_ObjectID)(long newVal) [inline]
  • STDMETHOD(LoadItem)(IStorage *pIParentStorage, BOOL bGlobalWorkspace) [inline]
  • STDMETHOD(SaveItem)(IStorage *pIParentStorage, BOOL bGlobalWorkspace) [inline]
  • STDMETHOD_(void, PreClose)() [inline]
  • STDMETHOD_(void, Close)() [inline]
  • UnlockObjectFunc() PURE [protected, virtual]
Generated on Tue Dec 25 18:26:00 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IStructureLevelImpl Member List

This is the complete list of members for IStructureLevelImpl, including all inherited members.
  • AddObjectToLevel(IUnknown *pIObjUnk, long *pnObjectID=NULL, BOOL bInit=FALSE) [inline]
  • AfterAddObjectToLevelVrt(IStructureItem *pIObject) [inline, virtual]
  • AfterRemoveObjectFromLevelVrt() [inline, virtual]
  • AssignIStructureItem(IUnknown *pSrc) [inline]
  • BeforeRemoveObjectFromLevelVrt(IStructureItem *pIObject) [inline, virtual]
  • DoPostUninitStructureItem(IStructureItem *pIObject) [inline, virtual]
  • DoPreInitStructureItem(IStructureItem *pIObject) [inline, virtual]
  • GenerateNewObjectID() [inline]
  • LoadItemsFromWorkspace(IStorage *pIStorage, BOOL bGlobalWorkspace) [inline]
  • LockObjectFunc() PURE [protected, virtual]
  • m_arSubItems [protected]
  • m_ClsID
  • m_nLastObjectsID [protected]
  • m_nObjectID
  • m_oApplication
  • m_oParent
  • RemoveAllObjectsFromLevel(BOOL bDoUninit=FALSE) [inline]
  • RemoveObjectFromLevel(IUnknown *pObjectUnk) [inline]
  • SaveItemsToWorkspace(IStorage *pIStorage, BOOL bGlobalWorkspace) [inline]
  • SILoad(IStream *pIStream) [inline]
  • SISave(IStream *pIStream) [inline]
  • SLLoad(IStream *pIStream, BOOL bRecursed=TRUE) [inline]
  • SLSave(IStream *pIStream, BOOL bRecursed=TRUE) [inline]
  • STDMETHOD(Init)() [inline]
  • STDMETHOD(PostInit)() [inline]
  • STDMETHOD(CanClose)() [inline]
  • STDMETHOD(get_SubItems)(IEnumStructureItem **ppEnum) [inline]
  • STDMETHOD(get_SubItemByClsID)(REFIID clsid, IEnumStructureItem **ppEnum) [inline]
  • STDMETHOD(get_SubItemByID)(long ObjectID, IStructureItem **pVal) [inline]
  • IStructureItemImpl::STDMETHOD(put_Application)(IApplication *pVal) [inline]
  • IStructureItemImpl::STDMETHOD(LoadItem)(IStorage *pIParentStorage, BOOL bGlobalWorkspace) [inline]
  • IStructureItemImpl::STDMETHOD(SaveItem)(IStorage *pIParentStorage, BOOL bGlobalWorkspace) [inline]
  • STDMETHOD_(void, PreClose)() [inline]
  • STDMETHOD_(void, Close)() [inline]
  • UnlockObjectFunc() PURE [protected, virtual]
Generated on Tue Dec 25 18:26:00 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

CRegistryList Member List

This is the complete list of members for CRegistryList, including all inherited members.
  • Init(LPCTSTR szGroupKey, HKEY hRootKey=HKEY_CLASSES_ROOT) [inline]
  • operator[](int n) [inline]
  • RemoveAll() [inline]
  • size() [inline]
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

CStructureItems Member List

This is the complete list of members for CStructureItems, including all inherited members.
  • clear() [inline]
  • CStructureItems(IUnknown *pLevelUnk) [inline]
  • CStructureItems(CStructureItems< I2 > &Items) [inline]
  • Init(IUnknown *pLevelUnk) [inline]
  • operator=(CStructureItems< I2 > &Items) [inline]
  • operator[](int n) [inline]
  • size() [inline]
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IChildWindowImpl Member List

This is the complete list of members for IChildWindowImpl, including all inherited members.
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IChildWindow Member List

This is the complete list of members for IChildWindow, including all inherited members.
  • CreateChildWindow([in] HWND hParentWnd,[in] RECT rcWnd)
  • DestroyChildWindow()
  • FloatingState([out, retval] BOOL *pVal)
  • FloatingState([in] BOOL newVal)
  • WindowRect([out, retval] RECT *pVal)
  • WindowRect([in] RECT newVal)
  • WindowVisibled([out, retval] BOOL *pVal)
  • WindowVisibled([in] BOOL newVal)
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

_IChildWindowEvents Member List

This is the complete list of members for _IChildWindowEvents, including all inherited members.
  • AfterChildWindowDestroy([in] IChildWindow *pIChildWindow)
  • BeforeChildWindowDestroy([in] IChildWindow *pIChildWindow)
  • OnChildWindowCreated([in] IChildWindow *pIChildWindow)
  • OnChildWindowFloatingStateChanged([in] IChildWindow *pIChildWindow,[in] BOOL Float)
  • OnChildWindowRectChanged([in] IChildWindow *pIChildWindow,[in] RECT WindowRect)
  • OnChildWindowVisibilityChanged([in] IChildWindow *pIChildWindow,[in] BOOL Visibled)
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IChildWindowRegistrar Member List

This is the complete list of members for IChildWindowRegistrar, including all inherited members.
  • RegisterChildWindow([in] IUnknown *pChildWindowUnk)
  • UnregisterChildWindow([in] IUnknown *pChildWindowUnk)
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IChildWindowManager Member List

This is the complete list of members for IChildWindowManager, including all inherited members.
  • CoveringForm([out, retval] SIZE *pVal)
  • CoveringForm([in] SIZE newVal)
  • FloatEnabled([out, retval] BOOL *pVal)
  • FloatEnabled([in] BOOL newVal)
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

_IChildWindowManagerEvents Member List

This is the complete list of members for _IChildWindowManagerEvents, including all inherited members.
  • OnCoveringFormChanged([in] SIZE szNewCoveringForm)
  • OnFloatStateChanged([in] BOOL bNewState)
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IApplication Member List

This is the complete list of members for IApplication, including all inherited members.
  • AppWindow([out, retval] IAppWindow **pVal)
  • CanCloseApplication()
  • CloseApplication([in] BOOL bSaveState)
  • IsRunning()
  • LoadWorkspace([in] BSTR bsFName)
  • Run([in] long hInstance,[in] long hPrevInstance,[in] BSTR bsCmdLine,[in] int nCmdShow)
  • SaveWorkspace([in] BSTR bsFName)
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

_IApplicationStateEvents Member List

This is the complete list of members for _IApplicationStateEvents, including all inherited members.
  • OnAppLoadComplete()
  • OnGUIReady()
  • OnInitComplete()
  • OnShowAppWindow()
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IAppWindow Member List

This is the complete list of members for IAppWindow, including all inherited members.
  • FullScreen([out, retval] BOOL *pVal)
  • FullScreen([in] BOOL newVal)
  • hWnd([out, retval] HWND *pVal)
  • RegisterMainBarButton([in] long nTopOffsetFactor,[in] BSTR bsTitle,[in] HBITMAP hBmp,[in] IMainBarNotifyListener *pClickListener,[out] DWORD *pdwCookie)
  • SetMainBarButtonTitle([in] DWORD dwCookie,[in] BSTR bsTitle)
  • UnregisterMainBarButton([in] DWORD dwCookie)
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

_IAppWindowEvents Member List

This is the complete list of members for _IAppWindowEvents, including all inherited members.
  • OnScreenModeChanged([in] BOOL bFullScreen)
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IChannelDirector Member List

This is the complete list of members for IChannelDirector, including all inherited members.
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IStructureItem Member List

This is the complete list of members for IStructureItem, including all inherited members.
  • Application([out, retval] IApplication **pVal)
  • Application([in] IApplication *newVal)
  • CanClose()
  • Close()
  • ClsID([out, retval] CLSID *pVal)
  • Init()
  • LoadItem([in] IStorage *pIParentStorage,[in] BOOL bGlobalWorkspace)
  • ObjectID([out, retval] long *pVal)
  • ObjectID([in] long newVal)
  • Parent([out, retval] IStructureItem **pVal)
  • Parent([in] IStructureItem *newVal)
  • PostInit()
  • PreClose()
  • SaveItem([in] IStorage *pIParentStorage,[in] BOOL bGlobalWorkspace)
  • SIDescription([out, retval] BSTR *pVal)
  • SIDescription([in] BSTR newVal)
  • SIName([out, retval] BSTR *pVal)
  • SIName([in] BSTR newVal)
Generated on Tue Dec 25 18:26:00 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

_IStructureItemEvents Member List

This is the complete list of members for _IStructureItemEvents, including all inherited members.
  • OnStructureItemDescriptionChanged([in] IStructureItem *pIStructureItem)
  • OnStructureItemNameChanged([in] IStructureItem *pIStructureItem)
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IEnumStructureItem Member List

This is the complete list of members for IEnumStructureItem, including all inherited members.
  • Clone([out] IEnumStructureItem **ppEnum)
  • Next([in] ULONG celt,[out, size_is(celt), length_is(*pCeltFetched)] IStructureItem **rgVar,[out] ULONG *pCeltFetched)
  • Reset()
  • Skip([in] ULONG celt)
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IStructureLevel Member List

This is the complete list of members for IStructureLevel, including all inherited members.
  • SubItemByClsID([in] REFIID clsid,[out] IEnumStructureItem **ppEnum)
  • SubItemByID([in] long ObjectID,[out, retval] IStructureItem **pVal)
  • SubItems([out] IEnumStructureItem **ppEnum)
Generated on Tue Dec 25 18:26:00 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

_IStructureLevelEvents Member List

This is the complete list of members for _IStructureLevelEvents, including all inherited members.
  • AfterAddItemToLevel([in] IStructureItem *pIStructureItem)
  • AfterRemoveItemFromLevel()
  • BeforeRemoveItemFromLevel([in] IStructureItem *pIStructureItem)
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IChannelManager Member List

This is the complete list of members for IChannelManager, including all inherited members.
  • CreateNewChannel([out, retval] IChannel **Channel)
  • EraseChannel([in] IChannel *pIChannel)
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IEnumLanguageCodes Member List

This is the complete list of members for IEnumLanguageCodes, including all inherited members.
  • Clone([out] IEnumLanguageCodes **ppEnum)
  • Next([in] ULONG celt,[out, size_is(celt), length_is(*pCeltFetched)] BSTR *rgVar,[out] ULONG *pCeltFetched)
  • Reset()
  • Skip([in] ULONG celt)
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

ILocalizationManager Member List

This is the complete list of members for ILocalizationManager, including all inherited members.
  • AddLanguage([in] BSTR bsLangCode,[in] BSTR bsLangName)
  • GetLocalization([out] BSTR *pLanguage)
  • GetStorage([out] ILocalizationStorage **pStorage)
  • LanguageName([in] BSTR bsLangCode,[out, retval] BSTR *pVal)
  • LanguageName([in] BSTR bsLangCode,[in] BSTR newVal)
  • Languages([out, retval] IEnumLanguageCodes **pVal)
  • RemoveLanguage([in] BSTR bsLangCode)
  • SetLocalization([in] BSTR Language)
Generated on Tue Dec 25 18:25:59 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

_ILocalizationEvents Member List

This is the complete list of members for _ILocalizationEvents, including all inherited members.
  • OnLanguageChanged()
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

ILocalizationStorage Member List

This is the complete list of members for ILocalizationStorage, including all inherited members.
  • LoadString([in] REFGUID refguid,[in] long resId,[out, retval] BSTR *pVal)
Generated on Tue Dec 25 18:25:59 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

ILocalizationSetup Member List

This is the complete list of members for ILocalizationSetup, including all inherited members.
  • RebuildStorageForLanguage([in] BSTR bsLang)
Generated on Tue Dec 25 18:25:59 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

LM_RECORD Member List

This is the complete list of members for LM_RECORD, including all inherited members.
  • bsExciter
  • bsText
  • bsUser
  • nRecType
  • tTime
Generated on Tue Dec 25 18:26:01 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IEnumLogRecords Member List

This is the complete list of members for IEnumLogRecords, including all inherited members.
  • Clone([out] IEnumLogRecords **ppEnum)
  • Next([in] ULONG celt,[out, size_is(celt), length_is(*pCeltFetched)] LM_RECORD *rgVar,[out] ULONG *pCeltFetched)
  • Reset()
  • Skip([in] ULONG celt)
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

ILogManager Member List

This is the complete list of members for ILogManager, including all inherited members.
  • AllRecords([out, retval] IEnumLogRecords **ppEnum)
  • InsertRecord([in] LM_RECORD *pRecord)
  • ShowLogWindow([in] HWND hOwner)
Generated on Tue Dec 25 18:25:59 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

ILogManagerClient Member List

This is the complete list of members for ILogManagerClient, including all inherited members.
  • EnableLoging([in] BOOL bEnable)
  • LogManager([out, retval] ILogManager **ppVal)
Generated on Tue Dec 25 18:25:59 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IDriverManager Member List

This is the complete list of members for IDriverManager, including all inherited members.
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IChannel Member List

This is the complete list of members for IChannel, including all inherited members.
  • TransferMode([out, retval] CHANNEL_MODE *pVal)
  • TransferMode([in] CHANNEL_MODE newVal)
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

_IChannelEvents Member List

This is the complete list of members for _IChannelEvents, including all inherited members.
  • OnTransferModeChanged([in] CHANNEL_MODE newMode)
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

CONNECT_INFO Member List

This is the complete list of members for CONNECT_INFO, including all inherited members.
  • nInConnectorID
  • nOutConnectorID
  • nSourceObjectID
  • nTargetObjectID
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IEnumConnectInfo Member List

This is the complete list of members for IEnumConnectInfo, including all inherited members.
  • Clone([out] IEnumConnectInfo **ppEnum)
  • Next([in] ULONG celt,[out, size_is(celt), length_is(*pCeltFetched)] CONNECT_INFO *rgVar,[out] ULONG *pCeltFetched)
  • Reset()
  • Skip([in] ULONG celt)
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IChannelStructure Member List

This is the complete list of members for IChannelStructure, including all inherited members.
  • AddObjectToChannel([in] IUnknown *ObjectUnk,[out] long *ObjectID)
  • ConnectionPairs([out, retval] IEnumConnectInfo **ppEnum)
  • ConnectObjects([in] CONNECT_INFO *pci)
  • ContainerRegistrar([out, retval] IChannelContainerRegistrar **pVal)
  • DisconnectObjects([in] CONNECT_INFO *pci)
  • RemoveObjectFromChannel([in] IUnknown *pObjectUnk)
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IChannelContainerRegistrar Member List

This is the complete list of members for IChannelContainerRegistrar, including all inherited members.
  • RegisterCustomControl([in] BSTR sProgID,[in] long nWidth,[in] long nHeight,[in] REFIID iid,[out] IUnknown **ppCtrlUnk,[out] DWORD *pdwCookie)
  • UnregisterCustomControl([in] DWORD dwCookie)
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IChannelContainer Member List

This is the complete list of members for IChannelContainer, including all inherited members.
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IEnumConnectors Member List

This is the complete list of members for IEnumConnectors, including all inherited members.
  • Clone([out] IEnumConnectors **ppEnum)
  • Next([in] ULONG celt,[out, size_is(celt), length_is(*pCeltFetched)] IConnector **rgVar,[out] ULONG *pCeltFetched)
  • Reset()
  • Skip([in] ULONG celt)
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IChannelObject Member List

This is the complete list of members for IChannelObject, including all inherited members.
  • Channel([out, retval] IChannel **pVal)
  • Channel([in] IChannel *newVal)
  • InputConnectors([out, retval] IEnumConnectors **ppEnum)
  • OutputConnectors([out, retval] IEnumConnectors **ppEnum)
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

GCO_HT_INFO Member List

This is the complete list of members for GCO_HT_INFO, including all inherited members.
  • dwFlags
  • htCode
  • nConnectorID
  • nObjectID
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IGraphicsChannelObject Member List

This is the complete list of members for IGraphicsChannelObject, including all inherited members.
  • DrawChannelItem([in] HDC hDC,[in] long nXShift,[in] long nYShift)
  • GetBoundsRect([out] RECT *prcBounds)
  • HitTest([in] POINT pt,[out] GCO_HT_INFO *pHitTestInfo)
  • Position([out, retval] POINT *pVal)
  • Position([in] POINT newVal)
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

_IGraphicsChannelObject Member List

This is the complete list of members for _IGraphicsChannelObject, including all inherited members.
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IChannelData Member List

This is the complete list of members for IChannelData, including all inherited members.
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IImageData Member List

This is the complete list of members for IImageData, including all inherited members.
  • BPL([out, retval] long *pVal)
  • BPL([in] long newVal)
  • BPP([out, retval] long *pVal)
  • BPP([in] long newVal)
  • Height([out, retval] long *pVal)
  • Height([in] long newVal)
  • LockBuffer([out] void **ppBuffer)
  • UnlockBuffer()
  • Width([out, retval] long *pVal)
  • Width([in] long newVal)
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IEnumChannelData Member List

This is the complete list of members for IEnumChannelData, including all inherited members.
  • Clone([out] IEnumChannelData **ppEnum)
  • Next([in] ULONG celt,[out, size_is(celt), length_is(*pCeltFetched)] IChannelData **rgVar,[out] ULONG *pCeltFetched)
  • Reset()
  • Skip([in] ULONG celt)
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IGroupData Member List

This is the complete list of members for IGroupData, including all inherited members.
  • AddData([in] IChannelData *Data)
  • GetDataEnum([out] IEnumChannelData **ppEnum)
  • RemoveAllData()
  • RemoveData([in] IChannelData *Data)
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

ICustomControlsPopupWindow Member List

This is the complete list of members for ICustomControlsPopupWindow, including all inherited members.
  • RegisterCustomControl([in] BSTR sProgID,[in] long nWidth,[in] long nHeight,[in] REFIID iid,[out] IUnknown **ppCtrlUnk,[out] DWORD *pdwCookie)
  • UnregisterCustomControl([in] DWORD dwCookie)
  • UpdateWindowPos()
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IMainBarNotifyListener Member List

This is the complete list of members for IMainBarNotifyListener, including all inherited members.
  • OnMainBarButtonClicked([in] DWORD dwCookie)
Generated on Tue Dec 25 18:25:59 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IMainBar Member List

This is the complete list of members for IMainBar, including all inherited members.
  • RegisterMainBarButton([in] long nTopOffsetFactor,[in] BSTR bsTitle,[in] HBITMAP hBmp,[in] IMainBarNotifyListener *pClickListener,[out] DWORD *pdwCookie)
  • SetMainBarButtonTitle([in] DWORD dwCookie,[in] BSTR bsTitle)
  • UnregisterMainBarButton([in] DWORD dwCookie)
Generated on Tue Dec 25 18:25:59 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IAppConfigDlg Member List

This is the complete list of members for IAppConfigDlg, including all inherited members.
  • DoConfig([in] IApplication *pApplocation)
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IConnector Member List

This is the complete list of members for IConnector, including all inherited members.
  • Align([out, retval] ALIGN_TYPE *pVal)
  • Align([in] ALIGN_TYPE newVal)
  • ClassType([out, retval] CLSID *pVal)
  • Connect([in] IConnector *pIConnector)
  • DataType([out, retval] GUID *pVal)
  • DataType([in] REFGUID newVal)
  • Disconnect()
  • ID([out, retval] long *pVal)
  • ID([in] long newVal)
  • IsConnected()
  • IsConnectorInput()
  • Offset([out, retval] POINT *pVal)
  • Offset([in] POINT newVal)
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

_IConnectorEvents Member List

This is the complete list of members for _IConnectorEvents, including all inherited members.
  • OnAlignChanged([in] IConnector *pIConnector,[in] ALIGN_TYPE newVal)
  • OnConnected([in] IConnector *pIConnector)
  • OnDisconnected([in] IConnector *pIConnector)
  • OnOffsetChanged([in] IConnector *pIConnector,[in] POINT newVal)
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IVideoInputConnector Member List

This is the complete list of members for IVideoInputConnector, including all inherited members.
Generated on Tue Dec 25 18:26:00 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IVideoInputConnectorInternal Member List

This is the complete list of members for IVideoInputConnectorInternal, including all inherited members.
Generated on Tue Dec 25 18:26:01 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

_IVideoInputConnectorEvents Member List

This is the complete list of members for _IVideoInputConnectorEvents, including all inherited members.
  • OnDataReady([in] IVideoInputConnector *pIConnector)
  • OnDataReceived([in] IVideoInputConnector *pIConnector)
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IVideoOutputConnector Member List

This is the complete list of members for IVideoOutputConnector, including all inherited members.
Generated on Tue Dec 25 18:26:01 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IVideoOutputConnectorInternal Member List

This is the complete list of members for IVideoOutputConnectorInternal, including all inherited members.
Generated on Tue Dec 25 18:26:01 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

_IVideoOutputConnectorEvents Member List

This is the complete list of members for _IVideoOutputConnectorEvents, including all inherited members.
  • OnQueryData([in] IVideoOutputConnector *pIConnector)
  • OnSendData([in] IVideoOutputConnector *pIConnector)
Generated on Tue Dec 25 18:25:56 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

ICloneObject Member List

This is the complete list of members for ICloneObject, including all inherited members.
  • Assign([in] IUnknown *pSourseObj)
  • AssignPart([in] REFIID riid,[in] IUnknown *pSource)
  • Clone([in] REFIID riid,[out, iid_is(riid)] void **pClone)
  • CloneID([out, retval] CLSID *pVal)
  • IsEqual([in] IUnknown *pUnk,[out, retval] BOOL *bEqual)
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

ISecurityUser Member List

This is the complete list of members for ISecurityUser, including all inherited members.
Generated on Tue Dec 25 18:26:00 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IEnumSecurityUsers Member List

This is the complete list of members for IEnumSecurityUsers, including all inherited members.
  • Clone([out] IEnumSecurityUsers **ppEnum)
  • Next([in] ULONG celt,[out, size_is(celt), length_is(*pCeltFetched)] ISecurityUser **rgVar,[out] ULONG *pCeltFetched)
  • Reset()
  • Skip([in] ULONG celt)
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

ISecurityGroup Member List

This is the complete list of members for ISecurityGroup, including all inherited members.
Generated on Tue Dec 25 18:25:59 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

ISecurityManager Member List

This is the complete list of members for ISecurityManager, including all inherited members.
Generated on Tue Dec 25 18:26:00 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IEnumBSTR Member List

This is the complete list of members for IEnumBSTR, including all inherited members.
  • Clone([out] IEnumBSTR **ppEnum)
  • Next([in] ULONG celt,[out, size_is(celt), length_is(*pCeltFetched)] BSTR *bsVar,[out] ULONG *pCeltFetched)
  • Reset()
  • Skip([in] ULONG celt)
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IEnumLONG Member List

This is the complete list of members for IEnumLONG, including all inherited members.
  • Clone([out] IEnumLONG **ppEnum)
  • Next([in] ULONG celt,[out, size_is(celt), length_is(*pCeltFetched)] long *nVar,[out] ULONG *pCeltFetched)
  • Reset()
  • Skip([in] ULONG celt)
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

ISecurityItem Member List

This is the complete list of members for ISecurityItem, including all inherited members.
Generated on Tue Dec 25 18:25:59 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IColorSettings Member List

This is the complete list of members for IColorSettings, including all inherited members.
  • Brightness([out, retval] double *pVal)
  • Brightness([in] double newVal)
  • Contrast([out, retval] double *pVal)
  • Contrast([in] double newVal)
  • Hue([out, retval] double *pVal)
  • Hue([in] double newVal)
  • Saturation([out, retval] double *pVal)
  • Saturation([in] double newVal)
Generated on Tue Dec 25 18:25:58 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

IAppPropertySheet Member List

This is the complete list of members for IAppPropertySheet, including all inherited members.
  • AddObject([in] IUnknown *pObjectUnk)
  • DoModal([in] IApplication *pIApplication)
Generated on Tue Dec 25 18:25:57 2001 for VideoSurveillanceSystem by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001